
<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" />
<meta content="width=device-width, initial-scale=1.0, user-scalable=no" name="viewport">
<meta name="google-site-verification" content="yFaDpIXoz-j5sCQSr6YC6Y8hdsu-3ea-T93cMXASqIU" />
<title>Mack High stages Our Town | Mad River Union</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://madriverunion.com/xmlrpc.php" />
<!--[if lt IE 9]>
<script src="https://madriverunion.com/wp-content/themes/mru-focus/assets/js/html5.js" type="text/javascript"></script>
<![endif]-->
<link rel='dns-prefetch' href='//code.tinypass.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Mad River Union &raquo; Feed" href="https://madriverunion.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mad River Union &raquo; Comments Feed" href="https://madriverunion.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mad River Union &raquo; Mack High stages Our Town Comments Feed" href="https://madriverunion.com/mack-high-stages-our-town/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/madriverunion.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.1.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='tp-sidebar-login-css'  href='https://madriverunion.com/wp-content/plugins/tt-sidebar-login-widget/assets/css/tt-sidebar-login.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://madriverunion.com/wp-includes/css/dist/block-library/style.min.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='ditty-news-ticker-font-css'  href='https://madriverunion.com/wp-content/plugins/ditty-news-ticker/assets/fontastic/styles.css?ver=1546044261' type='text/css' media='all' />
<link rel='stylesheet' id='ditty-news-ticker-css'  href='https://madriverunion.com/wp-content/plugins/ditty-news-ticker/assets/css/style.css?ver=1546044261' type='text/css' media='all' />
<link rel='stylesheet' id='gabfire-widget-css-css'  href='https://madriverunion.com/wp-content/plugins/gabfire-widget-pack/css/style.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='hsa-front-css'  href='https://madriverunion.com/wp-content/plugins/horizontal-scrolling-announcement/css/hsa_front.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='sb_instagram_styles-css'  href='https://madriverunion.com/wp-content/plugins/instagram-feed/css/sb-instagram.min.css?ver=1.11.2' type='text/css' media='all' />
<link rel='stylesheet' id='sb-font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='sidebar-login-css'  href='https://madriverunion.com/wp-content/plugins/sidebar-login/assets/css/sidebar-login.css?ver=2.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='dw_focus_template-css'  href='https://madriverunion.com/wp-content/themes/mru-focus/assets/css/template.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='dw_focus_responsive-css'  href='https://madriverunion.com/wp-content/themes/mru-focus/assets/css/responsive.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='style-css'  href='https://madriverunion.com/wp-content/themes/mru-focus/style.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='print-style-css'  href='https://madriverunion.com/wp-content/themes/mru-focus/assets/css/print.css?ver=5.1.1' type='text/css' media='print' />
<link rel='stylesheet' id='dw-focus-qa-css'  href='https://madriverunion.com/wp-content/themes/mru-focus/dwqa-templates/style.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='evcal_google_fonts-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400%2C300%7COpen+Sans%3A400%2C300&#038;ver=5.1.1' type='text/css' media='screen' />
<link rel='stylesheet' id='evcal_cal_default-css'  href='https://madriverunion.com/wp-content/plugins/eventON/assets/css/eventon_styles.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='evo_font_icons-css'  href='https://madriverunion.com/wp-content/plugins/eventON/assets/fonts/font-awesome.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='evo_fc_styles-css'  href='https://madriverunion.com/wp-content/plugins/eventon-full-cal/assets/fc_styles.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://madriverunion.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://madriverunion.com/wp-content/plugins/jetpack/css/jetpack.css?ver=7.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='ws-plugin--s2member-css'  href='https://madriverunion.com/wp-content/plugins/s2member/s2member-o.php?ws_plugin__s2member_css=1&#038;qcABC=1&#038;ver=170722-170722-253714573' type='text/css' media='all' />
<script type='text/javascript' src='https://code.tinypass.com/tpl/d1/tpm.js?ver=5.1.1'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/plugins/sidebar-login/assets/js/jquery.blockUI.min.js?ver=2.70'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sidebar_login_params = {"ajax_url":"https:\/\/madriverunion.com\/wp-admin\/admin-ajax.php","force_ssl_admin":"0","is_ssl":"1","i18n_username_required":"Please enter your username","i18n_password_required":"Please enter your password","error_class":"sidebar_login_error"};
/* ]]> */
</script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/plugins/sidebar-login/assets/js/sidebar-login.min.js?ver=2.7.3'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/themes/mru-focus/assets/js/bootstrap.min.js?ver=5.1.1'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/themes/mru-focus/assets/js/jquery.infinitescroll.min.js?ver=5.1.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var dw_focus = {"ajax_url":"https:\/\/madriverunion.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/themes/mru-focus/assets/js/custom.js?ver=5.1.1'></script>
<script type='text/javascript' src='//platform.twitter.com/widgets.js?ver=5.1.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var dw_focus = {"ajax_url":"https:\/\/madriverunion.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/themes/mru-focus/assets/js/single-socials.js?ver=5.1.1'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/themes/mru-focus/assets/js/jquery.mouse.move.js?ver=5.1.1'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/themes/mru-focus/assets/js/jquery.swipe.js?ver=5.1.1'></script>
<link rel='https://api.w.org/' href='https://madriverunion.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://madriverunion.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://madriverunion.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Ramblin&#8217; Jack&#8217;s Theatre Review: A night of great music at Smokey Joe’s Cafe' href='https://madriverunion.com/ramblin-jacks-theatre-review-a-night-of-great-music-at-smokey-joes-cafe/' />
<link rel='next' title='McKinleyville Rec Committee seeks members, DJ Marv seeks Karaokers' href='https://madriverunion.com/mckinleyville-rec-committee-seeks-members-dj-marv-seeks-karaokers/' />
<meta name="generator" content="WordPress 5.1.1" />
<link rel='shortlink' href='https://wp.me/p9ZzmG-csG' />
<link rel="alternate" type="application/json+oembed" href="https://madriverunion.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmadriverunion.com%2Fmack-high-stages-our-town%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://madriverunion.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmadriverunion.com%2Fmack-high-stages-our-town%2F&#038;format=xml" />
<style></style><link rel="canonical" href="https://madriverunion.com/mack-high-stages-our-town/"/>

<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//madriverunion.com/?wordfence_lh=1&hid=782CCC84C849EAD918FB674BF95365E4');
</script>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<meta property="og:title" content="Mack High stages Our Town" /><meta property="og:url" content="https://madriverunion.com/mack-high-stages-our-town/" /><meta property="og:image" content="https://madriverunion.com/wp-content/uploads/2019/03/MHS.Gossip-at-Grovers-Corner-Our-Town-1-110x85.jpg" /><meta property="og:description" content=""/>    <style type="text/css">
        
        
            </style>
    <link rel="shortcut icon" href="https://madriverunion.com/wp-content/themes/mru-focus/assets/img/favicon.ico">

<!-- EventON Version -->
<meta name="generator" content="EventON 2.2.23" />


<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Mack High stages Our Town" />
<meta property="og:url" content="https://madriverunion.com/mack-high-stages-our-town/" />
<meta property="og:description" content="McKinleyville High School MCKINLEYVILLE – Thornton Wilder’s classic Pulitzer Prize winning play Our Town is being brought to life by the students of McKinleyville High School for their annual Sprin…" />
<meta property="article:published_time" content="2019-03-20T22:50:13+00:00" />
<meta property="article:modified_time" content="2019-03-20T22:50:13+00:00" />
<meta property="og:site_name" content="Mad River Union" />
<meta property="og:image" content="https://madriverunion.com/wp-content/uploads/2019/03/MHS.Gossip-at-Grovers-Corner-Our-Town-1.jpg" />
<meta property="og:image:width" content="2833" />
<meta property="og:image:height" content="2188" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@madriverunion" />
<meta name="twitter:text:title" content="Mack High stages Our Town" />
<meta name="twitter:image" content="https://madriverunion.com/wp-content/uploads/2019/03/MHS.Gossip-at-Grovers-Corner-Our-Town-1.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-3490466616595796",
    enable_page_level_ads: true
  });
</script>
</head>
<body class="post-template-default single single-post postid-47906 single-format-standard desktop  not-login group-blog" >
	<header id="masthead" class="site-header" role="banner">
	    <div class="container">
	    	<div id="header">
	    		<div class="row">
	    			<div id="mtphr-dnt-12580" class="mtphr-dnt mtphr-dnt-12580 mtphr-dnt-default mtphr-dnt-scroll mtphr-dnt-scroll-left"><div class="mtphr-dnt-wrapper mtphr-dnt-clearfix"><h3 class="mtphr-dnt-title mtphr-dnt-inline-title"></h3><div class="mtphr-dnt-tick-container" style="padding-top:3px;padding-bottom:3px;"><div class="mtphr-dnt-tick-contents"><div style="height:20px;" class="mtphr-dnt-tick mtphr-dnt-default-tick mtphr-dnt-clearfix "><a href="http://madriverunion.com/marna-powell-awesomeness-at-stone-lagoon-benefit-for-dry-lagoon-saturday-nov-1/" target="_self">Subscribe to your local newspaper and support community journalism…</a></div><div style="height:20px;" class="mtphr-dnt-tick mtphr-dnt-default-tick mtphr-dnt-clearfix "><a href="http://crushallboxes.blogspot.com" target="_self">Authentic Arcata Ridge Trail markers available at Union office in Jacoby’s Storehouse…</a></div></div></div></div></div>	           		<div id="branding" class="span3 visible-desktop">
		                <h1>
		                	<a href="https://madriverunion.com/" title="Mad River Union" rel="home">
		                		Mad River Union		                	</a>
		                </h1>
		            </div>
		            		        </div>
	        </div>
	        		            <div class="btn-group top-news">
				    	        <a class="dropdown-toggle" data-toggle="dropdown" href="#">
            <span class="number">15</span>
            <span>Must read articles <i class="icon-caret-down"></i></span>
        </a>
                    <div class="top-news-inner">
                <ul class="dropdown-menu">
                    <div class="entry-meta">March 21, 2019</div>

                    <div class="row-fluid">
                        <ul>
                            <li class="has-thumbnail first">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/farmers-market-vendors-vote-for-partial-plaza-street-closure-on-saturdays/" title="Farmers Market vendors vote for partial Plaza street closure on Saturdays"><img width="40" height="20" src="https://madriverunion.com/wp-content/uploads/2019/03/Farmers-Market-circle-110x56.jpg" class="attachment-40x40 size-40x40 wp-post-image" alt="" srcset="https://madriverunion.com/wp-content/uploads/2019/03/Farmers-Market-circle-110x56.jpg 110w, https://madriverunion.com/wp-content/uploads/2019/03/Farmers-Market-circle-230x118.jpg 230w, https://madriverunion.com/wp-content/uploads/2019/03/Farmers-Market-circle-768x393.jpg 768w, https://madriverunion.com/wp-content/uploads/2019/03/Farmers-Market-circle-640x328.jpg 640w, https://madriverunion.com/wp-content/uploads/2019/03/Farmers-Market-circle.jpg 1600w" sizes="(max-width: 40px) 100vw, 40px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/farmers-market-vendors-vote-for-partial-plaza-street-closure-on-saturdays/" title="Farmers Market vendors vote for partial Plaza street closure on Saturdays"> Farmers Market vendors vote for partial Plaza street closure on Saturdays </a></div>
                </li>
                            <li class="has-thumbnail">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/forest-news-international-day-of-forests-a-saturday-volunteer-workday-and-andre-is-honored/" title="Forest news: International Day of Forests, a Saturday volunteer workday and Andre is honored"><img width="40" height="27" src="https://madriverunion.com/wp-content/uploads/2019/03/Mark-Andre-award-BOF-110x75.jpg" class="attachment-40x40 size-40x40 wp-post-image" alt="" srcset="https://madriverunion.com/wp-content/uploads/2019/03/Mark-Andre-award-BOF-110x75.jpg 110w, https://madriverunion.com/wp-content/uploads/2019/03/Mark-Andre-award-BOF-230x158.jpg 230w, https://madriverunion.com/wp-content/uploads/2019/03/Mark-Andre-award-BOF-768x527.jpg 768w, https://madriverunion.com/wp-content/uploads/2019/03/Mark-Andre-award-BOF-640x439.jpg 640w, https://madriverunion.com/wp-content/uploads/2019/03/Mark-Andre-award-BOF.jpg 1600w" sizes="(max-width: 40px) 100vw, 40px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/forest-news-international-day-of-forests-a-saturday-volunteer-workday-and-andre-is-honored/" title="Forest news: International Day of Forests, a Saturday volunteer workday and Andre is honored"> Forest news: International Day of Forests, a Saturday volunteer workday and Andre is honored </a></div>
                </li>
                            <li class="">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/strike4climate-and-sustainable-futures-with-aldaron/" title="#strike4climate and Sustainable Futures with Aldaron"></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/strike4climate-and-sustainable-futures-with-aldaron/" title="#strike4climate and Sustainable Futures with Aldaron"> #strike4climate and Sustainable Futures with Aldaron </a></div>
                </li>
                            <li class="has-thumbnail first">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/mckinleyville-rec-committee-seeks-members-dj-marv-seeks-karaokers/" title="McKinleyville Rec Committee seeks members, DJ Marv seeks Karaokers"><img width="26" height="40" src="https://madriverunion.com/wp-content/uploads/2019/01/Screen-Shot-2019-01-03-at-10.50.59-AM-110x171.png" class="attachment-40x40 size-40x40 wp-post-image" alt="" srcset="https://madriverunion.com/wp-content/uploads/2019/01/Screen-Shot-2019-01-03-at-10.50.59-AM-110x171.png 110w, https://madriverunion.com/wp-content/uploads/2019/01/Screen-Shot-2019-01-03-at-10.50.59-AM.png 161w" sizes="(max-width: 26px) 100vw, 26px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/mckinleyville-rec-committee-seeks-members-dj-marv-seeks-karaokers/" title="McKinleyville Rec Committee seeks members, DJ Marv seeks Karaokers"> McKinleyville Rec Committee seeks members, DJ Marv seeks Karaokers </a></div>
                </li>
                            <li class="has-thumbnail">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/mack-high-stages-our-town/" title="Mack High stages Our Town"><img width="40" height="31" src="https://madriverunion.com/wp-content/uploads/2019/03/MHS.Gossip-at-Grovers-Corner-Our-Town-1-110x85.jpg" class="attachment-40x40 size-40x40 wp-post-image" alt="" srcset="https://madriverunion.com/wp-content/uploads/2019/03/MHS.Gossip-at-Grovers-Corner-Our-Town-1-110x85.jpg 110w, https://madriverunion.com/wp-content/uploads/2019/03/MHS.Gossip-at-Grovers-Corner-Our-Town-1-230x178.jpg 230w, https://madriverunion.com/wp-content/uploads/2019/03/MHS.Gossip-at-Grovers-Corner-Our-Town-1-768x593.jpg 768w, https://madriverunion.com/wp-content/uploads/2019/03/MHS.Gossip-at-Grovers-Corner-Our-Town-1-640x494.jpg 640w, https://madriverunion.com/wp-content/uploads/2019/03/MHS.Gossip-at-Grovers-Corner-Our-Town-1-520x400.jpg 520w" sizes="(max-width: 40px) 100vw, 40px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/mack-high-stages-our-town/" title="Mack High stages Our Town"> Mack High stages Our Town </a></div>
                </li>
                            <li class="">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/obituary-jeanette-maxine-hubbard-smyth-jan-30-1934-feb-10-2019/" title="OBITUARY: Jeanette Maxine Hubbard-Smyth, Jan. 30, 1934 &#8211; Feb. 10, 2019"></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/obituary-jeanette-maxine-hubbard-smyth-jan-30-1934-feb-10-2019/" title="OBITUARY: Jeanette Maxine Hubbard-Smyth, Jan. 30, 1934 &#8211; Feb. 10, 2019"> OBITUARY: Jeanette Maxine Hubbard-Smyth, Jan. 30, 1934 &#8211; Feb. 10, 2019 </a></div>
                </li>
                            <li class=" first">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/obituary-wendy-l-bispo-dec-12-1958-feb-25-2019/" title="OBITUARY: Wendy L. Bispo, Dec. 12, 1958 &#8211; Feb. 25, 2019"></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/obituary-wendy-l-bispo-dec-12-1958-feb-25-2019/" title="OBITUARY: Wendy L. Bispo, Dec. 12, 1958 &#8211; Feb. 25, 2019"> OBITUARY: Wendy L. Bispo, Dec. 12, 1958 &#8211; Feb. 25, 2019 </a></div>
                </li>
                            <li class="has-thumbnail">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/take-arcatas-bicycle-friendly-community-survey/" title="Take Arcata&#8217;s Bicycle Friendly Community Survey"><img width="40" height="40" src="https://madriverunion.com/wp-content/uploads/2016/05/Bike.Commuter-110x109.jpg" class="attachment-40x40 size-40x40 wp-post-image" alt="" srcset="https://madriverunion.com/wp-content/uploads/2016/05/Bike.Commuter-110x109.jpg 110w, https://madriverunion.com/wp-content/uploads/2016/05/Bike.Commuter-230x227.jpg 230w, https://madriverunion.com/wp-content/uploads/2016/05/Bike.Commuter-768x758.jpg 768w, https://madriverunion.com/wp-content/uploads/2016/05/Bike.Commuter-640x632.jpg 640w" sizes="(max-width: 40px) 100vw, 40px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/take-arcatas-bicycle-friendly-community-survey/" title="Take Arcata&#8217;s Bicycle Friendly Community Survey"> Take Arcata&#8217;s Bicycle Friendly Community Survey </a></div>
                </li>
                            <li class="has-thumbnail">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/arcata-summer-recreation-guide/" title="Arcata Summer Recreation Guide"><img width="38" height="40" src="https://madriverunion.com/wp-content/uploads/2019/03/RecHalf-110x116.jpg" class="attachment-40x40 size-40x40 wp-post-image" alt="" srcset="https://madriverunion.com/wp-content/uploads/2019/03/RecHalf-110x116.jpg 110w, https://madriverunion.com/wp-content/uploads/2019/03/RecHalf-230x243.jpg 230w, https://madriverunion.com/wp-content/uploads/2019/03/RecHalf-768x813.jpg 768w, https://madriverunion.com/wp-content/uploads/2019/03/RecHalf-640x677.jpg 640w" sizes="(max-width: 38px) 100vw, 38px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/arcata-summer-recreation-guide/" title="Arcata Summer Recreation Guide"> Arcata Summer Recreation Guide </a></div>
                </li>
                            <li class="has-thumbnail first">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/new-mcsd-director-comes-under-fire/" title="New MCSD director comes under fire"><img width="40" height="40" src="https://madriverunion.com/wp-content/uploads/2019/03/Barsanti-Shel-110x110.jpg" class="attachment-40x40 size-40x40 wp-post-image" alt="" srcset="https://madriverunion.com/wp-content/uploads/2019/03/Barsanti-Shel-110x110.jpg 110w, https://madriverunion.com/wp-content/uploads/2019/03/Barsanti-Shel-230x230.jpg 230w, https://madriverunion.com/wp-content/uploads/2019/03/Barsanti-Shel-768x768.jpg 768w, https://madriverunion.com/wp-content/uploads/2019/03/Barsanti-Shel-640x640.jpg 640w, https://madriverunion.com/wp-content/uploads/2019/03/Barsanti-Shel.jpg 1000w" sizes="(max-width: 40px) 100vw, 40px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/new-mcsd-director-comes-under-fire/" title="New MCSD director comes under fire"> New MCSD director comes under fire </a></div>
                </li>
                            <li class="has-thumbnail">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/dogtown-hero-diesel-are-some-of-the-finest-gents-youll-ever-meet/" title="Dogtown: Hero &#038; Diesel are some of the finest gents you’ll ever meet"><img width="28" height="40" src="https://madriverunion.com/wp-content/uploads/2019/03/dogtown.Hero-with-JE-110x155.jpg" class="attachment-40x40 size-40x40 wp-post-image" alt="" srcset="https://madriverunion.com/wp-content/uploads/2019/03/dogtown.Hero-with-JE-110x155.jpg 110w, https://madriverunion.com/wp-content/uploads/2019/03/dogtown.Hero-with-JE-230x324.jpg 230w, https://madriverunion.com/wp-content/uploads/2019/03/dogtown.Hero-with-JE.jpg 454w" sizes="(max-width: 28px) 100vw, 28px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/dogtown-hero-diesel-are-some-of-the-finest-gents-youll-ever-meet/" title="Dogtown: Hero &#038; Diesel are some of the finest gents you’ll ever meet"> Dogtown: Hero &#038; Diesel are some of the finest gents you’ll ever meet </a></div>
                </li>
                            <li class="has-thumbnail">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/st-joe-kickstarts-hsu-cr-nursing-program-with-2-million-grant/" title="St. Joe kickstarts HSU/CR nursing program with $2 million grant"><img width="40" height="21" src="https://madriverunion.com/wp-content/uploads/2019/03/Nursing-group-110x57.jpg" class="attachment-40x40 size-40x40 wp-post-image" alt="" srcset="https://madriverunion.com/wp-content/uploads/2019/03/Nursing-group-110x57.jpg 110w, https://madriverunion.com/wp-content/uploads/2019/03/Nursing-group-230x119.jpg 230w, https://madriverunion.com/wp-content/uploads/2019/03/Nursing-group-768x398.jpg 768w, https://madriverunion.com/wp-content/uploads/2019/03/Nursing-group-640x332.jpg 640w, https://madriverunion.com/wp-content/uploads/2019/03/Nursing-group.jpg 1600w" sizes="(max-width: 40px) 100vw, 40px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/st-joe-kickstarts-hsu-cr-nursing-program-with-2-million-grant/" title="St. Joe kickstarts HSU/CR nursing program with $2 million grant"> St. Joe kickstarts HSU/CR nursing program with $2 million grant </a></div>
                </li>
                            <li class="has-thumbnail first">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/supes-laud-transitional-home-in-mck/" title="Supes laud transitional home in McK"><img width="40" height="40" src="https://madriverunion.com/wp-content/uploads/2019/03/AJs-logo-110x110.png" class="attachment-40x40 size-40x40 wp-post-image" alt="" srcset="https://madriverunion.com/wp-content/uploads/2019/03/AJs-logo-110x110.png 110w, https://madriverunion.com/wp-content/uploads/2019/03/AJs-logo-230x230.png 230w, https://madriverunion.com/wp-content/uploads/2019/03/AJs-logo-768x768.png 768w, https://madriverunion.com/wp-content/uploads/2019/03/AJs-logo-640x640.png 640w, https://madriverunion.com/wp-content/uploads/2019/03/AJs-logo.png 960w" sizes="(max-width: 40px) 100vw, 40px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/supes-laud-transitional-home-in-mck/" title="Supes laud transitional home in McK"> Supes laud transitional home in McK </a></div>
                </li>
                            <li class="has-thumbnail">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/mccullough-constructions-humboldt-bay-trail-north-excellence-honored/" title="McCullough Construction’s Humboldt Bay Trail North excellence honored"><img width="40" height="27" src="https://madriverunion.com/wp-content/uploads/2019/03/IMG_9589-110x73.jpg" class="attachment-40x40 size-40x40 wp-post-image" alt="" srcset="https://madriverunion.com/wp-content/uploads/2019/03/IMG_9589-110x73.jpg 110w, https://madriverunion.com/wp-content/uploads/2019/03/IMG_9589-230x153.jpg 230w, https://madriverunion.com/wp-content/uploads/2019/03/IMG_9589-768x512.jpg 768w, https://madriverunion.com/wp-content/uploads/2019/03/IMG_9589-640x427.jpg 640w" sizes="(max-width: 40px) 100vw, 40px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/mccullough-constructions-humboldt-bay-trail-north-excellence-honored/" title="McCullough Construction’s Humboldt Bay Trail North excellence honored"> McCullough Construction’s Humboldt Bay Trail North excellence honored </a></div>
                </li>
                            <li class="has-thumbnail">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/arcata-main-street-is-seeking-vendors-and-nonprofits-for-29th-annual-oyster-festival/" title="Arcata Main Street is seeking vendors and nonprofits for 29th annual Oyster Festival"><img width="40" height="40" src="https://madriverunion.com/wp-content/uploads/2019/03/Screen-Shot-2019-03-15-at-12.30.57-PM-110x110.png" class="attachment-40x40 size-40x40 wp-post-image" alt="" srcset="https://madriverunion.com/wp-content/uploads/2019/03/Screen-Shot-2019-03-15-at-12.30.57-PM-110x110.png 110w, https://madriverunion.com/wp-content/uploads/2019/03/Screen-Shot-2019-03-15-at-12.30.57-PM-230x229.png 230w, https://madriverunion.com/wp-content/uploads/2019/03/Screen-Shot-2019-03-15-at-12.30.57-PM.png 515w" sizes="(max-width: 40px) 100vw, 40px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/arcata-main-street-is-seeking-vendors-and-nonprofits-for-29th-annual-oyster-festival/" title="Arcata Main Street is seeking vendors and nonprofits for 29th annual Oyster Festival"> Arcata Main Street is seeking vendors and nonprofits for 29th annual Oyster Festival </a></div>
                </li>
              
                        </ul>
                    </div>
                </ul>
            </div>
            				    </div>
			
		    <div class="wrap-navigation">
		        <nav id="site-navigation" class="main-navigation navbar" role="navigation">
		            <div class="navbar-inner">
						<button class="btn btn-navbar" data-target=".nav-collapse" data-toggle="collapse"  type="button">
							<span class="icon-bar"></span>
							<span class="icon-bar"></span>
							<span class="icon-bar"></span>
						</button>

						<button class="collapse-search hidden-desktop" data-target=".search-collapse" data-toggle="collapse" >
							<i class="icon-search"></i>
						</button>

						<a class="small-logo hidden-desktop" rel="home" title="DW Focus" href="https://madriverunion.com/">DW Focus</a>
					
												<ul class="social-links visible-desktop">
																																																</ul><!-- End social links -->

						<div class="search-collapse collapse">
								<form method="get" name="searchForm" class="searchForm" action="https://madriverunion.com/" role="search">
		<input type="text" class="field" name="s" value="" placeholder="Search &hellip;" />
		<input type="submit" class="submit" name="submit" value="Search" />
	</form>
						</div>

						<div class="nav-collapse collapse">
							<ul id="menu-primary-menu" class="nav"><li id="menu-item-12432" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12432 color-none 0"><a href="https://madriverunion.com/category/featured/">Featured</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-12433" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12433 color-yellow 0"><a href="https://madriverunion.com/category/news/">News</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-12430" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12430 color-green 0"><a href="https://madriverunion.com/category/community/">Community</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-12434" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12434 color-orange 0"><a href="https://madriverunion.com/category/opinion/">Opinion</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-12431" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12431 color-violet 0"><a href="https://madriverunion.com/category/entertainment/">Entertainment</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-15879" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15879 color-none 0"><a href="https://madriverunion.com/category/premium/">Premium</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-12429" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-parent-item menu-parent-item menu-item-12429 0"><a href="https://madriverunion.com/about/">About the Union</a><i class="sub-menu-collapse icon-chevron-down hidden-desktop"></i>
<ul class="sub-menu">
	<li id="menu-item-12427" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12427 active 1"><a href="https://madriverunion.com/submission-guide/">Submission Guide</a></li>
	<li id="menu-item-40768" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40768 1"><a href="https://madriverunion.com/about/comment-policy/">Comment Policy</a></li>
	<li id="menu-item-12426" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12426 1"><a href="https://madriverunion.com/where-to-buy-the-mad-river-union/">Where To Buy</a></li>
	<li id="menu-item-12428" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12428 1"><a href="https://madriverunion.com/advertising/">Ad/Legal Rates and Sample Ads</a></li>
	<li id="menu-item-12425" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12425 1"><a href="https://madriverunion.com/contact-us/">Contact Us</a></li>
</ul>
</li>
<li id="menu-item-15865" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15865 0"><a href="https://madriverunion.com/subscription-options/">Subscribe</a></li>
</ul>						</div>	
		            </div>
		        </nav>

		        <div id="under-navigation" class="clearfix under-navigation">
		        	<div class="row-fluid">
		        				        				        		<!-- Under navigation positions ( breadcrum, twitter widgets) -->
			        	<div class="span9">
							        
        <aside id="dw_focus_news_headlines-5" class="widget dw_focus_headlines">        <h3 class="widget-title">New Stories</h3>        <div class="headlines" data-interval="5000">
            <ul>
                            <li><a href="https://madriverunion.com/farmers-market-vendors-vote-for-partial-plaza-street-closure-on-saturdays/">Farmers Market vendors vote for partial Plaza street closure on Saturdays</a><span class="time_diff"> - 15 hours ago</span></li>
                            <li><a href="https://madriverunion.com/forest-news-international-day-of-forests-a-saturday-volunteer-workday-and-andre-is-honored/">Forest news: International Day of Forests, a Saturday volunteer workday and Andre is honored</a><span class="time_diff"> - 15 hours ago</span></li>
                            <li><a href="https://madriverunion.com/strike4climate-and-sustainable-futures-with-aldaron/">#strike4climate and Sustainable Futures with Aldaron</a><span class="time_diff"> - 16 hours ago</span></li>
                            <li><a href="https://madriverunion.com/mckinleyville-rec-committee-seeks-members-dj-marv-seeks-karaokers/">McKinleyville Rec Committee seeks members, DJ Marv seeks Karaokers</a><span class="time_diff"> - 16 hours ago</span></li>
                            <li><a href="https://madriverunion.com/mack-high-stages-our-town/">Mack High stages Our Town</a><span class="time_diff"> - 16 hours ago</span></li>
                 
            </ul>
        </div>
        </aside><aside id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"></div></aside>						</div>
						
						<div class="span3 ">	<form method="get" name="searchForm" class="searchForm" action="https://madriverunion.com/" role="search">
		<input type="text" class="field" name="s" value="" placeholder="Search &hellip;" />
		<input type="submit" class="submit" name="submit" value="Search" />
	</form>
</div>
					</div>
			    </div>
		    </div>
	    </div>
	</header> <!-- End header -->

	<div id="main">
         <div class="container">
             <div class="row">


    <div id="primary" class="site-content span9">

	
		
<article id="post-47906" class="post-47906 post type-post status-publish format-standard has-post-thumbnail hentry category-entertainment category-featured tag-mckinleyville-high-school tag-our-town content-print">
	<header class="entry-header">
		<h1 class="entry-title">Mack High stages Our Town</h1>
		
		<div class="entry-meta">
			<ul class="post-categories">
	<li><a href="https://madriverunion.com/category/entertainment/" rel="tag">Entertainment</a></li>
	<li><a href="https://madriverunion.com/category/featured/" rel="tag">Featured</a></li></ul><time class="entry-date" datetime="2019-03-20T15:50:13-07:00" pubdate>16 hours ago</time>		</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

			<!-- <div class="entry-thumbnail">
			<img width="2833" height="2188" src="https://madriverunion.com/wp-content/uploads/2019/03/MHS.Gossip-at-Grovers-Corner-Our-Town-1.jpg" class="attachment- size- wp-post-image" alt="" srcset="https://madriverunion.com/wp-content/uploads/2019/03/MHS.Gossip-at-Grovers-Corner-Our-Town-1.jpg 2833w, https://madriverunion.com/wp-content/uploads/2019/03/MHS.Gossip-at-Grovers-Corner-Our-Town-1-110x85.jpg 110w, https://madriverunion.com/wp-content/uploads/2019/03/MHS.Gossip-at-Grovers-Corner-Our-Town-1-230x178.jpg 230w, https://madriverunion.com/wp-content/uploads/2019/03/MHS.Gossip-at-Grovers-Corner-Our-Town-1-768x593.jpg 768w, https://madriverunion.com/wp-content/uploads/2019/03/MHS.Gossip-at-Grovers-Corner-Our-Town-1-640x494.jpg 640w" sizes="(max-width: 2833px) 100vw, 2833px" />		</div> --> <!-- from content-single.php -->
	
	<div class="entry-content">
		<div id="attachment_47929" style="width: 650px" class="wp-caption aligncenter"><a href="https://madriverunion.com/wp-content/uploads/2019/03/MHS.Gossip-at-Grovers-Corner-Our-Town-1.jpg"><img aria-describedby="caption-attachment-47929" class="size-large wp-image-47929" src="https://madriverunion.com/wp-content/uploads/2019/03/MHS.Gossip-at-Grovers-Corner-Our-Town-1-640x494.jpg" alt="" width="640" height="494" srcset="https://madriverunion.com/wp-content/uploads/2019/03/MHS.Gossip-at-Grovers-Corner-Our-Town-1-640x494.jpg 640w, https://madriverunion.com/wp-content/uploads/2019/03/MHS.Gossip-at-Grovers-Corner-Our-Town-1-110x85.jpg 110w, https://madriverunion.com/wp-content/uploads/2019/03/MHS.Gossip-at-Grovers-Corner-Our-Town-1-230x178.jpg 230w, https://madriverunion.com/wp-content/uploads/2019/03/MHS.Gossip-at-Grovers-Corner-Our-Town-1-768x593.jpg 768w, https://madriverunion.com/wp-content/uploads/2019/03/MHS.Gossip-at-Grovers-Corner-Our-Town-1-520x400.jpg 520w" sizes="(max-width: 640px) 100vw, 640px" /></a><p id="caption-attachment-47929" class="wp-caption-text">At rehearsal, some McKinleyville High student actors portray gossiping townsfolk in Thornton Wilder’s play “Our Town” which opens Wednesday, March 20th and plays through Saturday, March 23. Submitted photo</p></div>
<p style="text-align: center;"><b>McKinleyville<span class="Apple-converted-space"> </span></b><b>High School</b></p>
<p>MCKINLEYVILLE – Thornton Wilder’s classic Pulitzer Prize winning play <i>Our Town</i> is being brought to life by the students of McKinleyville High School for their annual Spring Play. Performances are today, March 20 through Saturday, March 23 at the McKinleyville High School Multi-purpose Room, 1300 Murray Rd. Doors open at 6:30 p.m. and the curtain rises at 7 p.m. Snacks and refreshments are available during the intermission. General Admission tickets are $8 and $6 for students and seniors.</p>
<p>Directed by MHS Drama teacher Steve Nystrom, student actors find themselves telling the story of Grover’s Corners between 1901 and 1913. The audience has a role to play in this innovative play which has been in production somewhere in the United States every day since its 1938 debut. Its themes of daily life, love and marriage, death and eternity are timeless. Props will be pantomimed and improvisation with audience members will showcase the actors’ skills.</p>
<p>In addition to enjoying some great entertainment, audience members are helping to support the Drama Departments activities which include theater workshops, performances during the year for school, and an educational trip to Ashland, Oregon.<span class="Apple-converted-space"> </span></p>
<p>A 15-year veteran of directing student plays at Mack High, Nystrom says that his students show that they take their roles as actors and as their characters seriously by attending play practice after school and on weekends for almost two months in preparation.</p>
<p>&nbsp;</p>
<p><ins class="adsbygoogle" style="display: inline-block; width: 728px; height: 90px;" data-ad-client="ca-pub-3490466616595796" data-ad-slot="7921456462"></ins><br />
<script><br />
(adsbygoogle = window.adsbygoogle || []).push({});<br />
</script><br />
<ins class="adsbygoogle" style="display: inline-block; width: 336px; height: 280px;" data-ad-client="ca-pub-3490466616595796" data-ad-slot="3851720064"></ins><br />
<script><br />
(adsbygoogle = window.adsbygoogle || []).push({});<br />
</script></p>
<p><script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<!-- Article Bottom Ad --><br />
<ins class="adsbygoogle" style="display: inline-block; width: 728px; height: 90px;" data-ad-client="ca-pub-3490466616595796" data-ad-slot="7921456462"></ins><br />
<script><br />
(adsbygoogle = window.adsbygoogle || []).push({});<br />
</script></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-47906" class="share-twitter sd-button share-icon" href="https://madriverunion.com/mack-high-stages-our-town/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-end"></li></ul></div></div></div>			</div><!-- .entry-content -->

	        <div class="entry-action">
            <div class="social-action" data-nonce="38cb7767c5">
                <span class="title-action">Sharing</span>
                <ul>
                    <li id="twitter-share" class="twitter" data-post-id="47906" data-nonce="b8bc26ef1b"><i class="icon-twitter"></i><a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fmadriverunion.com%2Fmack-high-stages-our-town%2F&amp;text=Mack%20High%20stages%20Our%20Town">Twitter</a><span class="digit digit-twitter">0</span></li>
                    <li class="facebook"><i class="icon-facebook-sign"></i><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fmadriverunion.com%2Fmack-high-stages-our-town%2F&amp;t=Mack%20High%20stages%20Our%20Town" >Facebook</a><span class="digit digit-facebook">0</span></li>
                    <li class="google"><i class="icon-google-plus-sign"></i><a href="https://plus.google.com/share?url=https%3A%2F%2Fmadriverunion.com%2Fmack-high-stages-our-town%2F" >Google +</a><span>0</span></li>
                    <li class="linkedin"><i class="icon-linkedin-sign"></i><a href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fmadriverunion.com%2Fmack-high-stages-our-town%2F&amp;title=Mack%20High%20stages%20Our%20Town&amp;summary=McKinleyville%C2%A0High%20School%20MCKINLEYVILLE%20%E2%80%93%20Thornton%20Wilder%E2%80%99s%20classic%20Pulitzer%20Prize%20winning%20play%20Our%20Town%20is%20being%20brought%20to%20life%20by%20the%20students%20of%20McKinleyville%20High%20School%20for%20their%20annual%20Spring%20Play.%20Performances%20are%20today%2C%20March%2020%20through%20Saturday%2C%20March%2023%20at%20the%20McKinleyville%20High%20School%20Multi-purpose%20Room%2C%201300%20Murray%20Rd.%20Doors%20open%20at%206%3A30%20p.m.%20and%3Ca%20href%3D%22https%3A%2F%2Fmadriverunion.com%2Fmack-high-stages-our-town%2F%22%20title%3D%22Read%20more%22%20%3E...%3C%2Fa%3E">Linkedin</a><span class="digit digit-linkedin">0</span></li>
                    <li class="email"><i class="icon-envelope-alt"></i><a href="/cdn-cgi/l/email-protection#fec1ad8b9c949b9d8ac3b39f9d95dbccceb6979996dbccce8d8a9f999b8ddbccceb18b8cdbccceaa918990d89f938ec59c919a87c3968a8a8e8ddbcdbfdbccb8dbccb8939f9a8c97889b8c8b90979190d09d9193dbccb8939f9d95d396979996d38d8a9f999b8dd3918b8cd38a918990dbccb8">Email this article</a></li>
                                        <li class="print"><i class="icon-print"></i><a href="#" onclick="window.print();">Print this article</a></li>
                                    </ul>
            </div>

                            <div class="co-author">
                <span class="title-action">Authors</span>
                
                    <div class="author-info">
                        <img alt='' src='https://secure.gravatar.com/avatar/bf535201942314b455964ae40aec0404?s=96&#038;d=mm&#038;r=pg' srcset='https://secure.gravatar.com/avatar/bf535201942314b455964ae40aec0404?s=192&#038;d=mm&#038;r=pg 2x' class='avatar avatar-96 photo' height='96' width='96' />                        <a class="author-name" href="https://madriverunion.com/author/kevpod/" rel="author">Kevin Hoover</a></h2>
                    </div><!-- .author-info -->

                                </div>
            
                         <div class="tag-action">
                <span class="title-action">Tags</span>
                <span class="tags-links">
                    <a href="https://madriverunion.com/tag/mckinleyville-high-school/" rel="tag">McKinleyville High School</a>, <a href="https://madriverunion.com/tag/our-town/" rel="tag">Our Town</a>                </span>
            </div>
                    </div>
    	
</article><!-- #post-47906 -->
		

	
					<div class="related-post">
					<h3>Related posts</h3>
					<div class="row-fluid">
						<div class="content-inner">
						
<article id="post-46981" class="row-fluid post-46981 post type-post status-publish format-standard has-post-thumbnail hentry category-community category-featured tag-big-lagoon-school tag-california-federation-of-womens-clubs-student-art-contest tag-howdy-emerson tag-janine-volkmar tag-jim-lahman-band tag-mckinleyville-high-school tag-monarch-butterflies tag-moonstone-crossing-tasting-room tag-trinidad-art-gallery tag-trinidad-coastal-land-trust tag-trinidad-school tag-trinidad-tidings tag-trinidad-town-hall tag-trinidad-volunteer-fire-department tag-valentines-day tag-westhaven-center-for-the-arts content-print">
        <div class="entry-thumbnail">
        <a href="https://madriverunion.com/trinidad-tidings-a-valentine-celebration-the-seaside-village-way/" title="Permalink to Trinidad Tidings: A Valentine celebration the seaside village way" rel="bookmark">
            
            <img width="166" height="300" src="https://madriverunion.com/wp-content/uploads/2014/09/TrinidadTidings-230x416.jpg" class="attachment-medium size-medium wp-post-image" alt="" srcset="https://madriverunion.com/wp-content/uploads/2014/09/TrinidadTidings-230x416.jpg 230w, https://madriverunion.com/wp-content/uploads/2014/09/TrinidadTidings-110x199.jpg 110w, https://madriverunion.com/wp-content/uploads/2014/09/TrinidadTidings.jpg 264w" sizes="(max-width: 166px) 100vw, 166px" />        </a>
    </div>
    
    <div class="post-inner">
        <header class="entry-header">
            <h2 class="entry-title"><a href="https://madriverunion.com/trinidad-tidings-a-valentine-celebration-the-seaside-village-way/" title="Permalink to Trinidad Tidings: A Valentine celebration the seaside village way" rel="bookmark">Trinidad Tidings: A Valentine celebration the seaside village way</a>
            </h2>
        </header>
    </div>
</article>
<article id="post-46934" class="row-fluid post-46934 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-elliptigo-arc-8-bike tag-humboldt-county-sheriffs-office tag-mack-town tag-mckinleyville-crime tag-mckinleyville-high-school tag-theft content-print">
        <div class="entry-thumbnail">
        <a href="https://madriverunion.com/burglar-takes-7500-in-property-from-mack-high/" title="Permalink to Burglar takes $7,500 in property from Mack High" rel="bookmark">
            
            <img width="230" height="230" src="https://madriverunion.com/wp-content/uploads/2019/02/Document-230x230.jpeg" class="attachment-medium size-medium wp-post-image" alt="" srcset="https://madriverunion.com/wp-content/uploads/2019/02/Document-230x230.jpeg 230w, https://madriverunion.com/wp-content/uploads/2019/02/Document-110x110.jpeg 110w, https://madriverunion.com/wp-content/uploads/2019/02/Document-768x768.jpeg 768w, https://madriverunion.com/wp-content/uploads/2019/02/Document-640x640.jpeg 640w, https://madriverunion.com/wp-content/uploads/2019/02/Document.jpeg 1500w" sizes="(max-width: 230px) 100vw, 230px" />        </a>
    </div>
    
    <div class="post-inner">
        <header class="entry-header">
            <h2 class="entry-title"><a href="https://madriverunion.com/burglar-takes-7500-in-property-from-mack-high/" title="Permalink to Burglar takes $7,500 in property from Mack High" rel="bookmark">Burglar takes $7,500 in property from Mack High</a>
            </h2>
        </header>
    </div>
</article>
<article id="post-45328" class="row-fluid post-45328 post type-post status-publish format-standard hentry category-news tag-election-2018 tag-mckinleyville-high-school tag-true-north-organizing-network tag-yurok-tribal-council-runoff-election content-print">
    
    <div class="post-inner">
        <header class="entry-header">
            <h2 class="entry-title"><a href="https://madriverunion.com/true-north-organizing-network-hosts-yurok-tribal-council-runoff-forum-at-mckinleyville-high-school/" title="Permalink to True North Organizing Network hosts Yurok Tribal Council runoff forum at McKinleyville High School" rel="bookmark">True North Organizing Network hosts Yurok Tribal Council runoff forum at McKinleyville High School</a>
            </h2>
        </header>
    </div>
</article>			
						</div>
					</div>
				</div>
		
		
			

<div id="comments" class="comments-area">

		
	

	


		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/mack-high-stages-our-town/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="https://madriverunion.com/wp-login.php?redirect_to=https%3A%2F%2Fmadriverunion.com%2Fmack-high-stages-our-town%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	
</div><!-- #comments .comments-area -->
		</div>

  	
	    <div id="secondary" class="widget-area span3" role="complementary">
		<aside id="wp_sidebarlogin-3" class="widget widget_wp_sidebarlogin"><h3 class="widget-title">Login</h3>
		<form name="loginform" id="loginform" action="https://madriverunion.com/wp-login.php" method="post">
			
			<p class="login-username">
				<label for="user_login">Username</label>
				<input type="text" name="log" id="user_login" class="input" value="" size="20" />
			</p>
			<p class="login-password">
				<label for="user_pass">Password</label>
				<input type="password" name="pwd" id="user_pass" class="input" value="" size="20" />
			</p>
			
			<p class="login-remember"><label><input name="rememberme" type="checkbox" id="rememberme" value="forever" checked="checked" /> Remember Me</label></p>
			<p class="login-submit">
				<input type="submit" name="wp-submit" id="wp-submit" class="button button-primary" value="Login &rarr;" />
				<input type="hidden" name="redirect_to" value="http://madriverunion.com/category/premium/" />
			</p>
			
		</form><ul class="pagenav sidebar_login_links"><li class="lost_password-link"><a href="https://madriverunion.com/wp-login.php?action=lostpassword">Lost Password</a></li></ul></aside><aside id="text-25" class="widget widget_text">			<div class="textwidget"><p>If you don’t have an account you may subscribe directly below.</p>
<style type="text/css"> #ptp-15632 div.ptp-item-container{border-radius:0;padding:0;margin-left:0;margin-right:0}#ptp-15632 div.ptp-item-container div{margin:0}#ptp-15632 div.ptp-plan{border-top-right-radius:0;border-top-left-radius:0;font-size:1.5em;padding:.9375em 1.25em}#ptp-15632 div.ptp-price{font-size:1.75em;padding:.9375em 1.25em}#ptp-15632 div.ptp-cta{border-bottom-right-radius:0;border-bottom-left-radius:0;padding-top:1.25em;padding-bottom:1.25em}#ptp-15632 a.ptp-button{border-radius:0;font-size:1em;color:#fff;background-color:#c96236;border-bottom:#c93c00 4px solid;margin:0}#ptp-15632 a.ptp-button:hover{background-color:#c94d18}div#ptp-15632 .ptp-highlight a.ptp-button{color:#fff;background-color:#ca3c00;border-bottom:#c41300 4px solid}div#ptp-15632 .ptp-highlight a.ptp-button:hover{background-color:#c9683e}#ptp-15632 div.ptp-bullet-item{font-size:.875em;padding:.9375em .5em .9375em .5em}#ptp-15632 div.ptp-most-popular{border-radius:0;font-size:.75em}</style>
<div id="ptp-15632" class="ptp-pricing-table">
        <div class="ptp-col  ptp-highlight ptp-col-id-1"><div class="ptp-cta"><a class="ptp-button" id="ptp-15632-cta-1" href="http://madriverunion.com/subscription-options">Subscribe</a></div></div>
</div></div>
		</aside><aside id="text-30" class="widget widget_text"><h3 class="widget-title">Advertisements</h3>			<div class="textwidget"><a href="http://getreadyhumboldt.com/" target="_blank"><img src="https://madriverunion.com/wp-content/uploads/2018/11/Get-Ready-Humboldt-logo.jpg" alt="" width="110" height="160" border="0"></a>


<a href="https://madriverunion.com/arcata-summer-recreation-guide/"><img src="https://madriverunion.com/wp-content/uploads/2019/03/RECS2019-Guide-with-coversFINAL-1.jpg" alt="" width="110" height="160" border="0"></a>


<a href="https://madriverunion.com/legal-advertising-fictitious-business-name-statements-name-changes-more/"><img src="https://madriverunion.com/wp-content/uploads/2019/02/LegalAd.webad_.Newjpg.jpg" alt="" width="110" height="160" border="0"></a>

<a href="https://www.etsy.com/shop/RamblingJacksArtLab?ref=seller-platform-mcnav"><img src="<a href="https://madriverunion.com/2018-fall-activity-guide/"><img src="https://madriverunion.com/wp-content/uploads/2018/12/RamblingJacksArtLab.UnionAd.12.19.18.jpg" alt="" width="110" height="160" border="0"></a>" alt="" width="110" height="160" border="0"></a>









<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- First ad sidebar -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3490466616595796"
     data-ad-slot="3698236469"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>













<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- First ad sidebar -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3490466616595796"
     data-ad-slot="3698236469"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>



<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- First ad sidebar -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3490466616595796"
     data-ad-slot="3698236469"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>


<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- First ad sidebar -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3490466616595796"
     data-ad-slot="3698236469"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>


<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- First ad sidebar -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3490466616595796"
     data-ad-slot="3698236469"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</aside>		<aside id="recent-posts-2" class="widget widget_recent_entries">		<h3 class="widget-title">Recent Posts</h3>		<ul>
											<li>
					<a href="https://madriverunion.com/farmers-market-vendors-vote-for-partial-plaza-street-closure-on-saturdays/">Farmers Market vendors vote for partial Plaza street closure on Saturdays</a>
									</li>
											<li>
					<a href="https://madriverunion.com/forest-news-international-day-of-forests-a-saturday-volunteer-workday-and-andre-is-honored/">Forest news: International Day of Forests, a Saturday volunteer workday and Andre is honored</a>
									</li>
											<li>
					<a href="https://madriverunion.com/strike4climate-and-sustainable-futures-with-aldaron/">#strike4climate and Sustainable Futures with Aldaron</a>
									</li>
											<li>
					<a href="https://madriverunion.com/mckinleyville-rec-committee-seeks-members-dj-marv-seeks-karaokers/">McKinleyville Rec Committee seeks members, DJ Marv seeks Karaokers</a>
									</li>
											<li>
					<a href="https://madriverunion.com/mack-high-stages-our-town/">Mack High stages Our Town</a>
									</li>
					</ul>
		</aside>	</div>
	<script type='text/javascript'>
	var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-58649125-1']);
_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
            </div>
         </div>
     </div>

    
    <!-- Footer -->
    <footer id="colophon" class="site-footer dark" role="contentinfo">
        <div class="container">

            <div id="site-tools">
                <div class="row">
                    <div class="span9"><ul class="breadcrumbs"><li itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="https://madriverunion.com"><span itemprop="title">Mad River Union</span></a> </li> <li itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="https://madriverunion.com/category/entertainment/"><span itemprop="title">Entertainment</span></a></li><li> Mack High stages Our Town</li></ul></div>
                                    </div>
            </div>

            
            <div class="footer-shadown"></div>
        </div>

        <div id="site-info" class="container">
            <div class="clearfix">
                <div class="copyright">
                    <p>Copyright &copy; 2014 by <a href="http://www.madriverunion.com" title="DW Focus" rel="nofollow">Mad River Union</a></p>
                    <p>All Rights Reserved</p>
                </div>
                <div class="logo">
                    <a class="small-logo" href="https://madriverunion.com/" title="Mad River Union" rel="home">Mad River Union</a>
                </div>
            </div>
        </div>
    </footer><!-- #colophon .site-footer -->
<a class="scroll-top" href="#masthead" title="Scroll to top">Top</a>
		<script type="text/javascript">
		/*<![CDATA[*/
		var gmapstyles = 'default';
		/* ]]> */
		</script>		
		<!-- Instagram Feed JS -->
<script type="text/javascript">
var sbiajaxurl = "https://madriverunion.com/wp-admin/admin-ajax.php";
</script>

<script type="text/javascript">
    window._tpm = window._tpm || [];
    window._tpm['paywallID'] = '0'; 
    window._tpm['sandbox'] = false; 
    window._tpm['trackPageview'] = false; 
</script>

	<div style="display:none">
	<div class="grofile-hash-map-bf535201942314b455964ae40aec0404">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/madriverunion.com\/mack-high-stages-our-town\/":47906};
	</script>
				<link rel='stylesheet' id='eventon_dynamic_styles-css'  href='https://madriverunion.com/wp-content/plugins/eventON/assets/css/eventon_dynamic_styles.css?ver=5.1.1' type='text/css' media='all' />
<script type='text/javascript' src='https://madriverunion.com/wp-content/plugins/ditty-news-ticker/assets/js/jquery.touchSwipe.min.js?ver=1546044261'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/plugins/ditty-news-ticker/assets/js/jquery.easing.1.3.js?ver=1.3'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/plugins/ditty-news-ticker/assets/js/imagesloaded.pkgd.min.js?ver=4.1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mtphr_dnt_vars = {"is_rtl":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/plugins/ditty-news-ticker/assets/js/ditty-news-ticker.js?ver=1546044261'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/plugins/gabfire-widget-pack/js/jquery.tools.min.js?ver=5.1.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sb_instagram_js_options = {"sb_instagram_at":"1594887313.M2E4MWE5Zg==.MmE2ZGE0MTllOTEz.NDM2Mjg2OTg3Mjg5MTA0OWYzN2Q=","font_method":"svg"};
/* ]]> */
</script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/plugins/instagram-feed/js/sb-instagram.min.js?ver=1.11.2'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201912'></script>
<script type='text/javascript' data-cfasync="false" src='https://madriverunion.com/wp-content/plugins/s2member/s2member-o.php?ws_plugin__s2member_js_w_globals=1&#038;qcABC=1&#038;ver=170722-170722-253714573'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-includes/js/wp-embed.min.js?ver=5.1.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=7.0.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
</script>
		<script>
			jQuery( document ).ready( function($) {
							$( '#mtphr-dnt-12580' ).ditty_news_ticker({
					id : '12580',
					type : 'scroll',
					scroll_direction : 'left',
					scroll_speed : 6,
					scroll_pause : 0,
					scroll_spacing : 40,
					scroll_init : 0,
					rotate_type : 'slide_left',
					auto_rotate : 0,
					rotate_delay : 7,
					rotate_pause : 0,
					rotate_speed : 3,
					rotate_ease : 'linear',
					nav_reverse : 0,
					disable_touchswipe : 0,
					offset : 20,
					after_load : function( $ticker ) {
											},
					before_change : function( $ticker ) {
											},
					after_change : function( $ticker ) {
											}
				});
			 			});
		</script>
		<script type='text/javascript' src='https://stats.wp.com/e-201912.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.0.1',blog:'147660978',post:'47906',tz:'-7',srv:'madriverunion.com'} ]);
	_stq.push([ 'clickTrackerInit', '147660978', '47906' ]);
</script>
</body>
</html>