

<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" />
<meta content="width=device-width, initial-scale=1.0, user-scalable=no" name="viewport">
<meta name="google-site-verification" content="yFaDpIXoz-j5sCQSr6YC6Y8hdsu-3ea-T93cMXASqIU" />
<title>Letters to the Editor, February 17, 2021 | Mad River Union</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://madriverunion.com/xmlrpc.php" />
<!--[if lt IE 9]>
<script src="https://madriverunion.com/wp-content/themes/mru-focus/assets/js/html5.js" type="text/javascript"></script>
<![endif]-->
<link rel='dns-prefetch' href='//code.tinypass.com' />
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Mad River Union &raquo; Feed" href="https://madriverunion.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mad River Union &raquo; Comments Feed" href="https://madriverunion.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mad River Union &raquo; Letters to the Editor, February 17, 2021 Comments Feed" href="https://madriverunion.com/letters-to-the-editor-february-17-2021/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/madriverunion.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='tp-sidebar-login-css'  href='https://madriverunion.com/wp-content/plugins/tt-sidebar-login-widget/assets/css/tt-sidebar-login.css?ver=5.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.6.1/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='ditty-news-ticker-font-css'  href='https://madriverunion.com/wp-content/plugins/ditty-news-ticker/inc/static/libs/fontastic/styles.css?ver=2.3.7' type='text/css' media='all' />
<link rel='stylesheet' id='ditty-news-ticker-css'  href='https://madriverunion.com/wp-content/plugins/ditty-news-ticker/inc/static/css/style.css?ver=1612289768' type='text/css' media='all' />
<link rel='stylesheet' id='gabfire-widget-css-css'  href='https://madriverunion.com/wp-content/plugins/gabfire-widget-pack/css/style.css?ver=5.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='sidebar-login-css'  href='https://madriverunion.com/wp-content/plugins/sidebar-login/build/sidebar-login.css?ver=1603739335' type='text/css' media='all' />
<link rel='stylesheet' id='dw_focus_template-css'  href='https://madriverunion.com/wp-content/themes/mru-focus/assets/css/template.css?ver=5.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='dw_focus_responsive-css'  href='https://madriverunion.com/wp-content/themes/mru-focus/assets/css/responsive.css?ver=5.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='style-css'  href='https://madriverunion.com/wp-content/themes/mru-focus/style.css?ver=5.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='print-style-css'  href='https://madriverunion.com/wp-content/themes/mru-focus/assets/css/print.css?ver=5.6.1' type='text/css' media='print' />
<link rel='stylesheet' id='dw-focus-qa-css'  href='https://madriverunion.com/wp-content/themes/mru-focus/dwqa-templates/style.css?ver=5.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='evcal_google_fonts-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400%2C300%7COpen+Sans%3A700%2C400%2C400i%7CRoboto%3A700%2C400&#038;ver=5.6.1' type='text/css' media='screen' />
<link rel='stylesheet' id='evcal_cal_default-css'  href='//madriverunion.com/wp-content/plugins/eventON/assets/css/eventon_styles.css?ver=2.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='evo_font_icons-css'  href='//madriverunion.com/wp-content/plugins/eventON/assets/fonts/font-awesome.css?ver=2.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='eventon_dynamic_styles-css'  href='//madriverunion.com/wp-content/plugins/eventON/assets/css/eventon_dynamic_styles.css?ver=2.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='evo_fc_styles-css'  href='https://madriverunion.com/wp-content/plugins/eventon-full-cal/assets/fc_styles.css?ver=5.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/9.4/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/9.4/css/jetpack.css' type='text/css' media='all' />
<link rel='stylesheet' id='ws-plugin--s2member-css'  href='https://madriverunion.com/wp-content/plugins/s2member/s2member-o.php?ws_plugin__s2member_css=1&#038;qcABC=1&#038;ver=201225-201225-252523928' type='text/css' media='all' />
<script type='text/javascript' src='https://code.tinypass.com/tpl/d1/tpm.js?ver=5.6.1' id='tpm.js-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.6.1/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.6.1/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/themes/mru-focus/assets/js/bootstrap.min.js?ver=5.6.1' id='bootstrap-js'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/themes/mru-focus/assets/js/jquery.infinitescroll.min.js?ver=5.6.1' id='infinitescroll-js'></script>
<script type='text/javascript' id='dw_focus-js-extra'>
/* <![CDATA[ */
var dw_focus = {"ajax_url":"https:\/\/madriverunion.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/themes/mru-focus/assets/js/custom.js?ver=5.6.1' id='dw_focus-js'></script>
<script type='text/javascript' src='//platform.twitter.com/widgets.js?ver=5.6.1' id='twitter-indent-js'></script>
<script type='text/javascript' id='single-social-js-extra'>
/* <![CDATA[ */
var dw_focus = {"ajax_url":"https:\/\/madriverunion.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/themes/mru-focus/assets/js/single-socials.js?ver=5.6.1' id='single-social-js'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/themes/mru-focus/assets/js/jquery.mouse.move.js?ver=5.6.1' id='mouse-move-js'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/themes/mru-focus/assets/js/jquery.swipe.js?ver=5.6.1' id='swipe-js'></script>
<link rel="https://api.w.org/" href="https://madriverunion.com/wp-json/" /><link rel="alternate" type="application/json" href="https://madriverunion.com/wp-json/wp/v2/posts/58998" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://madriverunion.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://madriverunion.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.6.1" />
<link rel="canonical" href="https://madriverunion.com/letters-to-the-editor-february-17-2021/" />
<link rel='shortlink' href='https://wp.me/p9ZzmG-flA' />
<link rel="alternate" type="application/json+oembed" href="https://madriverunion.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmadriverunion.com%2Fletters-to-the-editor-february-17-2021%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://madriverunion.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmadriverunion.com%2Fletters-to-the-editor-february-17-2021%2F&#038;format=xml" />
<style></style><meta property="og:title" content="Letters to the Editor, February 17, 2021" /><meta property="og:url" content="https://madriverunion.com/letters-to-the-editor-february-17-2021/" /><meta property="og:image" content="https://madriverunion.com/wp-content/uploads/2020/09/463897461_sm-2-4050063-copy-110x73.jpg" /><meta property="og:description" content="Non-extremist Christians still alive, well and around As a Presbyterian minister in McKinleyville, I feel compelled to respond to Gail Ledbetter’s “Christians gone awry” piece in last week’s Union. As with Jan Phelps’ letter concerning religious hypocrisy, it might surprise Ms. Ledbetter that I agree with almost everything she and Ms. Phelps said, except for&lt;a href=&quot;https://madriverunion.com/letters-to-the-editor-february-17-2021/&quot; title=&quot;Read more&quot; &gt;...&lt;/a&gt;"/>    <style type="text/css">
        
        
            </style>
    <link rel="shortcut icon" href="https://madriverunion.com/wp-content/themes/mru-focus/assets/img/favicon.ico">

<!-- EventON Version -->
<meta name="generator" content="EventON 2.7.2" />


<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Letters to the Editor, February 17, 2021" />
<meta property="og:url" content="https://madriverunion.com/letters-to-the-editor-february-17-2021/" />
<meta property="og:description" content="Non-extremist Christians still alive, well and around As a Presbyterian minister in McKinleyville, I feel compelled to respond to Gail Ledbetter’s “Christians gone awry” piece in last week’s Union.…" />
<meta property="article:published_time" content="2021-02-21T09:45:27+00:00" />
<meta property="article:modified_time" content="2021-02-21T15:36:40+00:00" />
<meta property="og:site_name" content="Mad River Union" />
<meta property="og:image" content="https://madriverunion.com/wp-content/uploads/2020/09/463897461_sm-2-4050063-copy.jpg" />
<meta property="og:image:width" content="960" />
<meta property="og:image:height" content="639" />
<meta property="og:image:alt" content="Letters" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@madriverunion" />
<meta name="twitter:text:title" content="Letters to the Editor, February 17, 2021" />
<meta name="twitter:image" content="https://madriverunion.com/wp-content/uploads/2020/09/463897461_sm-2-4050063-copy.jpg?w=640" />
<meta name="twitter:image:alt" content="Letters" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-3490466616595796",
    enable_page_level_ads: true
  });
</script>
<script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head>
<body class="post-template-default single single-post postid-58998 single-format-standard desktop  not-login group-blog" >
	<header id="masthead" class="site-header" role="banner">
	    <div class="container">
	    	<div id="header">
	    		<div class="row">
	    			<div id="mtphr-dnt-12580" class="mtphr-dnt mtphr-dnt-12580 mtphr-dnt-default mtphr-dnt-scroll mtphr-dnt-scroll-left"><div class="mtphr-dnt-wrapper mtphr-dnt-clearfix"><h3 class="mtphr-dnt-title mtphr-dnt-inline-title"></h3><div class="mtphr-dnt-tick-container" style="padding-top:3px;padding-bottom:3px;"><div class="mtphr-dnt-tick-contents"><div style="height:20px;" class="mtphr-dnt-tick mtphr-dnt-default-tick mtphr-dnt-clearfix "><a href="http://madriverunion.com/marna-powell-awesomeness-at-stone-lagoon-benefit-for-dry-lagoon-saturday-nov-1/" target="_self">Subscribe to your local newspaper and support community journalism…</a></div><div style="height:20px;" class="mtphr-dnt-tick mtphr-dnt-default-tick mtphr-dnt-clearfix "><a href="http://crushallboxes.blogspot.com" target="_self">Authentic Arcata Ridge Trail markers available at Union office in Jacoby’s Storehouse…</a></div></div></div></div></div>	           		<div id="branding" class="span3 visible-desktop">
		                <h1>
		                	<a href="https://madriverunion.com/" title="Mad River Union" rel="home">
		                		Mad River Union		                	</a>
		                </h1>
		            </div>
		            		            <div id="sidebar-header" class="span9">
	            		<aside id="text-31" class="widget widget_text">			<div class="textwidget"></div>
		</aside>		            </div>
		            		        </div>
	        </div>
	        		            <div class="btn-group top-news">
				    	        <a class="dropdown-toggle" data-toggle="dropdown" href="#">
            <span class="number">2</span>
            <span>New Articles today <i class="icon-caret-down"></i></span>
        </a>
                    <div class="top-news-inner">
                <ul class="dropdown-menu">
                    <div class="entry-meta">February 21, 2021</div>

                    <div class="row-fluid">
                        <ul>
                            <li class="has-thumbnail first">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/humboldt-states-five-year-strategic-plan-unveiled/" title="Humboldt State&#8217;s five-year strategic plan unveiled"><img width="30" height="40" src="https://madriverunion.com/wp-content/uploads/2021/02/HSU-Master-Plan-110x147.jpg" class="attachment-40x40 size-40x40 wp-post-image" alt="" loading="lazy" srcset="https://madriverunion.com/wp-content/uploads/2021/02/HSU-Master-Plan-110x147.jpg 110w, https://madriverunion.com/wp-content/uploads/2021/02/HSU-Master-Plan-230x306.jpg 230w, https://madriverunion.com/wp-content/uploads/2021/02/HSU-Master-Plan-640x852.jpg 640w, https://madriverunion.com/wp-content/uploads/2021/02/HSU-Master-Plan.jpg 928w" sizes="(max-width: 30px) 100vw, 30px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/humboldt-states-five-year-strategic-plan-unveiled/" title="Humboldt State&#8217;s five-year strategic plan unveiled"> Humboldt State&#8217;s five-year strategic plan unveiled </a></div>
                </li>
                            <li class="has-thumbnail">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/letters-to-the-editor-february-17-2021/" title="Letters to the Editor, February 17, 2021"><img width="40" height="27" src="https://madriverunion.com/wp-content/uploads/2020/09/463897461_sm-2-4050063-copy-110x73.jpg" class="attachment-40x40 size-40x40 wp-post-image" alt="Letters" loading="lazy" srcset="https://madriverunion.com/wp-content/uploads/2020/09/463897461_sm-2-4050063-copy-110x73.jpg 110w, https://madriverunion.com/wp-content/uploads/2020/09/463897461_sm-2-4050063-copy-230x153.jpg 230w, https://madriverunion.com/wp-content/uploads/2020/09/463897461_sm-2-4050063-copy-640x426.jpg 640w, https://madriverunion.com/wp-content/uploads/2020/09/463897461_sm-2-4050063-copy.jpg 960w" sizes="(max-width: 40px) 100vw, 40px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/letters-to-the-editor-february-17-2021/" title="Letters to the Editor, February 17, 2021"> Letters to the Editor, February 17, 2021 </a></div>
                </li>
              
                        </ul>
                    </div>
                </ul>
            </div>
            				    </div>
			
		    <div class="wrap-navigation">
		        <nav id="site-navigation" class="main-navigation navbar" role="navigation">
		            <div class="navbar-inner">
						<button class="btn btn-navbar" data-target=".nav-collapse" data-toggle="collapse"  type="button">
							<span class="icon-bar"></span>
							<span class="icon-bar"></span>
							<span class="icon-bar"></span>
						</button>

						<button class="collapse-search hidden-desktop" data-target=".search-collapse" data-toggle="collapse" >
							<i class="icon-search"></i>
						</button>

						<a class="small-logo hidden-desktop" rel="home" title="DW Focus" href="https://madriverunion.com/">DW Focus</a>
					
												<ul class="social-links visible-desktop">
																																																</ul><!-- End social links -->

						<div class="search-collapse collapse">
								<form method="get" name="searchForm" class="searchForm" action="https://madriverunion.com/" role="search">
		<input type="text" class="field" name="s" value="" placeholder="Search &hellip;" />
		<input type="submit" class="submit" name="submit" value="Search" />
	</form>
						</div>

						<div class="nav-collapse collapse">
							<ul id="menu-primary-menu" class="nav"><li id="menu-item-12432" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12432 color-none 0"><a href="https://madriverunion.com/category/featured/">Featured</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-12433" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12433 color-yellow 0"><a href="https://madriverunion.com/category/news/">News</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-12430" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12430 color-green 0"><a href="https://madriverunion.com/category/community/">Community</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-12434" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12434 color-orange 0"><a href="https://madriverunion.com/category/opinion/">Opinion</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-12431" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12431 color-violet 0"><a href="https://madriverunion.com/category/entertainment/">Entertainment</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-15879" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15879 color-none 0"><a href="https://madriverunion.com/category/premium/">Premium</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-12429" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-parent-item menu-parent-item menu-item-12429 0"><a href="https://madriverunion.com/about/">About the Union</a><i class="sub-menu-collapse icon-chevron-down hidden-desktop"></i>
<ul class="sub-menu">
	<li id="menu-item-12427" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12427 active 1"><a href="https://madriverunion.com/submission-guide/">Submission Guide</a></li>
	<li id="menu-item-40768" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40768 1"><a href="https://madriverunion.com/about/comment-policy/">Comment Policy</a></li>
	<li id="menu-item-12426" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12426 1"><a href="https://madriverunion.com/where-to-buy-the-mad-river-union/">Where To Buy</a></li>
	<li id="menu-item-12428" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12428 1"><a href="https://madriverunion.com/advertising/">Ad/Legal Rates and Sample Ads</a></li>
	<li id="menu-item-12425" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12425 1"><a href="https://madriverunion.com/contact-us/">Contact Us</a></li>
</ul>
</li>
<li id="menu-item-15865" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15865 0"><a href="https://madriverunion.com/subscription-options/">Subscribe</a></li>
</ul>						</div>	
		            </div>
		        </nav>

		        <div id="under-navigation" class="clearfix under-navigation">
		        	<div class="row-fluid">
		        				        				        		<!-- Under navigation positions ( breadcrum, twitter widgets) -->
			        	<div class="span9">
							        
        <aside id="dw_focus_news_headlines-5" class="widget dw_focus_headlines">        <h3 class="widget-title">New Stories</h3>        <div class="headlines" data-interval="5000">
            <ul>
                            <li><a href="https://madriverunion.com/humboldt-states-five-year-strategic-plan-unveiled/">Humboldt State&#8217;s five-year strategic plan unveiled</a><span class="time_diff"> - 29 mins ago</span></li>
                            <li><a href="https://madriverunion.com/letters-to-the-editor-february-17-2021/">Letters to the Editor, February 17, 2021</a><span class="time_diff"> - 7 hours ago</span></li>
                            <li><a href="https://madriverunion.com/arcata-bottom-cannabis-project-comment-sought/">Arcata Bottom cannabis project comment sought</a><span class="time_diff"> - 16 hours ago</span></li>
                            <li><a href="https://madriverunion.com/explosion-fire-destroy-bayview-street-home/">Explosion, fire destroy Bayview Street home</a><span class="time_diff"> - 2 days ago</span></li>
                            <li><a href="https://madriverunion.com/big-or-bigger-covid-19-surge-predicted/">COVID variants complicate planning</a><span class="time_diff"> - 2 days ago</span></li>
                 
            </ul>
        </div>
        </aside><aside id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"></div></aside>						</div>
						
						<div class="span3 ">	<form method="get" name="searchForm" class="searchForm" action="https://madriverunion.com/" role="search">
		<input type="text" class="field" name="s" value="" placeholder="Search &hellip;" />
		<input type="submit" class="submit" name="submit" value="Search" />
	</form>
</div>
					</div>
			    </div>
		    </div>
	    </div>
	</header> <!-- End header -->

	<div id="main">
         <div class="container">
             <div class="row">


    <div id="primary" class="site-content span9">

	
		
<article id="post-58998" class="post-58998 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-opinion tag-letters-to-the-editor content-print">
	<header class="entry-header">
		<h1 class="entry-title">Letters to the Editor, February 17, 2021</h1>
		
		<div class="entry-meta">
			<ul class="post-categories">
	<li><a href="https://madriverunion.com/category/featured/" rel="tag">Featured</a></li>
	<li><a href="https://madriverunion.com/category/opinion/" rel="tag">Opinion</a></li></ul><time class="entry-date" datetime="2021-02-21T01:45:27-08:00" pubdate>7 hours ago</time>		</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

			<!-- <div class="entry-thumbnail">
			<img width="960" height="639" src="https://madriverunion.com/wp-content/uploads/2020/09/463897461_sm-2-4050063-copy.jpg" class="attachment- size- wp-post-image" alt="Letters" loading="lazy" srcset="https://madriverunion.com/wp-content/uploads/2020/09/463897461_sm-2-4050063-copy.jpg 960w, https://madriverunion.com/wp-content/uploads/2020/09/463897461_sm-2-4050063-copy-230x153.jpg 230w, https://madriverunion.com/wp-content/uploads/2020/09/463897461_sm-2-4050063-copy-640x426.jpg 640w, https://madriverunion.com/wp-content/uploads/2020/09/463897461_sm-2-4050063-copy-110x73.jpg 110w" sizes="(max-width: 960px) 100vw, 960px" />		</div> --> <!-- from content-single.php -->
	
	<div class="entry-content">
		<p style="text-align: center;"><strong>Non-extremist Christians still alive, well and around</strong></p>
<p>As a Presbyterian minister in McKinleyville, I feel compelled to respond to Gail Ledbetter’s “Christians gone awry” piece in last week’s <i>Union</i>. As with Jan Phelps’ <a href="https://madriverunion.com/letters-to-the-editor-february-10-2021/"><strong>letter concerning religious hypocrisy,</strong></a> it might surprise Ms. Ledbetter that I agree with almost everything she and Ms. Phelps said, except for her last paragraph in which she writes, “Decent, kind, inclusive, forgiving, loving Christians seems to have gone silent or disappeared.”</p>
<p>Unfortunately, it seems that White Christian nationalists are the only ones getting media attention these days – especially on the national scene – the most recent example being that of the insurrection that took place at our national capitol on January 6th.<span class="Apple-converted-space"> </span></p>
<p>Ms. Ledbetter astutely points out that this kind of so-called Christianity is every bit as hateful and backward as Muslim extremists. I would also add that every major world religion has their extreme splinter groups: Judaism, Islam and Christianity. Think of the Jews who want to annihilate the Palestinians, Islamic terrorists, the Ku Klux Klan, Proud Boys, Oath Keepers or whatever modern White Supremacists call themselves these days… they are all terrorists, we must now recognize that some of them are home grown.</p>
<p>I am sorry Ms. Ledbetter has a relative that prays to Trump, but this is not Christianity, it is idolatry, and those who claim to be a person of faith who worship anything other than God are following a cult, not a religion. They most certainly are not listening to the teachings of Jesus. And just so I am not accused of being judgmental, I believe that every person has their own unique path (or not) to the divine life, and that path should be respected. However, praying to a person, as opposed to praying for someone, is idolatry by any world religion’s definition.<span class="Apple-converted-space"> </span></p>
<p>My husband (a Lutheran pastor) and I have been preaching and teaching against the dangers of fascism and white supremacy for most of 2020. The parallels between what happened in Germany with the Third Reich and our own country should be alarming for anyone paying attention — including the Christian church’s complicity and silence. We have been trying to make our voices heard, but unfortunately, forgiveness, inclusivity and love rarely get media attention. Hate and violence increase ratings and make money!<span class="Apple-converted-space"> </span></p>
<p>Our church, Grace Good Shepherd, had a confrontation with a truck load of Trump supporters when they drove up on our lawn because of our Black Lives Matter sign that also supported immigrant and gay rights. We are doing our best to practice what we preach, but it is difficult when a lot of people want to assume all Christians are the same. We are not perfect, none of us is, but we are trying to live as Ms. Ledbetter was raised, that “God is Life, Love, Truth, Spirit.”<span class="Apple-converted-space"> </span></p>
<p>There was a small “Confessing Church” in Germany who worked against Hitler and even saved many Jewish people from certain death. While I hope it never comes to that, I know there are several progressive churches in Humboldt County, as well as synagogues, and Buddhist groups who do not support religious fundamentalism or white Christian nationalism, but embrace the Golden Rule. I, too am sad, sad that our voices have not been loud enough to hear.</p>
<p><b>Deborah Hubbard<br />
</b><b>McKinleyville</b></p>
<p style="text-align: center;"><a href="http://madriverunion.com/subscription-options/"><b><i>Subscribe to the Mad River Union and enjoy online access to the full print edition for just $40/year!</i></b></a></p>
<p style="text-align: center;"><strong>Affirmation matters</strong></p>
<p>A few members of our Humboldt Unitarian Universalist Congregation stand on a Eureka corner Saturdays during the noon hour with a “Black Lives Matter” banner. We’re encouraged by friendly waves, smiles, peace signs, and thumbs up from passing drivers.</p>
<p>We’re also perplexed and saddened that our witness is occasionally responded to with obscene shouts and gestures. How can a simple affirmation in support of allowing people to live evoke such vehement anger?<span class="Apple-converted-space"> </span></p>
<p>Nearly every Saturday, at least one passer-by says, “All lives matter.” We answer with an agreeable nod, smile, and thumbs-up. When, however, “ALL LIVES MATTER (plus a four-syllable expletive)” is yelled at us in rage as the driver accelerates away, we’re unable to respond.<span class="Apple-converted-space"> </span></p>
<p>On occasions when a pedestrian has stopped to talk or a driver has parked and walked back to join or question us, our conversations have been positive.<span class="Apple-converted-space"> </span></p>
<p>Not one of us denies that all lives matter. Nor suggests that only Black lives matter.<span class="Apple-converted-space"> </span></p>
<p>We stand to protect people who are at risk. We have to recognize how often Black people are reacted to with fear, suspicion, violence and murder. Our country has awakened to the urgency of repairing fractured and antagonistic relationships.<span class="Apple-converted-space"> </span></p>
<p>Let us all say, “All lives matter” and really mean it.<span class="Apple-converted-space"> </span></p>
<p>If any of us find ourselves unable to publicly say, “Black lives matter,” we must ask ourselves, “What is preventing me from affirming the value of Black people?”</p>
<p><b>Alison O’Dowd, Arcata<br />
</b><b>Allison Bronkall, Eureka<br />
</b><b>Berti Welty, Indianola<br />
</b><b>Beverly Morgan Lewis, Eureka<span class="Apple-converted-space"><br />
</span></b><b>Bonnie MacGregor, McKinleyville<br />
</b><b>Celestine Armenta, Bayside<br />
</b><b>Cena Marino, Eureka<br />
</b><b>Chip Sharpe, Bayside<span class="Apple-converted-space"><br />
</span></b><b>Colleen Broderick, Humboldt Hill<br />
</b><b>Cynthia Chason, McKinleyville<span class="Apple-converted-space"><br />
</span></b><b>David Marshak, Arcata<br />
</b><b>Deborah Cooper, Arcata<br />
</b><b>John Schaefer, Arcata<br />
</b><b>Kate McClain, McKinleyville<span class="Apple-converted-space"><br />
</span></b><b>Mary Jo Stepp, Arcata<br />
</b><b>Peggy Ho, Cutten<br />
</b><b>Sylvia Shaw, Arcata<br />
Terry Uyeki, McKinleyville</b></p>
<p style="text-align: center;"><strong>Reform Arcata House</strong></p>
<p>I wish to rebut Darlene Spoor’s grandiose <a href="https://madriverunion.com/letters-to-the-editor-january-6-2020/"><strong>opinion of the success</strong></a> of the “Arcata House Partnership” (AHP) of which she heads up as its top director.</p>
<p>Through my own (very personal) experience and having also viewed the treatment of other of their clients and former employees, AHP has, too often, lacked common respect of these individuals and their basic human rights and dignities.</p>
<p>Being a non-profit, 501(c) organization, they, like religious, faith-based organizations, seem to be exempt from the same rules and conduct that are required by a public funded, civil government.</p>
<p>All such organizations such as AHP should be made to adhere to a (protected) standard of correct and humane treatment to all clients, under the law.<span class="Apple-converted-space"> </span></p>
<p>Furthermore, any such organization receiving public funding and government grants should have close oversight and review by the government and the general public. The local governments should put in place open grievance procedures for any complaints, and records should be kept and referred to, before allowing any further funding of such a group.</p>
<p>When and if any civil government wishes to avoid and relegate their “rightful” duties to an “outside” organization, they must then become ultimately responsible for such an organization.<span class="Apple-converted-space"> </span></p>
<p>Lastly, I welcome and look forward to any responsible, non-partisan, open investigation and review the “workings” of AHP during the last five years.</p>
<p>These and all such groups should allow anyone having concerns to openly address their entire Board of Directors in an open meeting to demand proper connections and total transparency.</p>
<p>Thank you,<span class="Apple-converted-space"><br />
</span><b>Michael Robert Langdon<br />
</b><b>Arcata</b></p>
<p style="text-align: center;"><strong>Levels of scumbag</strong></p>
<p>A <a href="https://madriverunion.com/letters-to-the-editor-february-10-2021/"><strong>letter submission</strong></a> attempting to defend the Antifa-led riots in Portland and Seattle resented being compared in a previous submission to the Insurrectionists in the U.S. Capitol.<span class="Apple-converted-space"> </span></p>
<p>I can see the point, as the latter certainly has serious implications for democracy. I found it ironic that the defender of Antifa said there was no organization and no leaders and the rioters weren’t really Antifa, but the rioters put up an Antifa banner with the Antifa cause.<span class="Apple-converted-space"> </span></p>
<p>Since the letter writer said there was no organization or leaders and the rioters said they identified with Antifa, the letter writer was in no position to say they were or weren’t.<span class="Apple-converted-space"> </span></p>
<p>They trashed Democratic offices and protested Joe Biden, but “property damage is not commensurate with a violent attempted coup.” One hundred percent agree.<span class="Apple-converted-space"> </span></p>
<p>You did realize that in October, a self-identified Antifa sympathizer shot dead a right wing protester, and later was shot and killed himself by U.S. Marshals. That sounds suspiciously like a bit more than property damage, especially when one factors in other deaths and mayhem in the occupied area of Seattle.<span class="Apple-converted-space"> </span></p>
<p>Perhaps we can agree that the rioters identifying as Antifa are not the same level of scumbag as the Insurrectionist mob. It’s not a ringing endorsement, but it is the best I can muster.</p>
<p>Regards,<br />
<b>John Dillon<br />
</b><b>Eureka</b></p>
<p style="text-align: center;"><strong>Why the D.C. riots?</strong></p>
<p>On Jan. 7, the day after the D.C. riots, I sent an opinion piece to the <i>Washington Post </i>that went unpublished.<span class="Apple-converted-space"> </span></p>
<p>I did not submit it locally because it was more likely that our elected officials would see it in the Post.<span class="Apple-converted-space"> </span></p>
<p>By the time the <i>Post</i> responded to my opinion the topic was no longer news worthy.</p>
<p>Today (Feb. 10, <i><a href="http://wapo.st/3a6loif"><strong>wapo.st/3a6loif</strong></a>)</i> the Post published the result of their investigation into the people that have been arrested as a result of the riot and now my topic is pertinent again. My comments are below:</p>
<p>I hope that you, elected official, do not think that you are innocent victims in the D.C. riots that occurred on Jan. 6.<span class="Apple-converted-space"> </span></p>
<p>Trump cannot be crazy if he has nearly half of the nation willing to support him in such an undemocratic demonstration. He has tapped into the anger, frustration and mistrust that the declining middle class has and he is using that to bludgeon his way into power.<span class="Apple-converted-space"> </span></p>
<p>You, elected officials, are the ones who have set the stage for Trump’s assent. You, elected officials, stood by and continue to make policies that have eviscerated the middle class.<span class="Apple-converted-space"> </span></p>
<p>So now, you, elected officials, get to experience in small part what your poor judgment has foisted on the nation.</p>
<p>For three generations the middle class has experienced governmental policies that have resulted in a declining standard of living.<span class="Apple-converted-space"> </span></p>
<p>The working class is fully aware of your practice of favoring corporate profitability and high-income donors while withholding approaches that would grow the economy from the bottom up.<span class="Apple-converted-space"> </span></p>
<p>You are not kidding anyone. After all these years, your policies have <i>not</i> created a rising tide.</p>
<p>So, elected officials, look in the mirror. See how you have managed our Democracy to the point that such a siginificant percentage of the populace is willing to not only vote for a fluke like Trump but is willing to riot on his command. You are not innocent victims!</p>
<p>But you are the leadership that we need at this time. We need you to guide us into a democracy that values the working class. I urge you to begin anew and make choices that will build the middle class’s earning power.<span class="Apple-converted-space"> </span></p>
<p>I urge you to think about the part you play on the stage of democracy and act in a manner that benefits all the people of this teetering nation.</p>
<p><b>Patti Rose<br />
</b><b>McKinleyville</b></p>
<p style="text-align: center;"><strong>A spectre’s summary</strong></p>
<p>As you recover from watching rampaging rednecks take a gnarly dump on democracy, far be it from me to drop another psychogenic bomb on your already shell-shocked wits.</p>
<p>But as I assume my role as the spectre at the banquet, I must take sardonic pleasure in assuring you that even as the Cheeto-in-Chief does a Twitter-less fade-out to Florida, you still ain’t safe!</p>
<p>Even if Chuck Schumer has a fit of fortitude as the Senate does a weak flip from right to left, they are still out there and they are still gonna getcha! Right about now you’re reaching for your cell phone to call 911 as you look furtively up and down the street through the window blinds. What’s this guy talking about? Who’s gonna get me?</p>
<p>C’mon folks, you know who they are. The deceptively human-looking alien lizard-creatures disguised as your friends, co-workers and that in-law whose name you can never remember.</p>
<p>The smiling faces who pretended to celebrate the end of racism in America with you when Barack Obama was elected — then voted to send your ass on a collision course with a bunch of whack jobs having a Tea Party.</p>
<p>Like kids who act up most right before lights-out, they lasted a couple of election cycles before getting tired and put to bed. But then the Angry Creamsicle woke them up again. With Captain Chaos in the White House they felt safe enough to reveal their true form; you saw them on TV brandishing torches in Charlottesville and assault rifles in Kenosha.</p>
<p>On Jan. 6 you watched them kill a police officer for doing his job even as another officer narrowly saved the Vice President from getting hung for doing his.</p>
<p>Don’t let them gaslight you into thinking they’ve given up as they take on human form again, hiding right in plain sight as someone you think you know.</p>
<p>When you’re not watching they’ll conjure alternate reality conspiracy theories in online Cult45 forums as they wait for an opportunity to strike again from their outpost on the Planet of the Screaming Carrot Demon.</p>
<p>They’ll be the ones quietly electing wingnuts anxious to legislate their certainty that devil-worshiping pedophiles are trafficking child sex while drinking blood with Hillary Clinton in the basement of a pizza parlor.</p>
<p>They’ll be the closet “patriots” having a field day as they rush to fill out the paperwork for candidacy in 2022, looking for new and improved ways to keep anybody who isn’t white from voting.</p>
<p>The only way this scenario doesn’t end with the Forces of Evil marketing an upgraded version of Agent Orange four years from now is if people realize the threat not only walks among us, folks, it votes. Without a firewall of people casting votes for anyone whose platform doesn’t resemble something written by Ted Nugent on acid, Cheeto Jesus’ apostles will happily take Congress back.</p>
<p>Don’t assume Joe Biden’s election means the worst is over, or that everyone who supports Fuckface Von Clownstick wears a MAGA hat.</p>
<p>This is where I am compelled to remind you that the price of freedom is eternal vigilance. In short, if you snooze, you lose.</p>
<p><b>David Courtland<br />
</b><b>Thousand Oaks</b></p>
<p style="text-align: center;"><strong>The enemy is within</strong></p>
<p>Is the pro-pandemic, genocidal GOP still the party of the defeated, deranged racist traitor Donald Trump? Or is the Republican Party now following the fanatical footsteps of that other infamous homicidal American politician Dan White, the crazy ex-cop who murdered San Francisco Mayor George Moscone and Supervisor Harvey Milk?</p>
<p>Actually, FOX News’ favorite fresh fascist face Marjorie Taylor Greene (R-Georgia) appears to conveniently enough be the political combination of Donald Trump and Dan White – a pathologically dishonest, crackpot QAnon conspiracy theorist whose hatred is clearly putting her on the path of political assassination and domestic terrorism. Marjorie is a violent psycho!<span class="Apple-converted-space"> </span></p>
<p>But the tangerine tyrant Trump says Greene is “a future Republican Star”. Here’s a suggestion for you neo-Nazi Republicans: next time you attempt a domestic terrorist takeover, hijacking the federal government with hateful hillbillies is probably not the most effective approach.<span class="Apple-converted-space"> </span></p>
<p>No “Twinkie defense” for Trump.</p>
<p><span class="Apple-converted-space"> </span>Sincerely,<span class="Apple-converted-space"><br />
</span><b>Jake Pickering<span class="Apple-converted-space"><br />
</span></b><b>Arcata</b></p>
<p>&nbsp;</p>
<p><ins class="adsbygoogle" style="display: inline-block; width: 728px; height: 90px;" data-ad-client="ca-pub-3490466616595796" data-ad-slot="7921456462"></ins><br />
<script><br />
(adsbygoogle = window.adsbygoogle || []).push({});<br />
</script><br />
<ins class="adsbygoogle" style="display: inline-block; width: 336px; height: 280px;" data-ad-client="ca-pub-3490466616595796" data-ad-slot="3851720064"></ins><br />
<script><br />
(adsbygoogle = window.adsbygoogle || []).push({});<br />
</script></p>
<p><script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<!-- Article Bottom Ad --><br />
<ins class="adsbygoogle" style="display: inline-block; width: 728px; height: 90px;" data-ad-client="ca-pub-3490466616595796" data-ad-slot="7921456462"></ins><br />
<script><br />
(adsbygoogle = window.adsbygoogle || []).push({});<br />
</script></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-58998" class="share-twitter sd-button share-icon" href="https://madriverunion.com/letters-to-the-editor-february-17-2021/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-end"></li></ul></div></div></div>			</div><!-- .entry-content -->

	        <div class="entry-action">
            <div class="social-action" data-nonce="c716615ba5">
                <span class="title-action">Sharing</span>
                <ul>
                    <li id="twitter-share" class="twitter" data-post-id="58998" data-nonce="48362c78d4"><i class="icon-twitter"></i><a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fmadriverunion.com%2Fletters-to-the-editor-february-17-2021%2F&amp;text=Letters%20to%20the%20Editor%2C%20February%2017%2C%202021">Twitter</a><span class="digit digit-twitter">0</span></li>
                    <li class="facebook"><i class="icon-facebook-sign"></i><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fmadriverunion.com%2Fletters-to-the-editor-february-17-2021%2F&amp;t=Letters%20to%20the%20Editor%2C%20February%2017%2C%202021" >Facebook</a><span class="digit digit-facebook">0</span></li>
                    <li class="google"><i class="icon-google-plus-sign"></i><a href="https://plus.google.com/share?url=https%3A%2F%2Fmadriverunion.com%2Fletters-to-the-editor-february-17-2021%2F" >Google +</a><span>0</span></li>
                    <li class="linkedin"><i class="icon-linkedin-sign"></i><a href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fmadriverunion.com%2Fletters-to-the-editor-february-17-2021%2F&amp;title=Letters%20to%20the%20Editor%2C%20February%2017%2C%202021&amp;summary=Non-extremist%20Christians%20still%20alive%2C%20well%20and%20around%20As%20a%20Presbyterian%20minister%20in%20McKinleyville%2C%20I%20feel%20compelled%20to%20respond%20to%20Gail%20Ledbetter%E2%80%99s%20%E2%80%9CChristians%20gone%20awry%E2%80%9D%20piece%20in%20last%20week%E2%80%99s%20Union.%20As%20with%20Jan%20Phelps%E2%80%99%20letter%20concerning%20religious%20hypocrisy%2C%20it%20might%20surprise%20Ms.%20Ledbetter%20that%20I%20agree%20with%20almost%20everything%20she%20and%20Ms.%20Phelps%20said%2C%20except%20for%3Ca%20href%3D%22https%3A%2F%2Fmadriverunion.com%2Fletters-to-the-editor-february-17-2021%2F%22%20title%3D%22Read%20more%22%20%3E...%3C%2Fa%3E">Linkedin</a><span class="digit digit-linkedin">active){li-icon[type=linkedin-bug][color=inverse] .background{fill</span></li>
                    <li class="email"><i class="icon-envelope-alt"></i><a href="/cdn-cgi/l/email-protection#36096543545c5355420b7a5342425344451304064259130406425e5313040673525f425944130475130406705354444357444f13040607011304751304060406040710575b460d5459524f0b5e424246451305771304701304705b5752445f40534443585f59581855595b1304705a5342425344451b42591b425e531b53525f4259441b505354444357444f1b07011b04060407130470">Email this article</a></li>
                                        <li class="print"><i class="icon-print"></i><a href="#" onclick="window.print();">Print this article</a></li>
                                    </ul>
            </div>

                            <div class="co-author">
                <span class="title-action">Authors</span>
                
                    <div class="author-info">
                        <img alt='' src='https://secure.gravatar.com/avatar/bf535201942314b455964ae40aec0404?s=96&#038;d=mm&#038;r=pg' srcset='https://secure.gravatar.com/avatar/bf535201942314b455964ae40aec0404?s=192&#038;d=mm&#038;r=pg 2x' class='avatar avatar-96 photo' height='96' width='96' loading='lazy'/>                        <a class="author-name" href="https://madriverunion.com/author/kevpod/" rel="author">Kevin Hoover</a></h2>
                    </div><!-- .author-info -->

                                </div>
            
                         <div class="tag-action">
                <span class="title-action">Tags</span>
                <span class="tags-links">
                    <a href="https://madriverunion.com/tag/letters-to-the-editor/" rel="tag">Letters to the Editor</a>                </span>
            </div>
                    </div>
    	
</article><!-- #post-58998 -->
		

	
					<div class="related-post">
					<h3>Related posts</h3>
					<div class="row-fluid">
						<div class="content-inner">
						
<article id="post-58827" class="row-fluid post-58827 post type-post status-publish format-standard has-post-thumbnail hentry category-opinion tag-letters-to-the-editor content-print">
        <div class="entry-thumbnail">
        <a href="https://madriverunion.com/letters-to-the-editor-february-10-2021/" title="Permalink to Letters to the Editor, February 10, 2021" rel="bookmark">
            
            <img width="230" height="153" src="https://madriverunion.com/wp-content/uploads/2020/09/463897461_sm-2-4050063-copy-230x153.jpg" class="attachment-medium size-medium wp-post-image" alt="Letters" loading="lazy" srcset="https://madriverunion.com/wp-content/uploads/2020/09/463897461_sm-2-4050063-copy-230x153.jpg 230w, https://madriverunion.com/wp-content/uploads/2020/09/463897461_sm-2-4050063-copy-640x426.jpg 640w, https://madriverunion.com/wp-content/uploads/2020/09/463897461_sm-2-4050063-copy-110x73.jpg 110w, https://madriverunion.com/wp-content/uploads/2020/09/463897461_sm-2-4050063-copy.jpg 960w" sizes="(max-width: 230px) 100vw, 230px" />        </a>
    </div>
    
    <div class="post-inner">
        <header class="entry-header">
            <h2 class="entry-title"><a href="https://madriverunion.com/letters-to-the-editor-february-10-2021/" title="Permalink to Letters to the Editor, February 10, 2021" rel="bookmark">Letters to the Editor, February 10, 2021</a>
            </h2>
        </header>
    </div>
</article>
<article id="post-58731" class="row-fluid post-58731 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-opinion tag-letters-to-the-editor tag-mckinleyville-high-school content-print">
        <div class="entry-thumbnail">
        <a href="https://madriverunion.com/letters-to-the-editor-february-3-2021/" title="Permalink to Letters to the Editor, February 3, 2021" rel="bookmark">
            
            <img width="230" height="153" src="https://madriverunion.com/wp-content/uploads/2020/09/463897461_sm-2-4050063-copy-230x153.jpg" class="attachment-medium size-medium wp-post-image" alt="Letters" loading="lazy" srcset="https://madriverunion.com/wp-content/uploads/2020/09/463897461_sm-2-4050063-copy-230x153.jpg 230w, https://madriverunion.com/wp-content/uploads/2020/09/463897461_sm-2-4050063-copy-640x426.jpg 640w, https://madriverunion.com/wp-content/uploads/2020/09/463897461_sm-2-4050063-copy-110x73.jpg 110w, https://madriverunion.com/wp-content/uploads/2020/09/463897461_sm-2-4050063-copy.jpg 960w" sizes="(max-width: 230px) 100vw, 230px" />        </a>
    </div>
    
    <div class="post-inner">
        <header class="entry-header">
            <h2 class="entry-title"><a href="https://madriverunion.com/letters-to-the-editor-february-3-2021/" title="Permalink to Letters to the Editor, February 3, 2021" rel="bookmark">Letters to the Editor, February 3, 2021</a>
            </h2>
        </header>
    </div>
</article>
<article id="post-58572" class="row-fluid post-58572 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-opinion tag-letters-to-the-editor content-print">
        <div class="entry-thumbnail">
        <a href="https://madriverunion.com/letters-to-the-editor-january-27-2021/" title="Permalink to Letters to the Editor, January 27, 2021" rel="bookmark">
            
            <img width="230" height="153" src="https://madriverunion.com/wp-content/uploads/2020/09/463897461_sm-2-4050063-copy-230x153.jpg" class="attachment-medium size-medium wp-post-image" alt="Letters" loading="lazy" srcset="https://madriverunion.com/wp-content/uploads/2020/09/463897461_sm-2-4050063-copy-230x153.jpg 230w, https://madriverunion.com/wp-content/uploads/2020/09/463897461_sm-2-4050063-copy-640x426.jpg 640w, https://madriverunion.com/wp-content/uploads/2020/09/463897461_sm-2-4050063-copy-110x73.jpg 110w, https://madriverunion.com/wp-content/uploads/2020/09/463897461_sm-2-4050063-copy.jpg 960w" sizes="(max-width: 230px) 100vw, 230px" />        </a>
    </div>
    
    <div class="post-inner">
        <header class="entry-header">
            <h2 class="entry-title"><a href="https://madriverunion.com/letters-to-the-editor-january-27-2021/" title="Permalink to Letters to the Editor, January 27, 2021" rel="bookmark">Letters to the Editor, January 27, 2021</a>
            </h2>
        </header>
    </div>
</article>			
						</div>
					</div>
				</div>
		
		
			

<div id="comments" class="comments-area">

		
	

	


		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/letters-to-the-editor-february-17-2021/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="https://madriverunion.com/wp-login.php?redirect_to=https%3A%2F%2Fmadriverunion.com%2Fletters-to-the-editor-february-17-2021%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	
</div><!-- #comments .comments-area -->
		</div>

  	
	    <div id="secondary" class="widget-area span3" role="complementary">
		<aside id="wp_sidebarlogin-3" class="widget widget_wp_sidebarlogin"><h3 class="widget-title">Login</h3><div class="sidebar-login-form">
		<form name="loginform" id="loginform" action="https://madriverunion.com/wp-login.php" method="post">
			
			<p class="login-username">
				<label for="user_login">Username</label>
				<input type="text" name="log" id="user_login" class="input" value="" size="20" />
			</p>
			<p class="login-password">
				<label for="user_pass">Password</label>
				<input type="password" name="pwd" id="user_pass" class="input" value="" size="20" />
			</p>
			
			<p class="login-remember"><label><input name="rememberme" type="checkbox" id="rememberme" value="forever" checked="checked" /> Remember Me</label></p>
			<p class="login-submit">
				<input type="submit" name="wp-submit" id="wp-submit" class="button button-primary" value="Log In" />
				<input type="hidden" name="redirect_to" value="http://madriverunion.com/category/premium/" />
			</p>
			
		</form><ul class="sidebar-login-links pagenav sidebar_login_links"><li class="lost_password-link"><a href="https://madriverunion.com/wp-login.php?action=lostpassword">Lost Password</a></li></ul></div></aside><aside id="text-25" class="widget widget_text">			<div class="textwidget"><p>If you don’t have an account you may subscribe directly below.</p>
<style type="text/css"> #ptp-15632 div.ptp-item-container{border-radius:0;padding:0;margin-left:0;margin-right:0}#ptp-15632 div.ptp-item-container div{margin:0}#ptp-15632 div.ptp-plan{border-top-right-radius:0;border-top-left-radius:0;font-size:1.5em;padding:.9375em 1.25em}#ptp-15632 div.ptp-price{font-size:1.75em;padding:.9375em 1.25em}#ptp-15632 div.ptp-cta{border-bottom-right-radius:0;border-bottom-left-radius:0;padding-top:1.25em;padding-bottom:1.25em}#ptp-15632 a.ptp-button{border-radius:0;font-size:1em;color:#fff;background-color:#c96236;border-bottom:#c93c00 4px solid;margin:0}#ptp-15632 a.ptp-button:hover{background-color:#c94d18}div#ptp-15632 .ptp-highlight a.ptp-button{color:#fff;background-color:#ca3c00;border-bottom:#c41300 4px solid}div#ptp-15632 .ptp-highlight a.ptp-button:hover{background-color:#c9683e}#ptp-15632 div.ptp-bullet-item{font-size:.875em;padding:.9375em .5em .9375em .5em}#ptp-15632 div.ptp-most-popular{border-radius:0;font-size:.75em}</style>
<div id="ptp-15632" class="ptp-pricing-table">
        <div class="ptp-col  ptp-highlight ptp-col-id-1"><div class="ptp-cta"><a class="ptp-button" id="ptp-15632-cta-1" href="http://madriverunion.com/subscription-options">Subscribe</a></div></div>
</div></div>
		</aside><aside id="text-30" class="widget widget_text"><h3 class="widget-title">Advertisements</h3>			<div class="textwidget"><a href="https://admissions.humboldt.edu/impaction"><img src="https://madriverunion.com/wp-content/uploads/2021/02/HSU_onlineAd_2.5x6.jpg" alt="" width="110" height="160" border="0"></a>


<a href="http://www.hwma.net"><img src=" https://madriverunion.com/wp-content/uploads/2020/08/HWMA-THIS-ONE-ERC-Recycling-Changes-08012020-2.jpg" alt="" width="110" height="160" border="0"></a>

<a href="https://www.arcatacabinet.com/products"><img src="https://madriverunion.com/wp-content/uploads/2020/07/ArcataCabinet.5.20.20.jpg" alt="" width="110" height="160" border="0"></a>

<a href="https://madriverunion.com/legal-advertising-fictitious-business-name-statements-name-changes-more/"><img src="https://madriverunion.com/wp-content/uploads/2019/02/LegalAd.webad_.Newjpg.jpg" alt="" width="110" height="160" border="0"></a>

<a href="https://madriverunion.com/summer-recreation-guide-2020/><img src="https://madriverunion.com/wp-content/uploads/2020/03/SummerRecGuide.2020-scaled.jpg" alt="" width="110" height="160" border="0"></a>











<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- First ad sidebar -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3490466616595796"
     data-ad-slot="3698236469"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>













<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- First ad sidebar -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3490466616595796"
     data-ad-slot="3698236469"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>



<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- First ad sidebar -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3490466616595796"
     data-ad-slot="3698236469"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>


<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- First ad sidebar -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3490466616595796"
     data-ad-slot="3698236469"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>


<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- First ad sidebar -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3490466616595796"
     data-ad-slot="3698236469"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</aside>
		<aside id="recent-posts-2" class="widget widget_recent_entries">
		<h3 class="widget-title">Recent Posts</h3>
		<ul>
											<li>
					<a href="https://madriverunion.com/humboldt-states-five-year-strategic-plan-unveiled/">Humboldt State&#8217;s five-year strategic plan unveiled</a>
									</li>
											<li>
					<a href="https://madriverunion.com/letters-to-the-editor-february-17-2021/" aria-current="page">Letters to the Editor, February 17, 2021</a>
									</li>
											<li>
					<a href="https://madriverunion.com/arcata-bottom-cannabis-project-comment-sought/">Arcata Bottom cannabis project comment sought</a>
									</li>
											<li>
					<a href="https://madriverunion.com/explosion-fire-destroy-bayview-street-home/">Explosion, fire destroy Bayview Street home</a>
									</li>
											<li>
					<a href="https://madriverunion.com/big-or-bigger-covid-19-surge-predicted/">COVID variants complicate planning</a>
									</li>
					</ul>

		</aside>	</div>
	<script type='text/javascript'>
	var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-58649125-1']);
_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
            </div>
         </div>
     </div>

    
    <!-- Footer -->
    <footer id="colophon" class="site-footer dark" role="contentinfo">
        <div class="container">

            <div id="site-tools">
                <div class="row">
                    <div class="span9"><ul class="breadcrumbs"><li itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="https://madriverunion.com"><span itemprop="title">Mad River Union</span></a> </li> <li itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="https://madriverunion.com/category/featured/"><span itemprop="title">Featured</span></a></li><li> Letters to the Editor, February 17, 2021</li></ul></div>
                                    </div>
            </div>

            
            <div class="footer-shadown"></div>
        </div>

        <div id="site-info" class="container">
            <div class="clearfix">
                <div class="copyright">
                    <p>Copyright &copy; 2014 by <a href="http://www.madriverunion.com" title="DW Focus" rel="nofollow">Mad River Union</a></p>
                    <p>All Rights Reserved</p>
                </div>
                <div class="logo">
                    <a class="small-logo" href="https://madriverunion.com/" title="Mad River Union" rel="home">Mad River Union</a>
                </div>
            </div>
        </div>
    </footer><!-- #colophon .site-footer -->
<a class="scroll-top" href="#masthead" title="Scroll to top">Top</a>
		<script type="text/javascript" alt='evo_map_styles'>
		/*<![CDATA[*/
		var gmapstyles = 'default';
		/* ]]> */
		</script>		
		
<script type="text/javascript">
    window._tpm = window._tpm || [];
    window._tpm['paywallID'] = '0'; 
    window._tpm['sandbox'] = false; 
    window._tpm['trackPageview'] = false; 
</script>

	<div style="display:none">
	<div class="grofile-hash-map-bf535201942314b455964ae40aec0404">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/madriverunion.com\/letters-to-the-editor-february-17-2021\/":58998};
	</script>
				<div class='evo_lightboxes' style='display:block'>					<div class='evo_lightbox eventcard eventon_events_list' id='' >
						<div class="evo_content_in">													
							<div class="evo_content_inin">
								<div class="evo_lightbox_content">
									<a class='evolbclose '>X</a>
									<div class='evo_lightbox_body eventon_list_event evo_pop_body evcal_eventcard'> </div>
								</div>
							</div>							
						</div>
					</div>
					</div><script type='text/javascript' src='https://madriverunion.com/wp-content/plugins/ditty-news-ticker/inc/static/js/swiped-events.min.js?ver=1.1.4' id='swiped-events-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.6.1/wp-includes/js/imagesloaded.min.js' id='imagesloaded-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.6.1/wp-includes/js/jquery/ui/effect.min.js' id='jquery-effects-core-js'></script>
<script type='text/javascript' id='ditty-news-ticker-js-extra'>
/* <![CDATA[ */
var mtphr_dnt_vars = {"is_rtl":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/plugins/ditty-news-ticker/inc/static/js/ditty-news-ticker.min.js?ver=1612289768' id='ditty-news-ticker-js'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/plugins/gabfire-widget-pack/js/jquery.tools.min.js?ver=5.6.1' id='jquerytools-js'></script>
<script type='text/javascript' src='//madriverunion.com/wp-content/plugins/eventON/assets/js/eventon_functions.js?ver=2.7.2' id='evcal_functions-js'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/plugins/eventON/assets/js/handlebars.js?ver=2.7.2' id='evo_handlebars-js'></script>
<script type='text/javascript' src='//madriverunion.com/wp-content/plugins/eventON/assets/js/jquery.mobile.min.js?ver=2.7.2' id='evo_mobile-js'></script>
<script type='text/javascript' src='//madriverunion.com/wp-content/plugins/eventON/assets/js/jquery.mousewheel.min.js?ver=2.7.2' id='evo_mouse-js'></script>
<script type='text/javascript' id='evcal_ajax_handle-js-extra'>
/* <![CDATA[ */
var the_ajax_script = {"ajaxurl":"https:\/\/madriverunion.com\/wp-admin\/admin-ajax.php","postnonce":"96544e51a6"};
/* ]]> */
</script>
<script type='text/javascript' src='//madriverunion.com/wp-content/plugins/eventON/assets/js/eventon_script.js?ver=2.7.2' id='evcal_ajax_handle-js'></script>
<script type='text/javascript' data-cfasync="false" src='https://madriverunion.com/wp-content/plugins/s2member/s2member-o.php?ws_plugin__s2member_js_w_globals=1&#038;qcABC=1&#038;ver=201225-201225-252523928' id='ws-plugin--s2member-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.6.1/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.6.1/wp-includes/js/dist/vendor/wp-polyfill.min.js' id='wp-polyfill-js'></script>
<script type='text/javascript' id='wp-polyfill-js-after'>
( 'fetch' in window ) || document.write( '<script src="https://madriverunion.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://madriverunion.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://madriverunion.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://madriverunion.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://madriverunion.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://madriverunion.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );
</script>
<script type='text/javascript' id='sidebar-login-js-extra'>
/* <![CDATA[ */
var sidebar_login_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","force_ssl_admin":"0","is_ssl":"1","i18n_username_required":"Please enter your username","i18n_password_required":"Please enter your password","error_class":"sidebar-login-error"};
/* ]]> */
</script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/plugins/sidebar-login/build/frontend.js?ver=39f7653913319f945fb39a83c9a25003' id='sidebar-login-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.4/_inc/build/sharedaddy/sharing.min.js' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			document.body.addEventListener( 'click', function ( event ) {
				if ( event.target && (
					event.target.matches && event.target.matches( 'a.share-twitter' ) ||
					event.target.msMatchesSelector && event.target.msMatchesSelector( 'a.share-twitter' )
				) ) {
					// If there's another sharing window open, close it.
					if ( typeof windowOpen !== 'undefined' ) {
						windowOpen.close();
					}
					windowOpen = window.open( event.target.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
					return false;
				}
			} );
</script>
		<script>
			jQuery( document ).ready( function($) {
							$( '#mtphr-dnt-12580' ).ditty_news_ticker({
					id : '12580',
					type : 'scroll',
					scroll_direction : 'left',
					scroll_speed : 6,
					scroll_pause : 0,
					scroll_spacing : 40,
					scroll_init : 0,
					scroll_init_delay : 2,
					rotate_type : 'slide_left',
					auto_rotate : 0,
					rotate_delay : 7,
					rotate_pause : 0,
					rotate_speed : 3,
					rotate_ease : 'linear',
					nav_reverse : 0,
					disable_touchswipe : 0,
					offset : 20,
					after_load : function( $ticker ) {
											},
					before_change : function( $ticker ) {
											},
					after_change : function( $ticker ) {
											}
				});
			 			});
		</script>
		<script src='https://stats.wp.com/e-202107.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.4',blog:'147660978',post:'58998',tz:'-8',srv:'madriverunion.com'} ]);
	_stq.push([ 'clickTrackerInit', '147660978', '58998' ]);
</script>
<script type="text/javascript">(function(){window['__CF$cv$params']={r:'6251cae249bb3853',m:'88bbf4d0c003eda9e937de0bd2d976d781c364c5-1613924404-1800-ASB9CfGN6uX9lXBfVgoHgtsj0obQop+m70G4JkoOqTu3DicNl3/QDAcQrfzAEaW0o6wPYTQB/OfeKMyspJPr49Nc1qvYDPuGPW8iNlSumlA9u9ENox8GK5C7qfsloExwFU1hBFteRmiVfCkVjhRV8VCO2HHuTeo+16PYkdb18bxE',s:[0x8fe2dda81f,0xab2d4a498c],}})();</script></body>
</html>