

<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" />
<meta content="width=device-width, initial-scale=1.0, user-scalable=no" name="viewport">
<meta name="google-site-verification" content="yFaDpIXoz-j5sCQSr6YC6Y8hdsu-3ea-T93cMXASqIU" />
<title>OBITUARY: Jeffrey Terry Edwards, Nov. 17, 1945 – July 10, 2021 | Mad River Union</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://madriverunion.com/xmlrpc.php" />
<!--[if lt IE 9]>
<script src="https://madriverunion.com/wp-content/themes/mru-focus/assets/js/html5.js" type="text/javascript"></script>
<![endif]-->
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//code.tinypass.com' />
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Mad River Union &raquo; Feed" href="https://madriverunion.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mad River Union &raquo; Comments Feed" href="https://madriverunion.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mad River Union &raquo; OBITUARY: Jeffrey Terry Edwards, Nov. 17, 1945 – July 10, 2021 Comments Feed" href="https://madriverunion.com/jeffrey-terry-edwards-nov-17-1945-july-10-2021/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/madriverunion.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='tp-sidebar-login-css'  href='https://madriverunion.com/wp-content/plugins/tt-sidebar-login-widget/assets/css/tt-sidebar-login.css?ver=5.8' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.8/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='fca-ept-layout1-style-css'  href='https://madriverunion.com/wp-content/plugins/easy-pricing-tables/assets/blocks/layout1/fca-ept-layout1.min.css?ver=5.8' type='text/css' media='all' />
<link rel='stylesheet' id='fca-ept-layout2-style-css'  href='https://madriverunion.com/wp-content/plugins/easy-pricing-tables/assets/blocks/layout2/fca-ept-layout2.min.css?ver=5.8' type='text/css' media='all' />
<link rel='stylesheet' id='ditty-news-ticker-font-css'  href='https://madriverunion.com/wp-content/plugins/ditty-news-ticker/inc/static/libs/fontastic/styles.css?ver=2.3.9' type='text/css' media='all' />
<link rel='stylesheet' id='ditty-news-ticker-css'  href='https://madriverunion.com/wp-content/plugins/ditty-news-ticker/inc/static/css/style.css?ver=1625003029' type='text/css' media='all' />
<link rel='stylesheet' id='gabfire-widget-css-css'  href='https://madriverunion.com/wp-content/plugins/gabfire-widget-pack/css/style.css?ver=5.8' type='text/css' media='all' />
<link rel='stylesheet' id='sidebar-login-css'  href='https://madriverunion.com/wp-content/plugins/sidebar-login/build/sidebar-login.css?ver=1603739335' type='text/css' media='all' />
<link rel='stylesheet' id='dw_focus_template-css'  href='https://madriverunion.com/wp-content/themes/mru-focus/assets/css/template.css?ver=5.8' type='text/css' media='all' />
<link rel='stylesheet' id='dw_focus_responsive-css'  href='https://madriverunion.com/wp-content/themes/mru-focus/assets/css/responsive.css?ver=5.8' type='text/css' media='all' />
<link rel='stylesheet' id='style-css'  href='https://madriverunion.com/wp-content/themes/mru-focus/style.css?ver=5.8' type='text/css' media='all' />
<link rel='stylesheet' id='print-style-css'  href='https://madriverunion.com/wp-content/themes/mru-focus/assets/css/print.css?ver=5.8' type='text/css' media='print' />
<link rel='stylesheet' id='dw-focus-qa-css'  href='https://madriverunion.com/wp-content/themes/mru-focus/dwqa-templates/style.css?ver=5.8' type='text/css' media='all' />
<link rel='stylesheet' id='evcal_google_fonts-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400%2C300%7COpen+Sans%3A700%2C400%2C400i%7CRoboto%3A700%2C400&#038;ver=5.8' type='text/css' media='screen' />
<link rel='stylesheet' id='evcal_cal_default-css'  href='//madriverunion.com/wp-content/plugins/eventON/assets/css/eventon_styles.css?ver=2.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='evo_font_icons-css'  href='//madriverunion.com/wp-content/plugins/eventON/assets/fonts/font-awesome.css?ver=2.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='eventon_dynamic_styles-css'  href='//madriverunion.com/wp-content/plugins/eventON/assets/css/eventon_dynamic_styles.css?ver=2.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='evo_fc_styles-css'  href='https://madriverunion.com/wp-content/plugins/eventon-full-cal/assets/fc_styles.css?ver=5.8' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/9.8.1/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/9.8.1/css/jetpack.css' type='text/css' media='all' />
<link rel='stylesheet' id='ws-plugin--s2member-css'  href='https://madriverunion.com/wp-content/plugins/s2member/s2member-o.php?ws_plugin__s2member_css=1&#038;qcABC=1&#038;ver=210526-210526-3601771760' type='text/css' media='all' />
<script type='text/javascript' src='https://code.tinypass.com/tpl/d1/tpm.js?ver=5.8' id='tpm.js-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/themes/mru-focus/assets/js/bootstrap.min.js?ver=5.8' id='bootstrap-js'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/themes/mru-focus/assets/js/jquery.infinitescroll.min.js?ver=5.8' id='infinitescroll-js'></script>
<script type='text/javascript' id='dw_focus-js-extra'>
/* <![CDATA[ */
var dw_focus = {"ajax_url":"https:\/\/madriverunion.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/themes/mru-focus/assets/js/custom.js?ver=5.8' id='dw_focus-js'></script>
<script type='text/javascript' src='//platform.twitter.com/widgets.js?ver=5.8' id='twitter-indent-js'></script>
<script type='text/javascript' id='single-social-js-extra'>
/* <![CDATA[ */
var dw_focus = {"ajax_url":"https:\/\/madriverunion.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/themes/mru-focus/assets/js/single-socials.js?ver=5.8' id='single-social-js'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/themes/mru-focus/assets/js/jquery.mouse.move.js?ver=5.8' id='mouse-move-js'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/themes/mru-focus/assets/js/jquery.swipe.js?ver=5.8' id='swipe-js'></script>
<link rel="https://api.w.org/" href="https://madriverunion.com/wp-json/" /><link rel="alternate" type="application/json" href="https://madriverunion.com/wp-json/wp/v2/posts/62147" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://madriverunion.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://madriverunion.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8" />
<link rel="canonical" href="https://madriverunion.com/jeffrey-terry-edwards-nov-17-1945-july-10-2021/" />
<link rel='shortlink' href='https://wp.me/p9ZzmG-gan' />
<link rel="alternate" type="application/json+oembed" href="https://madriverunion.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmadriverunion.com%2Fjeffrey-terry-edwards-nov-17-1945-july-10-2021%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://madriverunion.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmadriverunion.com%2Fjeffrey-terry-edwards-nov-17-1945-july-10-2021%2F&#038;format=xml" />
<style></style><meta property="og:title" content="OBITUARY: Jeffrey Terry Edwards, Nov. 17, 1945 – July 10, 2021" /><meta property="og:url" content="https://madriverunion.com/jeffrey-terry-edwards-nov-17-1945-july-10-2021/" /><meta property="og:image" content="https://madriverunion.com/wp-content/uploads/2021/08/Edwards.Obit_-110x140.png" /><meta property="og:description" content="He will be remembered for his kindness and for his willingness to help others in any way that he could.  No one was a stranger when it came to this trait.  "/>    <style type="text/css">
        
        
            </style>
    <link rel="shortcut icon" href="https://madriverunion.com/wp-content/themes/mru-focus/assets/img/favicon.ico">

<!-- EventON Version -->
<meta name="generator" content="EventON 2.7.2" />


<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="OBITUARY: Jeffrey Terry Edwards, Nov. 17, 1945 – July 10, 2021" />
<meta property="og:url" content="https://madriverunion.com/jeffrey-terry-edwards-nov-17-1945-july-10-2021/" />
<meta property="og:description" content="He will be remembered for his kindness and for his willingness to help others in any way that he could.  No one was a stranger when it came to this trait.  " />
<meta property="article:published_time" content="2021-08-12T16:49:01+00:00" />
<meta property="article:modified_time" content="2021-08-12T17:19:37+00:00" />
<meta property="og:site_name" content="Mad River Union" />
<meta property="og:image" content="https://madriverunion.com/wp-content/uploads/2021/08/Edwards.Obit_.png" />
<meta property="og:image:width" content="366" />
<meta property="og:image:height" content="467" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@madriverunion" />
<meta name="twitter:text:title" content="OBITUARY: Jeffrey Terry Edwards, Nov. 17, 1945 – July 10, 2021" />
<meta name="twitter:image" content="https://madriverunion.com/wp-content/uploads/2021/08/Edwards.Obit_.png?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-3490466616595796",
    enable_page_level_ads: true
  });
</script>
<script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head>
<body class="post-template-default single single-post postid-62147 single-format-standard desktop  not-login group-blog" >
	<header id="masthead" class="site-header" role="banner">
	    <div class="container">
	    	<div id="header">
	    		<div class="row">
	    			<div id="mtphr-dnt-12580" class="mtphr-dnt mtphr-dnt-12580 mtphr-dnt-default mtphr-dnt-scroll mtphr-dnt-scroll-left"><div class="mtphr-dnt-wrapper mtphr-dnt-clearfix"><h3 class="mtphr-dnt-title mtphr-dnt-inline-title"></h3><div class="mtphr-dnt-tick-container" style="padding-top:3px;padding-bottom:3px;"><div class="mtphr-dnt-tick-contents"><div style="height:20px;" class="mtphr-dnt-tick mtphr-dnt-default-tick mtphr-dnt-clearfix "><a href="http://madriverunion.com/marna-powell-awesomeness-at-stone-lagoon-benefit-for-dry-lagoon-saturday-nov-1/" target="_self">Subscribe to your local newspaper and support community journalism…</a></div><div style="height:20px;" class="mtphr-dnt-tick mtphr-dnt-default-tick mtphr-dnt-clearfix "><a href="http://crushallboxes.blogspot.com" target="_self">Authentic Arcata Ridge Trail markers available at Union office in Jacoby’s Storehouse…</a></div></div></div></div></div>	           		<div id="branding" class="span3 visible-desktop">
		                <h1>
		                	<a href="https://madriverunion.com/" title="Mad River Union" rel="home">
		                		Mad River Union		                	</a>
		                </h1>
		            </div>
		            		            <div id="sidebar-header" class="span9">
	            		<aside id="text-31" class="widget widget_text">			<div class="textwidget"></div>
		</aside>		            </div>
		            		        </div>
	        </div>
	        		            <div class="btn-group top-news">
				    	        <a class="dropdown-toggle" data-toggle="dropdown" href="#">
            <span class="number">15</span>
            <span>Must read articles <i class="icon-caret-down"></i></span>
        </a>
                    <div class="top-news-inner">
                <ul class="dropdown-menu">
                    <div class="entry-meta">August 13, 2021</div>

                    <div class="row-fluid">
                        <ul>
                            <li class="has-thumbnail first">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/%e2%80%8bcovid-cases-hospitalizations-at-all-time-highs/" title="​COVID cases, hospitalizations at all-time highs"><img width="40" height="19" src="https://madriverunion.com/wp-content/uploads/2021/04/APD-DHHS-110x51.jpg" class="attachment-40x40 size-40x40 wp-post-image" alt="" loading="lazy" srcset="https://madriverunion.com/wp-content/uploads/2021/04/APD-DHHS-110x51.jpg 110w, https://madriverunion.com/wp-content/uploads/2021/04/APD-DHHS-230x107.jpg 230w, https://madriverunion.com/wp-content/uploads/2021/04/APD-DHHS-640x298.jpg 640w, https://madriverunion.com/wp-content/uploads/2021/04/APD-DHHS.jpg 1074w" sizes="(max-width: 40px) 100vw, 40px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/%e2%80%8bcovid-cases-hospitalizations-at-all-time-highs/" title="​COVID cases, hospitalizations at all-time highs"> ​COVID cases, hospitalizations at all-time highs </a></div>
                </li>
                            <li class="has-thumbnail">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/bottoms-cell-tower-okd-second-poised-for-approval/" title="Bottoms cell tower OK’d, second poised for approval"><img width="22" height="40" src="https://madriverunion.com/wp-content/uploads/2021/08/ATT-110x196.jpg" class="attachment-40x40 size-40x40 wp-post-image" alt="" loading="lazy" srcset="https://madriverunion.com/wp-content/uploads/2021/08/ATT-110x196.jpg 110w, https://madriverunion.com/wp-content/uploads/2021/08/ATT-230x409.jpg 230w, https://madriverunion.com/wp-content/uploads/2021/08/ATT.jpg 600w" sizes="(max-width: 22px) 100vw, 22px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/bottoms-cell-tower-okd-second-poised-for-approval/" title="Bottoms cell tower OK’d, second poised for approval"> Bottoms cell tower OK’d, second poised for approval </a></div>
                </li>
                            <li class="has-thumbnail">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/survey-zoom-and-walks-to-scope-mckinleyville-transportation/" title="Survey, Zoom and walks to scope McKinleyville transportation"><img width="40" height="23" src="https://madriverunion.com/wp-content/uploads/2019/01/McKinleyville-sign-110x64.jpg" class="attachment-40x40 size-40x40 wp-post-image" alt="" loading="lazy" srcset="https://madriverunion.com/wp-content/uploads/2019/01/McKinleyville-sign-110x64.jpg 110w, https://madriverunion.com/wp-content/uploads/2019/01/McKinleyville-sign-230x133.jpg 230w, https://madriverunion.com/wp-content/uploads/2019/01/McKinleyville-sign-768x445.jpg 768w, https://madriverunion.com/wp-content/uploads/2019/01/McKinleyville-sign-640x371.jpg 640w, https://madriverunion.com/wp-content/uploads/2019/01/McKinleyville-sign.jpg 1600w" sizes="(max-width: 40px) 100vw, 40px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/survey-zoom-and-walks-to-scope-mckinleyville-transportation/" title="Survey, Zoom and walks to scope McKinleyville transportation"> Survey, Zoom and walks to scope McKinleyville transportation </a></div>
                </li>
                            <li class="has-thumbnail first">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/vicious-variant-forces-culture-cancellations-stay-safe-and-rock-on/" title="Vicious variant forces culture cancellations – &#8216;stay safe and rock on&#8217;"><img width="40" height="31" src="https://madriverunion.com/wp-content/uploads/2021/08/War-Moth-110x84.jpg" class="attachment-40x40 size-40x40 wp-post-image" alt="" loading="lazy" srcset="https://madriverunion.com/wp-content/uploads/2021/08/War-Moth-110x84.jpg 110w, https://madriverunion.com/wp-content/uploads/2021/08/War-Moth-230x175.jpg 230w, https://madriverunion.com/wp-content/uploads/2021/08/War-Moth-640x486.jpg 640w, https://madriverunion.com/wp-content/uploads/2021/08/War-Moth.jpg 1400w" sizes="(max-width: 40px) 100vw, 40px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/vicious-variant-forces-culture-cancellations-stay-safe-and-rock-on/" title="Vicious variant forces culture cancellations – &#8216;stay safe and rock on&#8217;"> Vicious variant forces culture cancellations – &#8216;stay safe and rock on&#8217; </a></div>
                </li>
                            <li class="has-thumbnail">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/seven-live-classical-music-concerts-alongside-paintings-by-seven-local-artists-showcased-over-6/" title="Seven live classical music concerts, alongside paintings by seven local artists, showcased over 6"><img width="40" height="40" src="https://madriverunion.com/wp-content/uploads/2021/08/75ed29_babc00f928e94193b55cc67c18532f35mv2-110x110.jpg" class="attachment-40x40 size-40x40 wp-post-image" alt="" loading="lazy" srcset="https://madriverunion.com/wp-content/uploads/2021/08/75ed29_babc00f928e94193b55cc67c18532f35mv2-110x110.jpg 110w, https://madriverunion.com/wp-content/uploads/2021/08/75ed29_babc00f928e94193b55cc67c18532f35mv2-230x230.jpg 230w, https://madriverunion.com/wp-content/uploads/2021/08/75ed29_babc00f928e94193b55cc67c18532f35mv2.jpg 442w" sizes="(max-width: 40px) 100vw, 40px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/seven-live-classical-music-concerts-alongside-paintings-by-seven-local-artists-showcased-over-6/" title="Seven live classical music concerts, alongside paintings by seven local artists, showcased over 6"> Seven live classical music concerts, alongside paintings by seven local artists, showcased over 6 </a></div>
                </li>
                            <li class="">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/charles-leslie-mooney/" title="OBITUARY: Charles Leslie Mooney"></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/charles-leslie-mooney/" title="OBITUARY: Charles Leslie Mooney"> OBITUARY: Charles Leslie Mooney </a></div>
                </li>
                            <li class="has-thumbnail first">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/jeffrey-terry-edwards-nov-17-1945-july-10-2021/" title="OBITUARY: Jeffrey Terry Edwards, Nov. 17, 1945 – July 10, 2021"><img width="31" height="40" src="https://madriverunion.com/wp-content/uploads/2021/08/Edwards.Obit_-110x140.png" class="attachment-40x40 size-40x40 wp-post-image" alt="" loading="lazy" srcset="https://madriverunion.com/wp-content/uploads/2021/08/Edwards.Obit_-110x140.png 110w, https://madriverunion.com/wp-content/uploads/2021/08/Edwards.Obit_-230x293.png 230w, https://madriverunion.com/wp-content/uploads/2021/08/Edwards.Obit_.png 366w" sizes="(max-width: 31px) 100vw, 31px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/jeffrey-terry-edwards-nov-17-1945-july-10-2021/" title="OBITUARY: Jeffrey Terry Edwards, Nov. 17, 1945 – July 10, 2021"> OBITUARY: Jeffrey Terry Edwards, Nov. 17, 1945 – July 10, 2021 </a></div>
                </li>
                            <li class="has-thumbnail">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/hsu-to-build-800-units-of-housing-at-craftmans-mall/" title="HSU building 800-bed housing project at Craftsman&#8217;s Mall"><img width="34" height="40" src="https://madriverunion.com/wp-content/uploads/2020/11/CM-sign-110x131.jpg" class="attachment-40x40 size-40x40 wp-post-image" alt="" loading="lazy" srcset="https://madriverunion.com/wp-content/uploads/2020/11/CM-sign-110x131.jpg 110w, https://madriverunion.com/wp-content/uploads/2020/11/CM-sign-230x274.jpg 230w, https://madriverunion.com/wp-content/uploads/2020/11/CM-sign-640x761.jpg 640w, https://madriverunion.com/wp-content/uploads/2020/11/CM-sign.jpg 1200w" sizes="(max-width: 34px) 100vw, 34px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/hsu-to-build-800-units-of-housing-at-craftmans-mall/" title="HSU building 800-bed housing project at Craftsman&#8217;s Mall"> HSU building 800-bed housing project at Craftsman&#8217;s Mall </a></div>
                </li>
                            <li class="has-thumbnail">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/humboldt-state-polytechnic-update/" title="Humboldt State Polytechnic Update"><img width="30" height="40" src="https://madriverunion.com/wp-content/uploads/2021/08/Screen-Shot-2021-08-11-at-3.34.45-PM-110x145.png" class="attachment-40x40 size-40x40 wp-post-image" alt="" loading="lazy" srcset="https://madriverunion.com/wp-content/uploads/2021/08/Screen-Shot-2021-08-11-at-3.34.45-PM-110x145.png 110w, https://madriverunion.com/wp-content/uploads/2021/08/Screen-Shot-2021-08-11-at-3.34.45-PM-230x304.png 230w, https://madriverunion.com/wp-content/uploads/2021/08/Screen-Shot-2021-08-11-at-3.34.45-PM-640x846.png 640w, https://madriverunion.com/wp-content/uploads/2021/08/Screen-Shot-2021-08-11-at-3.34.45-PM.png 930w" sizes="(max-width: 30px) 100vw, 30px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/humboldt-state-polytechnic-update/" title="Humboldt State Polytechnic Update"> Humboldt State Polytechnic Update </a></div>
                </li>
                            <li class="has-thumbnail first">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/racing-season-continues-at-redwood-acres-with-limited-crowd-size/" title="Racing season continues at Redwood Acres with limited crowd size"><img width="40" height="27" src="https://madriverunion.com/wp-content/uploads/2021/08/Redwood-acres-110x73.jpg" class="attachment-40x40 size-40x40 wp-post-image" alt="" loading="lazy" srcset="https://madriverunion.com/wp-content/uploads/2021/08/Redwood-acres-110x73.jpg 110w, https://madriverunion.com/wp-content/uploads/2021/08/Redwood-acres-230x153.jpg 230w, https://madriverunion.com/wp-content/uploads/2021/08/Redwood-acres-640x427.jpg 640w, https://madriverunion.com/wp-content/uploads/2021/08/Redwood-acres-1536x1024.jpg 1536w, https://madriverunion.com/wp-content/uploads/2021/08/Redwood-acres.jpg 1606w" sizes="(max-width: 40px) 100vw, 40px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/racing-season-continues-at-redwood-acres-with-limited-crowd-size/" title="Racing season continues at Redwood Acres with limited crowd size"> Racing season continues at Redwood Acres with limited crowd size </a></div>
                </li>
                            <li class="has-thumbnail">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/kirstens-kitchen-theres-no-shame-in-craving-chili-in-august/" title="Kirsten&#8217;s Kitchen: There’s no shame in craving chili in August"><img width="40" height="36" src="https://madriverunion.com/wp-content/uploads/2021/08/Kirstens-chili-110x99.jpg" class="attachment-40x40 size-40x40 wp-post-image" alt="" loading="lazy" srcset="https://madriverunion.com/wp-content/uploads/2021/08/Kirstens-chili-110x99.jpg 110w, https://madriverunion.com/wp-content/uploads/2021/08/Kirstens-chili-230x208.jpg 230w, https://madriverunion.com/wp-content/uploads/2021/08/Kirstens-chili-640x579.jpg 640w, https://madriverunion.com/wp-content/uploads/2021/08/Kirstens-chili-1536x1389.jpg 1536w, https://madriverunion.com/wp-content/uploads/2021/08/Kirstens-chili.jpg 1778w" sizes="(max-width: 40px) 100vw, 40px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/kirstens-kitchen-theres-no-shame-in-craving-chili-in-august/" title="Kirsten&#8217;s Kitchen: There’s no shame in craving chili in August"> Kirsten&#8217;s Kitchen: There’s no shame in craving chili in August </a></div>
                </li>
                            <li class="has-thumbnail">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/letters-to-the-editor-wednesday-august-4-2021/" title="Letters to the Editor, Wednesday, August 4, 2021"><img width="40" height="37" src="https://madriverunion.com/wp-content/uploads/2021/08/Screen-Shot-2021-08-04-at-12.04.58-PM-110x101.png" class="attachment-40x40 size-40x40 wp-post-image" alt="" loading="lazy" srcset="https://madriverunion.com/wp-content/uploads/2021/08/Screen-Shot-2021-08-04-at-12.04.58-PM-110x101.png 110w, https://madriverunion.com/wp-content/uploads/2021/08/Screen-Shot-2021-08-04-at-12.04.58-PM-230x211.png 230w, https://madriverunion.com/wp-content/uploads/2021/08/Screen-Shot-2021-08-04-at-12.04.58-PM-640x588.png 640w, https://madriverunion.com/wp-content/uploads/2021/08/Screen-Shot-2021-08-04-at-12.04.58-PM.png 1380w" sizes="(max-width: 40px) 100vw, 40px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/letters-to-the-editor-wednesday-august-4-2021/" title="Letters to the Editor, Wednesday, August 4, 2021"> Letters to the Editor, Wednesday, August 4, 2021 </a></div>
                </li>
                            <li class="has-thumbnail first">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/arcata-police-log-poorly-camouflaged-lost-boys-act-out-stages-of-grief-over-party-blunder/" title="Arcata Police Log: Poorly camouflaged Lost Boys act out stages of grief over party blunder"><img width="40" height="30" src="https://madriverunion.com/wp-content/uploads/2020/08/Coplog-bongos-alone-2020-110x83.jpg" class="attachment-40x40 size-40x40 wp-post-image" alt="" loading="lazy" srcset="https://madriverunion.com/wp-content/uploads/2020/08/Coplog-bongos-alone-2020-110x83.jpg 110w, https://madriverunion.com/wp-content/uploads/2020/08/Coplog-bongos-alone-2020-230x173.jpg 230w, https://madriverunion.com/wp-content/uploads/2020/08/Coplog-bongos-alone-2020-640x480.jpg 640w, https://madriverunion.com/wp-content/uploads/2020/08/Coplog-bongos-alone-2020-1536x1152.jpg 1536w, https://madriverunion.com/wp-content/uploads/2020/08/Coplog-bongos-alone-2020.jpg 1600w" sizes="(max-width: 40px) 100vw, 40px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/arcata-police-log-poorly-camouflaged-lost-boys-act-out-stages-of-grief-over-party-blunder/" title="Arcata Police Log: Poorly camouflaged Lost Boys act out stages of grief over party blunder"> Arcata Police Log: Poorly camouflaged Lost Boys act out stages of grief over party blunder </a></div>
                </li>
                            <li class="has-thumbnail">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/moonlight-macumber-when-engaged-we-raise-arcata/" title="Moonlight Macumber: When Engaged, We Raise Arcata!"><img width="18" height="40" src="https://madriverunion.com/wp-content/uploads/2021/08/Screen-Shot-2021-08-04-at-11.57.45-AM-110x245.png" class="attachment-40x40 size-40x40 wp-post-image" alt="" loading="lazy" srcset="https://madriverunion.com/wp-content/uploads/2021/08/Screen-Shot-2021-08-04-at-11.57.45-AM-110x245.png 110w, https://madriverunion.com/wp-content/uploads/2021/08/Screen-Shot-2021-08-04-at-11.57.45-AM-230x512.png 230w, https://madriverunion.com/wp-content/uploads/2021/08/Screen-Shot-2021-08-04-at-11.57.45-AM.png 522w" sizes="(max-width: 18px) 100vw, 18px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/moonlight-macumber-when-engaged-we-raise-arcata/" title="Moonlight Macumber: When Engaged, We Raise Arcata!"> Moonlight Macumber: When Engaged, We Raise Arcata! </a></div>
                </li>
                            <li class="has-thumbnail">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/dogtown-mike-and-ace-good-gregarious-get-along-guys/" title="Dogtown: Mike and Ace – good, gregarious get-along guys"><img width="30" height="40" src="https://madriverunion.com/wp-content/uploads/2021/08/Ace-LR-110x147.jpg" class="attachment-40x40 size-40x40 wp-post-image" alt="" loading="lazy" srcset="https://madriverunion.com/wp-content/uploads/2021/08/Ace-LR-110x147.jpg 110w, https://madriverunion.com/wp-content/uploads/2021/08/Ace-LR-230x307.jpg 230w, https://madriverunion.com/wp-content/uploads/2021/08/Ace-LR-640x853.jpg 640w, https://madriverunion.com/wp-content/uploads/2021/08/Ace-LR-1152x1536.jpg 1152w, https://madriverunion.com/wp-content/uploads/2021/08/Ace-LR.jpg 1400w" sizes="(max-width: 30px) 100vw, 30px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/dogtown-mike-and-ace-good-gregarious-get-along-guys/" title="Dogtown: Mike and Ace – good, gregarious get-along guys"> Dogtown: Mike and Ace – good, gregarious get-along guys </a></div>
                </li>
              
                        </ul>
                    </div>
                </ul>
            </div>
            				    </div>
			
		    <div class="wrap-navigation">
		        <nav id="site-navigation" class="main-navigation navbar" role="navigation">
		            <div class="navbar-inner">
						<button class="btn btn-navbar" data-target=".nav-collapse" data-toggle="collapse"  type="button">
							<span class="icon-bar"></span>
							<span class="icon-bar"></span>
							<span class="icon-bar"></span>
						</button>

						<button class="collapse-search hidden-desktop" data-target=".search-collapse" data-toggle="collapse" >
							<i class="icon-search"></i>
						</button>

						<a class="small-logo hidden-desktop" rel="home" title="DW Focus" href="https://madriverunion.com/">DW Focus</a>
					
												<ul class="social-links visible-desktop">
																																																</ul><!-- End social links -->

						<div class="search-collapse collapse">
								<form method="get" name="searchForm" class="searchForm" action="https://madriverunion.com/" role="search">
		<input type="text" class="field" name="s" value="" placeholder="Search &hellip;" />
		<input type="submit" class="submit" name="submit" value="Search" />
	</form>
						</div>

						<div class="nav-collapse collapse">
							<ul id="menu-primary-menu" class="nav"><li id="menu-item-12432" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12432 color-none 0"><a href="https://madriverunion.com/category/featured/">Featured</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-12433" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12433 color-yellow 0"><a href="https://madriverunion.com/category/news/">News</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-12430" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12430 color-green 0"><a href="https://madriverunion.com/category/community/">Community</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-12434" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12434 color-orange 0"><a href="https://madriverunion.com/category/opinion/">Opinion</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-12431" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12431 color-violet 0"><a href="https://madriverunion.com/category/entertainment/">Entertainment</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-15879" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15879 color-none 0"><a href="https://madriverunion.com/category/premium/">Premium</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-12429" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-parent-item menu-parent-item menu-item-12429 0"><a href="https://madriverunion.com/about/">About the Union</a><i class="sub-menu-collapse icon-chevron-down hidden-desktop"></i>
<ul class="sub-menu">
	<li id="menu-item-12427" class="menu-item menu-item-type-post_type menu-item-object-page current-post-parent menu-item-12427 active 1"><a href="https://madriverunion.com/submission-guide/">Submission Guide</a></li>
	<li id="menu-item-40768" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40768 1"><a href="https://madriverunion.com/about/comment-policy/">Comment Policy</a></li>
	<li id="menu-item-12426" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12426 1"><a href="https://madriverunion.com/where-to-buy-the-mad-river-union/">Where To Buy</a></li>
	<li id="menu-item-12428" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12428 1"><a href="https://madriverunion.com/advertising/">Ad/Legal Rates and Sample Ads</a></li>
	<li id="menu-item-12425" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12425 1"><a href="https://madriverunion.com/contact-us/">Contact Us</a></li>
</ul>
</li>
<li id="menu-item-15865" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15865 0"><a href="https://madriverunion.com/subscription-options/">Subscribe</a></li>
</ul>						</div>	
		            </div>
		        </nav>

		        <div id="under-navigation" class="clearfix under-navigation">
		        	<div class="row-fluid">
		        				        				        		<!-- Under navigation positions ( breadcrum, twitter widgets) -->
			        	<div class="span9">
							        
        <aside id="dw_focus_news_headlines-5" class="widget dw_focus_headlines">        <h3 class="widget-title">New Stories</h3>        <div class="headlines" data-interval="5000">
            <ul>
                            <li><a href="https://madriverunion.com/%e2%80%8bcovid-cases-hospitalizations-at-all-time-highs/">​COVID cases, hospitalizations at all-time highs</a><span class="time_diff"> - 14 hours ago</span></li>
                            <li><a href="https://madriverunion.com/bottoms-cell-tower-okd-second-poised-for-approval/">Bottoms cell tower OK’d, second poised for approval</a><span class="time_diff"> - 14 hours ago</span></li>
                            <li><a href="https://madriverunion.com/survey-zoom-and-walks-to-scope-mckinleyville-transportation/">Survey, Zoom and walks to scope McKinleyville transportation</a><span class="time_diff"> - 15 hours ago</span></li>
                            <li><a href="https://madriverunion.com/vicious-variant-forces-culture-cancellations-stay-safe-and-rock-on/">Vicious variant forces culture cancellations – &#8216;stay safe and rock on&#8217;</a><span class="time_diff"> - 15 hours ago</span></li>
                            <li><a href="https://madriverunion.com/seven-live-classical-music-concerts-alongside-paintings-by-seven-local-artists-showcased-over-6/">Seven live classical music concerts, alongside paintings by seven local artists, showcased over 6</a><span class="time_diff"> - 17 hours ago</span></li>
                 
            </ul>
        </div>
        </aside><aside id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"></div></aside>						</div>
						
						<div class="span3 ">	<form method="get" name="searchForm" class="searchForm" action="https://madriverunion.com/" role="search">
		<input type="text" class="field" name="s" value="" placeholder="Search &hellip;" />
		<input type="submit" class="submit" name="submit" value="Search" />
	</form>
</div>
					</div>
			    </div>
		    </div>
	    </div>
	</header> <!-- End header -->

	<div id="main">
         <div class="container">
             <div class="row">


    <div id="primary" class="site-content span9">

	
		
<article id="post-62147" class="post-62147 post type-post status-publish format-standard has-post-thumbnail hentry category-community category-featured tag-obituary content-print">
	<header class="entry-header">
		<h1 class="entry-title">OBITUARY: Jeffrey Terry Edwards, Nov. 17, 1945 – July 10, 2021</h1>
		
		<div class="entry-meta">
			<ul class="post-categories">
	<li><a href="https://madriverunion.com/category/community/" rel="tag">Community</a></li>
	<li><a href="https://madriverunion.com/category/featured/" rel="tag">Featured</a></li></ul><time class="entry-date" datetime="2021-08-12T09:49:01-07:00" pubdate>19 hours ago</time>		</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

			<!-- <div class="entry-thumbnail">
			<img width="366" height="467" src="https://madriverunion.com/wp-content/uploads/2021/08/Edwards.Obit_.png" class="attachment- size- wp-post-image" alt="" loading="lazy" srcset="https://madriverunion.com/wp-content/uploads/2021/08/Edwards.Obit_.png 366w, https://madriverunion.com/wp-content/uploads/2021/08/Edwards.Obit_-230x293.png 230w, https://madriverunion.com/wp-content/uploads/2021/08/Edwards.Obit_-110x140.png 110w" sizes="(max-width: 366px) 100vw, 366px" />		</div> --> <!-- from content-single.php -->
	
	<div class="entry-content">
		<p>Jeffrey Terry Edwards was born Nov. 17, 1945 and left us on July 10, 2021. Our dear Uncle Jeffrey was a complicated person; a thinker, a planner, brilliant at times, challenging at others. He was funny and had great insight and he could be obstinate and righteous too.<span class="Apple-converted-space">   </span></p>
<p><a href="https://madriverunion.com/wp-content/uploads/2021/08/Edwards.Obit_.png"><img loading="lazy" class="alignleft size-medium wp-image-62192" src="https://madriverunion.com/wp-content/uploads/2021/08/Edwards.Obit_-230x293.png" alt="" width="230" height="293" srcset="https://madriverunion.com/wp-content/uploads/2021/08/Edwards.Obit_-230x293.png 230w, https://madriverunion.com/wp-content/uploads/2021/08/Edwards.Obit_-110x140.png 110w, https://madriverunion.com/wp-content/uploads/2021/08/Edwards.Obit_.png 366w" sizes="(max-width: 230px) 100vw, 230px" /></a>Jeffrey graduated<span class="Apple-converted-space">  </span>in 1963 from Palo Alto High School.<span class="Apple-converted-space">  </span>At Paly he was a multi-sport athlete and still holds the shot putt record to this day.<span class="Apple-converted-space">  </span>He went on to Stanford University on a pre-med path and played football with the varsity team as a freshman.<span class="Apple-converted-space">  </span>A bout with mononucleosis derailed his plans and then life and the ’60s got in the way of his college path. <span class="Apple-converted-space"> </span></p>
<p>He traveled around the U.S. and across Europe, lived as a nomad for many years performing odd jobs, living in forests and abandoned buildings.<span class="Apple-converted-space">  </span>He had quite a following in San Francisco during the summer of 1965 because he was a deep thinker and philosopher with charm and wit. <span class="Apple-converted-space"> </span></p>
<p>Always a fixer, he worked various jobs and was skilled at plumbing, electrical work, and construction in general.<span class="Apple-converted-space">  </span>He was a very talented tile setter and worked many years at Watercourse Way, a well known spa in Palo Alto, California, building waterways, water falls, and tubs of various designs. <span class="Apple-converted-space"> </span></p>
<p>He moved to Humboldt County in 1995 having bought a property in Arcata. He built his own living quarters and, always the planner, he insisted on reinforcing the foundation in anticipation of a second and third floor! He was well known at all of the local hardware stores for his frequent patronage, conversational style and unique perspective. <span class="Apple-converted-space"> </span></p>
<p>He was tough. He survived a myriad of economic and health challenges over his lifetime. As recently as the past several months his stamina was put to the test and he survived multiple surgeries and trials<span class="Apple-converted-space">  </span>albeit challenging his practitioners at every turn. <span class="Apple-converted-space"> </span></p>
<p>He will be remembered for his kindness and for his willingness to help others in any way that he could.<span class="Apple-converted-space">  </span>No one was a stranger when it came to this trait. <span class="Apple-converted-space"> </span></p>
<p>He is survived by his 3 siblings; Kenneth, Jonathan, and Joan, sisters-in-law Joann and Nubia, brother-in-law Hooper, his nieces Chelsea and Kaitlin, nephews Kenny, Dan, Carl, Daniel, Zeke, and Marley, and by the many people he touched and helped over the years. <span class="Apple-converted-space"> </span></p>
<p>A memorial in his honor will be held Sunday, Sept. 5, 2021 at 3 p.m. at his sister’s home at 1800 27th St.,<span class="Apple-converted-space">  </span>Arcata, California. <span class="Apple-converted-space"> </span></p>
<p><ins class="adsbygoogle" style="display: inline-block; width: 728px; height: 90px;" data-ad-client="ca-pub-3490466616595796" data-ad-slot="7921456462"></ins><br />
<script><br />
(adsbygoogle = window.adsbygoogle || []).push({});<br />
</script><br />
<ins class="adsbygoogle" style="display: inline-block; width: 336px; height: 280px;" data-ad-client="ca-pub-3490466616595796" data-ad-slot="3851720064"></ins><br />
<script><br />
(adsbygoogle = window.adsbygoogle || []).push({});<br />
</script></p>
<p><script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<!-- Article Bottom Ad --><br />
<ins class="adsbygoogle" style="display: inline-block; width: 728px; height: 90px;" data-ad-client="ca-pub-3490466616595796" data-ad-slot="7921456462"></ins><br />
<script><br />
(adsbygoogle = window.adsbygoogle || []).push({});<br />
</script></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-62147" class="share-twitter sd-button share-icon" href="https://madriverunion.com/jeffrey-terry-edwards-nov-17-1945-july-10-2021/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-end"></li></ul></div></div></div>			</div><!-- .entry-content -->

	        <div class="entry-action">
            <div class="social-action" data-nonce="e32484ef94">
                <span class="title-action">Sharing</span>
                <ul>
                    <li id="twitter-share" class="twitter" data-post-id="62147" data-nonce="4a97a70b04"><i class="icon-twitter"></i><a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fmadriverunion.com%2Fjeffrey-terry-edwards-nov-17-1945-july-10-2021%2F&amp;text=OBITUARY%3A%20Jeffrey%20Terry%20Edwards%2C%20Nov.%2017%2C%201945%20%E2%80%93%20July%2010%2C%202021">Twitter</a><span class="digit digit-twitter">0</span></li>
                    <li class="facebook"><i class="icon-facebook-sign"></i><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fmadriverunion.com%2Fjeffrey-terry-edwards-nov-17-1945-july-10-2021%2F&amp;t=OBITUARY%3A%20Jeffrey%20Terry%20Edwards%2C%20Nov.%2017%2C%201945%20%E2%80%93%20July%2010%2C%202021" >Facebook</a><span class="digit digit-facebook">0</span></li>
                    <li class="google"><i class="icon-google-plus-sign"></i><a href="https://plus.google.com/share?url=https%3A%2F%2Fmadriverunion.com%2Fjeffrey-terry-edwards-nov-17-1945-july-10-2021%2F" >Google +</a><span>0</span></li>
                    <li class="linkedin"><i class="icon-linkedin-sign"></i><a href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fmadriverunion.com%2Fjeffrey-terry-edwards-nov-17-1945-july-10-2021%2F&amp;title=OBITUARY%3A%20Jeffrey%20Terry%20Edwards%2C%20Nov.%2017%2C%201945%20%E2%80%93%20July%2010%2C%202021&amp;summary=He%20will%20be%20remembered%20for%20his%20kindness%20and%20for%20his%20willingness%20to%20help%20others%20in%20any%20way%20that%20he%20could.%C2%A0%20No%20one%20was%20a%20stranger%20when%20it%20came%20to%20this%20trait.%20%C2%A0">Linkedin</a><span class="digit digit-linkedin">active){li-icon[type=linkedin-bug][color=inverse] .background{fill</span></li>
                    <li class="email"><i class="icon-envelope-alt"></i><a href="/cdn-cgi/l/email-protection#4c731f392e26292f3871030e0518190d1e15697f0d697e7c06292a2a3e2935697e7c18293e3e35697e7c09283b2d3e283f697e0f697e7c02233a62697e7c7d7b697e0f697e7c7d757879697e7c69097e69747c69757f697e7c06392035697e7c7d7c697e0f697e7c7e7c7e7d6a2d213c772e232835712438383c3f697f0d697e0a697e0a212d283e253a293e3922252322622f2321697e0a26292a2a3e29356138293e3e356129283b2d3e283f6122233a617d7b617d7578796126392035617d7c617e7c7e7d697e0a">Email this article</a></li>
                                        <li class="print"><i class="icon-print"></i><a href="#" onclick="window.print();">Print this article</a></li>
                                    </ul>
            </div>

                            <div class="co-author">
                <span class="title-action">Authors</span>
                
                    <div class="author-info">
                        <img alt='' src='https://secure.gravatar.com/avatar/bf535201942314b455964ae40aec0404?s=96&#038;d=mm&#038;r=pg' srcset='https://secure.gravatar.com/avatar/bf535201942314b455964ae40aec0404?s=192&#038;d=mm&#038;r=pg 2x' class='avatar avatar-96 photo' height='96' width='96' loading='lazy'/>                        <a class="author-name" href="https://madriverunion.com/author/kevpod/" rel="author">Kevin Hoover</a></h2>
                    </div><!-- .author-info -->

                                </div>
            
                         <div class="tag-action">
                <span class="title-action">Tags</span>
                <span class="tags-links">
                    <a href="https://madriverunion.com/tag/obituary/" rel="tag">Obituary</a>                </span>
            </div>
                    </div>
    	
</article><!-- #post-62147 -->
		

	
					<div class="related-post">
					<h3>Related posts</h3>
					<div class="row-fluid">
						<div class="content-inner">
						
<article id="post-62148" class="row-fluid post-62148 post type-post status-publish format-standard hentry category-community category-featured tag-obituary content-print">
    
    <div class="post-inner">
        <header class="entry-header">
            <h2 class="entry-title"><a href="https://madriverunion.com/charles-leslie-mooney/" title="Permalink to OBITUARY: Charles Leslie Mooney" rel="bookmark">OBITUARY: Charles Leslie Mooney</a>
            </h2>
        </header>
    </div>
</article>
<article id="post-61421" class="row-fluid post-61421 post type-post status-publish format-standard has-post-thumbnail hentry category-community category-featured tag-obituary tag-tim-gray content-print">
        <div class="entry-thumbnail">
        <a href="https://madriverunion.com/obituary-timothy-gray-1957-2021/" title="Permalink to OBITUARY: Timothy Gray, 1957 &#8211; 2021" rel="bookmark">
            
            <img width="230" height="225" src="https://madriverunion.com/wp-content/uploads/2019/06/Tim-Gray-Emblem-230x225.jpg" class="attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://madriverunion.com/wp-content/uploads/2019/06/Tim-Gray-Emblem-230x225.jpg 230w, https://madriverunion.com/wp-content/uploads/2019/06/Tim-Gray-Emblem-110x108.jpg 110w, https://madriverunion.com/wp-content/uploads/2019/06/Tim-Gray-Emblem-768x753.jpg 768w, https://madriverunion.com/wp-content/uploads/2019/06/Tim-Gray-Emblem-640x627.jpg 640w, https://madriverunion.com/wp-content/uploads/2019/06/Tim-Gray-Emblem.jpg 1000w" sizes="(max-width: 230px) 100vw, 230px" />        </a>
    </div>
    
    <div class="post-inner">
        <header class="entry-header">
            <h2 class="entry-title"><a href="https://madriverunion.com/obituary-timothy-gray-1957-2021/" title="Permalink to OBITUARY: Timothy Gray, 1957 &#8211; 2021" rel="bookmark">OBITUARY: Timothy Gray, 1957 &#8211; 2021</a>
            </h2>
        </header>
    </div>
</article>
<article id="post-61422" class="row-fluid post-61422 post type-post status-publish format-standard has-post-thumbnail hentry category-community category-featured tag-obituaries tag-obituary content-print">
        <div class="entry-thumbnail">
        <a href="https://madriverunion.com/obituaries-thomas-delaware-price-elizabeth-ellen-price/" title="Permalink to OBITUARIES: Thomas Delaware Price, Elizabeth Ellen Price" rel="bookmark">
            
            <img width="230" height="123" src="https://madriverunion.com/wp-content/uploads/2021/07/TomBetty-obit-photo-230x123.jpg" class="attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://madriverunion.com/wp-content/uploads/2021/07/TomBetty-obit-photo-230x123.jpg 230w, https://madriverunion.com/wp-content/uploads/2021/07/TomBetty-obit-photo-640x343.jpg 640w, https://madriverunion.com/wp-content/uploads/2021/07/TomBetty-obit-photo-110x59.jpg 110w, https://madriverunion.com/wp-content/uploads/2021/07/TomBetty-obit-photo-1536x823.jpg 1536w, https://madriverunion.com/wp-content/uploads/2021/07/TomBetty-obit-photo.jpg 1600w" sizes="(max-width: 230px) 100vw, 230px" />        </a>
    </div>
    
    <div class="post-inner">
        <header class="entry-header">
            <h2 class="entry-title"><a href="https://madriverunion.com/obituaries-thomas-delaware-price-elizabeth-ellen-price/" title="Permalink to OBITUARIES: Thomas Delaware Price, Elizabeth Ellen Price" rel="bookmark">OBITUARIES: Thomas Delaware Price, Elizabeth Ellen Price</a>
            </h2>
        </header>
    </div>
</article>			
						</div>
					</div>
				</div>
		
		
			

<div id="comments" class="comments-area">

		
	

	


		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/jeffrey-terry-edwards-nov-17-1945-july-10-2021/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="https://madriverunion.com/wp-login.php?redirect_to=https%3A%2F%2Fmadriverunion.com%2Fjeffrey-terry-edwards-nov-17-1945-july-10-2021%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	
</div><!-- #comments .comments-area -->
		</div>

  	
	    <div id="secondary" class="widget-area span3" role="complementary">
		<aside id="wp_sidebarlogin-3" class="widget widget_wp_sidebarlogin"><h3 class="widget-title">Login</h3><div class="sidebar-login-form">
		<form name="loginform" id="loginform" action="https://madriverunion.com/wp-login.php" method="post">
			
			<p class="login-username">
				<label for="user_login">Username</label>
				<input type="text" name="log" id="user_login" class="input" value="" size="20" />
			</p>
			<p class="login-password">
				<label for="user_pass">Password</label>
				<input type="password" name="pwd" id="user_pass" class="input" value="" size="20" />
			</p>
			
			<p class="login-remember"><label><input name="rememberme" type="checkbox" id="rememberme" value="forever" checked="checked" /> Remember Me</label></p>
			<p class="login-submit">
				<input type="submit" name="wp-submit" id="wp-submit" class="button button-primary" value="Log In" />
				<input type="hidden" name="redirect_to" value="http://madriverunion.com/category/premium/" />
			</p>
			
		</form><ul class="sidebar-login-links pagenav sidebar_login_links"><li class="lost_password-link"><a href="https://madriverunion.com/wp-login.php?action=lostpassword">Lost Password</a></li></ul></div></aside><aside id="text-25" class="widget widget_text">			<div class="textwidget"><p>If you don’t have an account you may subscribe directly below.</p>
<style type="text/css"> #ptp-15632 div.ptp-item-container{border-radius:0;padding:0;margin-left:0;margin-right:0}#ptp-15632 div.ptp-item-container div{margin:0}#ptp-15632 div.ptp-plan{border-top-right-radius:0;border-top-left-radius:0;font-size:1.5em;padding:.9375em 1.25em}#ptp-15632 div.ptp-price{font-size:1.75em;padding:.9375em 1.25em}#ptp-15632 div.ptp-cta{border-bottom-right-radius:0;border-bottom-left-radius:0;padding-top:1.25em;padding-bottom:1.25em}#ptp-15632 a.ptp-button{border-radius:0;font-size:1em;color:#fff;background-color:#c96236;border-bottom:#c93c00 4px solid;margin:0}#ptp-15632 a.ptp-button:hover{background-color:#c94d18}div#ptp-15632 .ptp-highlight a.ptp-button{color:#fff;background-color:#ca3c00;border-bottom:#c41300 4px solid}div#ptp-15632 .ptp-highlight a.ptp-button:hover{background-color:#c9683e}#ptp-15632 div.ptp-bullet-item{font-size:.875em;padding:.9375em .5em .9375em .5em}#ptp-15632 div.ptp-most-popular{border-radius:0;font-size:.75em}</style>
<div id="ptp-15632" class="ptp-pricing-table">
        <div class="ptp-col  ptp-highlight ptp-col-id-1"><div class="ptp-cta"><a class="ptp-button" id="ptp-15632-cta-1" href="http://madriverunion.com/subscription-options">Subscribe</a></div></div>
</div></div>
		</aside><aside id="text-30" class="widget widget_text"><h3 class="widget-title">Advertisements</h3>			<div class="textwidget"><a href="http://www.hwma.net"><img src=" https://madriverunion.com/wp-content/uploads/2020/08/HWMA-THIS-ONE-ERC-Recycling-Changes-08012020-2.jpg" alt="" width="110" height="160" border="0"></a>

<a href="https://www.arcatacabinet.com/products"><img src="https://madriverunion.com/wp-content/uploads/2020/07/ArcataCabinet.5.20.20.jpg" alt="" width="110" height="160" border="0"></a>

<a href="https://madriverunion.com/legal-advertising-fictitious-business-name-statements-name-changes-more/"><img src="https://madriverunion.com/wp-content/uploads/2019/02/LegalAd.webad_.Newjpg.jpg" alt="" width="110" height="160" border="0"></a>













<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- First ad sidebar -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3490466616595796"
     data-ad-slot="3698236469"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>













<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- First ad sidebar -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3490466616595796"
     data-ad-slot="3698236469"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>



<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- First ad sidebar -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3490466616595796"
     data-ad-slot="3698236469"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>


<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- First ad sidebar -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3490466616595796"
     data-ad-slot="3698236469"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>


<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- First ad sidebar -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3490466616595796"
     data-ad-slot="3698236469"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</aside>
		<aside id="recent-posts-2" class="widget widget_recent_entries">
		<h3 class="widget-title">Recent Posts</h3>
		<ul>
											<li>
					<a href="https://madriverunion.com/%e2%80%8bcovid-cases-hospitalizations-at-all-time-highs/">​COVID cases, hospitalizations at all-time highs</a>
									</li>
											<li>
					<a href="https://madriverunion.com/bottoms-cell-tower-okd-second-poised-for-approval/">Bottoms cell tower OK’d, second poised for approval</a>
									</li>
											<li>
					<a href="https://madriverunion.com/survey-zoom-and-walks-to-scope-mckinleyville-transportation/">Survey, Zoom and walks to scope McKinleyville transportation</a>
									</li>
											<li>
					<a href="https://madriverunion.com/vicious-variant-forces-culture-cancellations-stay-safe-and-rock-on/">Vicious variant forces culture cancellations – &#8216;stay safe and rock on&#8217;</a>
									</li>
											<li>
					<a href="https://madriverunion.com/seven-live-classical-music-concerts-alongside-paintings-by-seven-local-artists-showcased-over-6/">Seven live classical music concerts, alongside paintings by seven local artists, showcased over 6</a>
									</li>
					</ul>

		</aside>	</div>
	<script type='text/javascript'>
	var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-58649125-1']);
_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
            </div>
         </div>
     </div>

    
    <!-- Footer -->
    <footer id="colophon" class="site-footer dark" role="contentinfo">
        <div class="container">

            <div id="site-tools">
                <div class="row">
                    <div class="span9"><ul class="breadcrumbs"><li itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="https://madriverunion.com"><span itemprop="title">Mad River Union</span></a> </li> <li itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="https://madriverunion.com/category/community/"><span itemprop="title">Community</span></a></li><li> OBITUARY: Jeffrey Terry Edwards, Nov. 17, 1945 – July 10, 2021</li></ul></div>
                                    </div>
            </div>

            
            <div class="footer-shadown"></div>
        </div>

        <div id="site-info" class="container">
            <div class="clearfix">
                <div class="copyright">
                    <p>Copyright &copy; 2014 by <a href="http://www.madriverunion.com" title="DW Focus" rel="nofollow">Mad River Union</a></p>
                    <p>All Rights Reserved</p>
                </div>
                <div class="logo">
                    <a class="small-logo" href="https://madriverunion.com/" title="Mad River Union" rel="home">Mad River Union</a>
                </div>
            </div>
        </div>
    </footer><!-- #colophon .site-footer -->
<a class="scroll-top" href="#masthead" title="Scroll to top">Top</a>
		<script type="text/javascript" alt='evo_map_styles'>
		/*<![CDATA[*/
		var gmapstyles = 'default';
		/* ]]> */
		</script>		
		
<script type="text/javascript">
    window._tpm = window._tpm || [];
    window._tpm['paywallID'] = '0'; 
    window._tpm['sandbox'] = false; 
    window._tpm['trackPageview'] = false; 
</script>

	<div style="display:none">
	<div class="grofile-hash-map-bf535201942314b455964ae40aec0404">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/madriverunion.com\/jeffrey-terry-edwards-nov-17-1945-july-10-2021\/":62147};
	</script>
				<div class='evo_lightboxes' style='display:block'>					<div class='evo_lightbox eventcard eventon_events_list' id='' >
						<div class="evo_content_in">													
							<div class="evo_content_inin">
								<div class="evo_lightbox_content">
									<a class='evolbclose '>X</a>
									<div class='evo_lightbox_body eventon_list_event evo_pop_body evcal_eventcard'> </div>
								</div>
							</div>							
						</div>
					</div>
					</div><script type='text/javascript' src='https://madriverunion.com/wp-content/plugins/ditty-news-ticker/inc/static/js/swiped-events.min.js?ver=1.1.4' id='swiped-events-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8/wp-includes/js/imagesloaded.min.js' id='imagesloaded-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8/wp-includes/js/jquery/ui/effect.min.js' id='jquery-effects-core-js'></script>
<script type='text/javascript' id='ditty-news-ticker-js-extra'>
/* <![CDATA[ */
var mtphr_dnt_vars = {"is_rtl":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/plugins/ditty-news-ticker/inc/static/js/ditty-news-ticker.min.js?ver=1625003029' id='ditty-news-ticker-js'></script>
<script type='text/javascript' src='//madriverunion.com/wp-content/plugins/eventON/assets/js/eventon_functions.js?ver=2.7.2' id='evcal_functions-js'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/plugins/eventON/assets/js/handlebars.js?ver=2.7.2' id='evo_handlebars-js'></script>
<script type='text/javascript' src='//madriverunion.com/wp-content/plugins/eventON/assets/js/jquery.mobile.min.js?ver=2.7.2' id='evo_mobile-js'></script>
<script type='text/javascript' src='//madriverunion.com/wp-content/plugins/eventON/assets/js/jquery.mousewheel.min.js?ver=2.7.2' id='evo_mouse-js'></script>
<script type='text/javascript' id='evcal_ajax_handle-js-extra'>
/* <![CDATA[ */
var the_ajax_script = {"ajaxurl":"https:\/\/madriverunion.com\/wp-admin\/admin-ajax.php","postnonce":"d94e11e6d3"};
/* ]]> */
</script>
<script type='text/javascript' src='//madriverunion.com/wp-content/plugins/eventON/assets/js/eventon_script.js?ver=2.7.2' id='evcal_ajax_handle-js'></script>
<script type='text/javascript' data-cfasync="false" src='https://madriverunion.com/wp-content/plugins/s2member/s2member-o.php?ws_plugin__s2member_js_w_globals=1&#038;qcABC=1&#038;ver=210526-210526-3601771760' id='ws-plugin--s2member-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8/wp-includes/js/dist/vendor/regenerator-runtime.min.js' id='regenerator-runtime-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8/wp-includes/js/dist/vendor/wp-polyfill.min.js' id='wp-polyfill-js'></script>
<script type='text/javascript' id='sidebar-login-js-extra'>
/* <![CDATA[ */
var sidebar_login_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","force_ssl_admin":"0","is_ssl":"1","i18n_username_required":"Please enter your username","i18n_password_required":"Please enter your password","error_class":"sidebar-login-error"};
/* ]]> */
</script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/plugins/sidebar-login/build/frontend.js?ver=39f7653913319f945fb39a83c9a25003' id='sidebar-login-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.8.1/_inc/build/sharedaddy/sharing.min.js' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
</script>
		<script>
			jQuery( document ).ready( function($) {
							$( '#mtphr-dnt-12580' ).ditty_news_ticker({
					id : '12580',
					type : 'scroll',
					scroll_direction : 'left',
					scroll_speed : 6,
					scroll_pause : 0,
					scroll_spacing : 40,
					scroll_init : 0,
					scroll_init_delay : 2,
					rotate_type : 'slide_left',
					auto_rotate : 0,
					rotate_delay : 7,
					rotate_pause : 0,
					rotate_speed : 3,
					rotate_ease : 'linear',
					nav_reverse : 0,
					disable_touchswipe : 0,
					offset : 20,
					after_load : function( $ticker ) {
											},
					before_change : function( $ticker ) {
											},
					after_change : function( $ticker ) {
											}
				});
			 			});
		</script>
		<script src='https://stats.wp.com/e-202132.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.8.1',blog:'147660978',post:'62147',tz:'-7',srv:'madriverunion.com'} ]);
	_stq.push([ 'clickTrackerInit', '147660978', '62147' ]);
</script>
<script type="text/javascript">(function(){window['__CF$cv$params']={r:'67e19456382a5ae1',m:'0c79ffb8370e0027511ad809aa9f646efcc68e6c-1628853892-1800-AWHdZsVM5baEZCPZpkcLFbqwkNjjGC9UN3q+9FPFe+O+OkJLmXzParFg/7EcBowkHossxm5epoHPpis6mVIeHmrUQu/AZ9mQg0dbNPsSPJetn+hh/rrjpH4OcxwU5kbbxBqzelk3donwv+Ey4cN5r50/+7Ge1RIipXHU8WqIHpdv3NMtxlVg5A400ldLPhfajQ==',s:[0x111fabdef7,0x42cd43e9b2],}})();</script></body>
</html>