

<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" />
<meta content="width=device-width, initial-scale=1.0, user-scalable=no" name="viewport">
<meta name="google-site-verification" content="yFaDpIXoz-j5sCQSr6YC6Y8hdsu-3ea-T93cMXASqIU" />
<title>AHS Class of &#8217;74 reunited | Mad River Union</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://madriverunion.com/xmlrpc.php" />
<!--[if lt IE 9]>
<script src="https://madriverunion.com/wp-content/themes/mru-focus/assets/js/html5.js" type="text/javascript"></script>
<![endif]-->
<link rel='dns-prefetch' href='//code.tinypass.com' />
<link rel='dns-prefetch' href='//madriverunion.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Mad River Union &raquo; Feed" href="https://madriverunion.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mad River Union &raquo; Comments Feed" href="https://madriverunion.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mad River Union &raquo; AHS Class of &#8217;74 reunited Comments Feed" href="https://madriverunion.com/ahs-class-of-74-reunited/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/madriverunion.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.2"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='tp-sidebar-login-css'  href='https://madriverunion.com/wp-content/plugins/tt-sidebar-login-widget/assets/css/tt-sidebar-login.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://madriverunion.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='ditty-news-ticker-font-css'  href='https://madriverunion.com/wp-content/plugins/ditty-news-ticker/legacy/static/libs/fontastic/styles.css?ver=2.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='ditty-news-ticker-css'  href='https://madriverunion.com/wp-content/plugins/ditty-news-ticker/legacy/static/css/style.css?ver=1564106043' type='text/css' media='all' />
<link rel='stylesheet' id='gabfire-widget-css-css'  href='https://madriverunion.com/wp-content/plugins/gabfire-widget-pack/css/style.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='sidebar-login-css'  href='https://madriverunion.com/wp-content/plugins/sidebar-login/assets/css/sidebar-login.css?ver=2.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='dw_focus_template-css'  href='https://madriverunion.com/wp-content/themes/mru-focus/assets/css/template.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='dw_focus_responsive-css'  href='https://madriverunion.com/wp-content/themes/mru-focus/assets/css/responsive.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='style-css'  href='https://madriverunion.com/wp-content/themes/mru-focus/style.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='print-style-css'  href='https://madriverunion.com/wp-content/themes/mru-focus/assets/css/print.css?ver=5.2.2' type='text/css' media='print' />
<link rel='stylesheet' id='dw-focus-qa-css'  href='https://madriverunion.com/wp-content/themes/mru-focus/dwqa-templates/style.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='evcal_google_fonts-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400%2C300%7COpen+Sans%3A700%2C400%2C400i%7CRoboto%3A700%2C400&#038;ver=5.2.2' type='text/css' media='screen' />
<link rel='stylesheet' id='evcal_cal_default-css'  href='//madriverunion.com/wp-content/plugins/eventON/assets/css/eventon_styles.css?ver=2.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='evo_font_icons-css'  href='//madriverunion.com/wp-content/plugins/eventON/assets/fonts/font-awesome.css?ver=2.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='eventon_dynamic_styles-css'  href='//madriverunion.com/wp-content/plugins/eventON/assets/css/eventon_dynamic_styles.css?ver=2.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='evo_fc_styles-css'  href='https://madriverunion.com/wp-content/plugins/eventon-full-cal/assets/fc_styles.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://madriverunion.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://madriverunion.com/wp-content/plugins/jetpack/css/jetpack.css?ver=7.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='ws-plugin--s2member-css'  href='https://madriverunion.com/wp-content/plugins/s2member/s2member-o.php?ws_plugin__s2member_css=1&#038;qcABC=1&#038;ver=190617-190617-497438754' type='text/css' media='all' />
<script type='text/javascript' src='https://code.tinypass.com/tpl/d1/tpm.js?ver=5.2.2'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/plugins/sidebar-login/assets/js/jquery.blockUI.min.js?ver=2.70'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sidebar_login_params = {"ajax_url":"https:\/\/madriverunion.com\/wp-admin\/admin-ajax.php","force_ssl_admin":"0","is_ssl":"1","i18n_username_required":"Please enter your username","i18n_password_required":"Please enter your password","error_class":"sidebar_login_error"};
/* ]]> */
</script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/plugins/sidebar-login/assets/js/sidebar-login.min.js?ver=2.7.3'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/themes/mru-focus/assets/js/bootstrap.min.js?ver=5.2.2'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/themes/mru-focus/assets/js/jquery.infinitescroll.min.js?ver=5.2.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var dw_focus = {"ajax_url":"https:\/\/madriverunion.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/themes/mru-focus/assets/js/custom.js?ver=5.2.2'></script>
<script type='text/javascript' src='//platform.twitter.com/widgets.js?ver=5.2.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var dw_focus = {"ajax_url":"https:\/\/madriverunion.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/themes/mru-focus/assets/js/single-socials.js?ver=5.2.2'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/themes/mru-focus/assets/js/jquery.mouse.move.js?ver=5.2.2'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/themes/mru-focus/assets/js/jquery.swipe.js?ver=5.2.2'></script>
<link rel='https://api.w.org/' href='https://madriverunion.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://madriverunion.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://madriverunion.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Companion Animal Foundation: The Powerpuff Kittens of Sunny Brae' href='https://madriverunion.com/companion-animal-foundation-the-powerpuff-kittens-of-sunny-brae/' />
<meta name="generator" content="WordPress 5.2.2" />
<link rel="canonical" href="https://madriverunion.com/ahs-class-of-74-reunited/" />
<link rel='shortlink' href='https://wp.me/p9ZzmG-d9h' />
<link rel="alternate" type="application/json+oembed" href="https://madriverunion.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmadriverunion.com%2Fahs-class-of-74-reunited%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://madriverunion.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmadriverunion.com%2Fahs-class-of-74-reunited%2F&#038;format=xml" />
<style></style><script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//madriverunion.com/?wordfence_lh=1&hid=9087E255A9BC9E3B1AA2EC68A05DE535');
</script>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<meta property="og:title" content="AHS Class of &#8217;74 reunited" /><meta property="og:url" content="https://madriverunion.com/ahs-class-of-74-reunited/" /><meta property="og:image" content="https://madriverunion.com/wp-content/uploads/2019/08/ClassRenunion-copy-110x66.jpg" /><meta property="og:description" content="CLASS of 1974 The Arcata High School Class of 1974 gathered for its 45th class reunion on July 26 and July 27. The classmates gathered at Plaza Grill on July 26, then held their reunion in the Plaza View Room in Jacoby’s Storehouse on July 27. The evening included dinner, entertainment, music and mingling as&lt;a href=&quot;https://madriverunion.com/ahs-class-of-74-reunited/&quot; title=&quot;Read more&quot; &gt;...&lt;/a&gt;"/>    <style type="text/css">
        
        
            </style>
    <link rel="shortcut icon" href="https://madriverunion.com/wp-content/themes/mru-focus/assets/img/favicon.ico">

<!-- EventON Version -->
<meta name="generator" content="EventON 2.7.2" />


<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="AHS Class of &#8217;74 reunited" />
<meta property="og:url" content="https://madriverunion.com/ahs-class-of-74-reunited/" />
<meta property="og:description" content="CLASS of 1974 The Arcata High School Class of 1974 gathered for its 45th class reunion on July 26 and July 27. The classmates gathered at Plaza Grill on July 26, then held their reunion in the Plaz…" />
<meta property="article:published_time" content="2019-08-11T16:58:09+00:00" />
<meta property="article:modified_time" content="2019-08-11T16:58:09+00:00" />
<meta property="og:site_name" content="Mad River Union" />
<meta property="og:image" content="https://madriverunion.com/wp-content/uploads/2019/08/ClassRenunion-copy.jpg" />
<meta property="og:image:width" content="900" />
<meta property="og:image:height" content="537" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@madriverunion" />
<meta name="twitter:text:title" content="AHS Class of &#8217;74 reunited" />
<meta name="twitter:image" content="https://madriverunion.com/wp-content/uploads/2019/08/ClassRenunion-copy.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-3490466616595796",
    enable_page_level_ads: true
  });
</script>
</head>
<body class="post-template-default single single-post postid-50547 single-format-standard desktop  not-login group-blog" >
	<header id="masthead" class="site-header" role="banner">
	    <div class="container">
	    	<div id="header">
	    		<div class="row">
	    			<div id="mtphr-dnt-12580" class="mtphr-dnt mtphr-dnt-12580 mtphr-dnt-default mtphr-dnt-scroll mtphr-dnt-scroll-left"><div class="mtphr-dnt-wrapper mtphr-dnt-clearfix"><h3 class="mtphr-dnt-title mtphr-dnt-inline-title"></h3><div class="mtphr-dnt-tick-container" style="padding-top:3px;padding-bottom:3px;"><div class="mtphr-dnt-tick-contents"><div style="height:20px;" class="mtphr-dnt-tick mtphr-dnt-default-tick mtphr-dnt-clearfix "><a href="http://madriverunion.com/marna-powell-awesomeness-at-stone-lagoon-benefit-for-dry-lagoon-saturday-nov-1/" target="_self">Subscribe to your local newspaper and support community journalism…</a></div><div style="height:20px;" class="mtphr-dnt-tick mtphr-dnt-default-tick mtphr-dnt-clearfix "><a href="http://crushallboxes.blogspot.com" target="_self">Authentic Arcata Ridge Trail markers available at Union office in Jacoby’s Storehouse…</a></div></div></div></div></div>	           		<div id="branding" class="span3 visible-desktop">
		                <h1>
		                	<a href="https://madriverunion.com/" title="Mad River Union" rel="home">
		                		Mad River Union		                	</a>
		                </h1>
		            </div>
		            		        </div>
	        </div>
	        		            <div class="btn-group top-news">
				    	        <a class="dropdown-toggle" data-toggle="dropdown" href="#">
            <span class="number">6</span>
            <span>New Articles today <i class="icon-caret-down"></i></span>
        </a>
                    <div class="top-news-inner">
                <ul class="dropdown-menu">
                    <div class="entry-meta">August 11, 2019</div>

                    <div class="row-fluid">
                        <ul>
                            <li class="has-thumbnail first">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/ahs-class-of-74-reunited/" title="AHS Class of &#8217;74 reunited"><img width="40" height="24" src="https://madriverunion.com/wp-content/uploads/2019/08/ClassRenunion-copy-110x66.jpg" class="attachment-40x40 size-40x40 wp-post-image" alt="" srcset="https://madriverunion.com/wp-content/uploads/2019/08/ClassRenunion-copy-110x66.jpg 110w, https://madriverunion.com/wp-content/uploads/2019/08/ClassRenunion-copy-230x137.jpg 230w, https://madriverunion.com/wp-content/uploads/2019/08/ClassRenunion-copy-640x382.jpg 640w, https://madriverunion.com/wp-content/uploads/2019/08/ClassRenunion-copy.jpg 900w" sizes="(max-width: 40px) 100vw, 40px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/ahs-class-of-74-reunited/" title="AHS Class of &#8217;74 reunited"> AHS Class of &#8217;74 reunited </a></div>
                </li>
                            <li class="">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/companion-animal-foundation-the-powerpuff-kittens-of-sunny-brae/" title="Companion Animal Foundation: The Powerpuff Kittens of Sunny Brae"></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/companion-animal-foundation-the-powerpuff-kittens-of-sunny-brae/" title="Companion Animal Foundation: The Powerpuff Kittens of Sunny Brae"> Companion Animal Foundation: The Powerpuff Kittens of Sunny Brae </a></div>
                </li>
                            <li class="has-thumbnail">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/dogtown-jax-an-adventurer-and-otis-a-distinguished-gentleman/" title="Dogtown: Jax, an adventurer, and Otis, a distinguished gentleman"><img width="35" height="40" src="https://madriverunion.com/wp-content/uploads/2019/08/Jax-in-pool-110x124.jpg" class="attachment-40x40 size-40x40 wp-post-image" alt="" srcset="https://madriverunion.com/wp-content/uploads/2019/08/Jax-in-pool-110x124.jpg 110w, https://madriverunion.com/wp-content/uploads/2019/08/Jax-in-pool-230x259.jpg 230w, https://madriverunion.com/wp-content/uploads/2019/08/Jax-in-pool-640x720.jpg 640w, https://madriverunion.com/wp-content/uploads/2019/08/Jax-in-pool.jpg 853w" sizes="(max-width: 35px) 100vw, 35px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/dogtown-jax-an-adventurer-and-otis-a-distinguished-gentleman/" title="Dogtown: Jax, an adventurer, and Otis, a distinguished gentleman"> Dogtown: Jax, an adventurer, and Otis, a distinguished gentleman </a></div>
                </li>
                            <li class="has-thumbnail first">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/arcata-scoping-new-revenue-sources/" title="Arcata scoping new revenue sources"><img width="40" height="26" src="https://madriverunion.com/wp-content/uploads/2019/02/city_of_arcata-seal-copy-110x71.jpg" class="attachment-40x40 size-40x40 wp-post-image" alt="" srcset="https://madriverunion.com/wp-content/uploads/2019/02/city_of_arcata-seal-copy-110x71.jpg 110w, https://madriverunion.com/wp-content/uploads/2019/02/city_of_arcata-seal-copy-230x148.jpg 230w, https://madriverunion.com/wp-content/uploads/2019/02/city_of_arcata-seal-copy-768x495.jpg 768w, https://madriverunion.com/wp-content/uploads/2019/02/city_of_arcata-seal-copy-640x413.jpg 640w, https://madriverunion.com/wp-content/uploads/2019/02/city_of_arcata-seal-copy.jpg 1600w" sizes="(max-width: 40px) 100vw, 40px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/arcata-scoping-new-revenue-sources/" title="Arcata scoping new revenue sources"> Arcata scoping new revenue sources </a></div>
                </li>
                            <li class="has-thumbnail">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/humboldt-takes-aim-at-unlicensed-growers-planco-oks-mck-subdivision/" title="Humboldt takes aim at unlicensed growers, Planco OKs McK subdivision"><img width="30" height="40" src="https://madriverunion.com/wp-content/uploads/2013/09/ye-olde-pot-leaf-110x146.jpg" class="attachment-40x40 size-40x40 wp-post-image" alt="" srcset="https://madriverunion.com/wp-content/uploads/2013/09/ye-olde-pot-leaf-110x146.jpg 110w, https://madriverunion.com/wp-content/uploads/2013/09/ye-olde-pot-leaf-230x306.jpg 230w, https://madriverunion.com/wp-content/uploads/2013/09/ye-olde-pot-leaf-640x851.jpg 640w" sizes="(max-width: 30px) 100vw, 30px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/humboldt-takes-aim-at-unlicensed-growers-planco-oks-mck-subdivision/" title="Humboldt takes aim at unlicensed growers, Planco OKs McK subdivision"> Humboldt takes aim at unlicensed growers, Planco OKs McK subdivision </a></div>
                </li>
                            <li class="has-thumbnail">
                    <div class="topnews-thumbnail"><a href="https://madriverunion.com/mckmac-forms-two-forward-looking-committees-for-beautification-and-betterment/" title="McKMAC forms two forward-looking committees for beautification and betterment"><img width="40" height="23" src="https://madriverunion.com/wp-content/uploads/2019/01/McKinleyville-sign-110x64.jpg" class="attachment-40x40 size-40x40 wp-post-image" alt="" srcset="https://madriverunion.com/wp-content/uploads/2019/01/McKinleyville-sign-110x64.jpg 110w, https://madriverunion.com/wp-content/uploads/2019/01/McKinleyville-sign-230x133.jpg 230w, https://madriverunion.com/wp-content/uploads/2019/01/McKinleyville-sign-768x445.jpg 768w, https://madriverunion.com/wp-content/uploads/2019/01/McKinleyville-sign-640x371.jpg 640w, https://madriverunion.com/wp-content/uploads/2019/01/McKinleyville-sign.jpg 1600w" sizes="(max-width: 40px) 100vw, 40px" /></a></div>
                    <div class="topnews-title"><a href="https://madriverunion.com/mckmac-forms-two-forward-looking-committees-for-beautification-and-betterment/" title="McKMAC forms two forward-looking committees for beautification and betterment"> McKMAC forms two forward-looking committees for beautification and betterment </a></div>
                </li>
              
                        </ul>
                    </div>
                </ul>
            </div>
            				    </div>
			
		    <div class="wrap-navigation">
		        <nav id="site-navigation" class="main-navigation navbar" role="navigation">
		            <div class="navbar-inner">
						<button class="btn btn-navbar" data-target=".nav-collapse" data-toggle="collapse"  type="button">
							<span class="icon-bar"></span>
							<span class="icon-bar"></span>
							<span class="icon-bar"></span>
						</button>

						<button class="collapse-search hidden-desktop" data-target=".search-collapse" data-toggle="collapse" >
							<i class="icon-search"></i>
						</button>

						<a class="small-logo hidden-desktop" rel="home" title="DW Focus" href="https://madriverunion.com/">DW Focus</a>
					
												<ul class="social-links visible-desktop">
																																																</ul><!-- End social links -->

						<div class="search-collapse collapse">
								<form method="get" name="searchForm" class="searchForm" action="https://madriverunion.com/" role="search">
		<input type="text" class="field" name="s" value="" placeholder="Search &hellip;" />
		<input type="submit" class="submit" name="submit" value="Search" />
	</form>
						</div>

						<div class="nav-collapse collapse">
							<ul id="menu-primary-menu" class="nav"><li id="menu-item-12432" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12432 color-none 0"><a href="https://madriverunion.com/category/featured/">Featured</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-12433" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12433 color-yellow 0"><a href="https://madriverunion.com/category/news/">News</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-12430" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12430 color-green 0"><a href="https://madriverunion.com/category/community/">Community</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-12434" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12434 color-orange 0"><a href="https://madriverunion.com/category/opinion/">Opinion</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-12431" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12431 color-violet 0"><a href="https://madriverunion.com/category/entertainment/">Entertainment</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-15879" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15879 color-none 0"><a href="https://madriverunion.com/category/premium/">Premium</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-12429" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-parent-item menu-parent-item menu-item-12429 0"><a href="https://madriverunion.com/about/">About the Union</a><i class="sub-menu-collapse icon-chevron-down hidden-desktop"></i>
<ul class="sub-menu">
	<li id="menu-item-12427" class="menu-item menu-item-type-post_type menu-item-object-page current-post-parent menu-item-12427 active 1"><a href="https://madriverunion.com/submission-guide/">Submission Guide</a></li>
	<li id="menu-item-40768" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40768 1"><a href="https://madriverunion.com/about/comment-policy/">Comment Policy</a></li>
	<li id="menu-item-12426" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12426 1"><a href="https://madriverunion.com/where-to-buy-the-mad-river-union/">Where To Buy</a></li>
	<li id="menu-item-12428" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12428 1"><a href="https://madriverunion.com/advertising/">Ad/Legal Rates and Sample Ads</a></li>
	<li id="menu-item-12425" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12425 1"><a href="https://madriverunion.com/contact-us/">Contact Us</a></li>
</ul>
</li>
<li id="menu-item-15865" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15865 0"><a href="https://madriverunion.com/subscription-options/">Subscribe</a></li>
</ul>						</div>	
		            </div>
		        </nav>

		        <div id="under-navigation" class="clearfix under-navigation">
		        	<div class="row-fluid">
		        				        				        		<!-- Under navigation positions ( breadcrum, twitter widgets) -->
			        	<div class="span9">
							        
        <aside id="dw_focus_news_headlines-5" class="widget dw_focus_headlines">        <h3 class="widget-title">New Stories</h3>        <div class="headlines" data-interval="5000">
            <ul>
                            <li><a href="https://madriverunion.com/ahs-class-of-74-reunited/">AHS Class of &#8217;74 reunited</a><span class="time_diff"> - 2 hours ago</span></li>
                            <li><a href="https://madriverunion.com/companion-animal-foundation-the-powerpuff-kittens-of-sunny-brae/">Companion Animal Foundation: The Powerpuff Kittens of Sunny Brae</a><span class="time_diff"> - 2 hours ago</span></li>
                            <li><a href="https://madriverunion.com/dogtown-jax-an-adventurer-and-otis-a-distinguished-gentleman/">Dogtown: Jax, an adventurer, and Otis, a distinguished gentleman</a><span class="time_diff"> - 3 hours ago</span></li>
                            <li><a href="https://madriverunion.com/arcata-scoping-new-revenue-sources/">Arcata scoping new revenue sources</a><span class="time_diff"> - 3 hours ago</span></li>
                            <li><a href="https://madriverunion.com/humboldt-takes-aim-at-unlicensed-growers-planco-oks-mck-subdivision/">Humboldt takes aim at unlicensed growers, Planco OKs McK subdivision</a><span class="time_diff"> - 3 hours ago</span></li>
                 
            </ul>
        </div>
        </aside><aside id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"></div></aside>						</div>
						
						<div class="span3 ">	<form method="get" name="searchForm" class="searchForm" action="https://madriverunion.com/" role="search">
		<input type="text" class="field" name="s" value="" placeholder="Search &hellip;" />
		<input type="submit" class="submit" name="submit" value="Search" />
	</form>
</div>
					</div>
			    </div>
		    </div>
	    </div>
	</header> <!-- End header -->

	<div id="main">
         <div class="container">
             <div class="row">


    <div id="primary" class="site-content span9">

	
		
<article id="post-50547" class="post-50547 post type-post status-publish format-standard has-post-thumbnail hentry category-community category-featured tag-arcata-high-school content-print">
	<header class="entry-header">
		<h1 class="entry-title">AHS Class of &#8217;74 reunited</h1>
		
		<div class="entry-meta">
			<ul class="post-categories">
	<li><a href="https://madriverunion.com/category/community/" rel="tag">Community</a></li>
	<li><a href="https://madriverunion.com/category/featured/" rel="tag">Featured</a></li></ul><time class="entry-date" datetime="2019-08-11T09:58:09-07:00" pubdate>2 hours ago</time>		</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

			<!-- <div class="entry-thumbnail">
			<img width="900" height="537" src="https://madriverunion.com/wp-content/uploads/2019/08/ClassRenunion-copy.jpg" class="attachment- size- wp-post-image" alt="" srcset="https://madriverunion.com/wp-content/uploads/2019/08/ClassRenunion-copy.jpg 900w, https://madriverunion.com/wp-content/uploads/2019/08/ClassRenunion-copy-110x66.jpg 110w, https://madriverunion.com/wp-content/uploads/2019/08/ClassRenunion-copy-230x137.jpg 230w, https://madriverunion.com/wp-content/uploads/2019/08/ClassRenunion-copy-640x382.jpg 640w" sizes="(max-width: 900px) 100vw, 900px" />		</div> --> <!-- from content-single.php -->
	
	<div class="entry-content">
		<p><a href="https://madriverunion.com/wp-content/uploads/2019/08/ClassRenunion-copy.jpg"><img class="aligncenter size-large wp-image-50566" src="https://madriverunion.com/wp-content/uploads/2019/08/ClassRenunion-copy-640x382.jpg" alt="" width="640" height="382" srcset="https://madriverunion.com/wp-content/uploads/2019/08/ClassRenunion-copy-640x382.jpg 640w, https://madriverunion.com/wp-content/uploads/2019/08/ClassRenunion-copy-110x66.jpg 110w, https://madriverunion.com/wp-content/uploads/2019/08/ClassRenunion-copy-230x137.jpg 230w, https://madriverunion.com/wp-content/uploads/2019/08/ClassRenunion-copy.jpg 900w" sizes="(max-width: 640px) 100vw, 640px" /></a></p>
<p><b>CLASS of 1974</b><b> The Arcata High School Class of 1974 gathered for its 45th class reunion on July 26 and July 27. The classmates gathered at Plaza Grill on July 26, then held their reunion in the Plaza View Room in Jacoby’s Storehouse on July 27. The evening included dinner, entertainment, music and mingling as the classmates caught up and remembered good times. When they graduated from high school, gas was around 42 cents a gallon, Stephen King had published his first book, Carrie, and pocket calculators were just starting to appear. <span class="Apple-converted-space">   </span></b>Photo courtesy Tony Gonsalves</p>
<p><ins class="adsbygoogle" style="display: inline-block; width: 728px; height: 90px;" data-ad-client="ca-pub-3490466616595796" data-ad-slot="7921456462"></ins><br />
<script><br />
(adsbygoogle = window.adsbygoogle || []).push({});<br />
</script><br />
<ins class="adsbygoogle" style="display: inline-block; width: 336px; height: 280px;" data-ad-client="ca-pub-3490466616595796" data-ad-slot="3851720064"></ins><br />
<script><br />
(adsbygoogle = window.adsbygoogle || []).push({});<br />
</script></p>
<p><script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<!-- Article Bottom Ad --><br />
<ins class="adsbygoogle" style="display: inline-block; width: 728px; height: 90px;" data-ad-client="ca-pub-3490466616595796" data-ad-slot="7921456462"></ins><br />
<script><br />
(adsbygoogle = window.adsbygoogle || []).push({});<br />
</script></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-50547" class="share-twitter sd-button share-icon" href="https://madriverunion.com/ahs-class-of-74-reunited/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-end"></li></ul></div></div></div>			</div><!-- .entry-content -->

	        <div class="entry-action">
            <div class="social-action" data-nonce="5600c52312">
                <span class="title-action">Sharing</span>
                <ul>
                    <li id="twitter-share" class="twitter" data-post-id="50547" data-nonce="186233597c"><i class="icon-twitter"></i><a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fmadriverunion.com%2Fahs-class-of-74-reunited%2F&amp;text=AHS%20Class%20of%20%26%238217%3B74%20reunited">Twitter</a><span class="digit digit-twitter">0</span></li>
                    <li class="facebook"><i class="icon-facebook-sign"></i><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fmadriverunion.com%2Fahs-class-of-74-reunited%2F&amp;t=AHS%20Class%20of%20%26%238217%3B74%20reunited" >Facebook</a><span class="digit digit-facebook">0</span></li>
                    <li class="google"><i class="icon-google-plus-sign"></i><a href="https://plus.google.com/share?url=https%3A%2F%2Fmadriverunion.com%2Fahs-class-of-74-reunited%2F" >Google +</a><span>0</span></li>
                    <li class="linkedin"><i class="icon-linkedin-sign"></i><a href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fmadriverunion.com%2Fahs-class-of-74-reunited%2F&amp;title=AHS%20Class%20of%20%26%238217%3B74%20reunited&amp;summary=CLASS%20of%201974%20The%20Arcata%20High%20School%20Class%20of%201974%20gathered%20for%20its%2045th%20class%20reunion%20on%20July%2026%20and%20July%2027.%20The%20classmates%20gathered%20at%20Plaza%20Grill%20on%20July%2026%2C%20then%20held%20their%20reunion%20in%20the%20Plaza%20View%20Room%20in%20Jacoby%E2%80%99s%20Storehouse%20on%20July%2027.%20The%20evening%20included%20dinner%2C%20entertainment%2C%20music%20and%20mingling%20as%3Ca%20href%3D%22https%3A%2F%2Fmadriverunion.com%2Fahs-class-of-74-reunited%2F%22%20title%3D%22Read%20more%22%20%3E...%3C%2Fa%3E">Linkedin</a><span class="digit digit-linkedin">1208px){#body-footer</span></li>
                    <li class="email"><i class="icon-envelope-alt"></i><a href="/cdn-cgi/l/email-protection#8cb3dff9eee6e9eff8b1cdc4dfa9bebccfe0edffffa9bebce3eaa9bebca9bebaa9bebfb4bebdbba9bfcebbb8a9bebcfee9f9e2e5f8e9e8aaede1fcb7eee3e8f5b1e4f8f8fcffa9bfcda9becaa9becae1ede8fee5fae9fef9e2e5e3e2a2efe3e1a9becaede4ffa1efe0edffffa1e3eaa1bbb8a1fee9f9e2e5f8e9e8a9beca">Email this article</a></li>
                                        <li class="print"><i class="icon-print"></i><a href="#" onclick="window.print();">Print this article</a></li>
                                    </ul>
            </div>

                            <div class="co-author">
                <span class="title-action">Authors</span>
                
                    <div class="author-info">
                        <img alt='' src='https://secure.gravatar.com/avatar/bf535201942314b455964ae40aec0404?s=96&#038;d=mm&#038;r=pg' srcset='https://secure.gravatar.com/avatar/bf535201942314b455964ae40aec0404?s=192&#038;d=mm&#038;r=pg 2x' class='avatar avatar-96 photo' height='96' width='96' />                        <a class="author-name" href="https://madriverunion.com/author/kevpod/" rel="author">Kevin Hoover</a></h2>
                    </div><!-- .author-info -->

                                </div>
            
                         <div class="tag-action">
                <span class="title-action">Tags</span>
                <span class="tags-links">
                    <a href="https://madriverunion.com/tag/arcata-high-school/" rel="tag">Arcata High School</a>                </span>
            </div>
                    </div>
    	
</article><!-- #post-50547 -->
		

	
					<div class="related-post">
					<h3>Related posts</h3>
					<div class="row-fluid">
						<div class="content-inner">
						
<article id="post-47154" class="row-fluid post-47154 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-arcata-high-school tag-california-energy-commission tag-cher-ae-heights-indian-community-of-the-trinidad-rancheria tag-city-of-trinidad-short-term-rental-committee tag-dows-prairie-grange tag-freedom-of-the-press tag-luffenholtz-creek tag-measure-o tag-northcoast-preparatory-academy-npa tag-npa tag-short-term-rentals tag-six-rivers-charter-high-school tag-trinidad-cemetery tag-trinidad-city-council tag-trinidad-lions-club tag-trinidad-lions-club-student-speakers-contest tag-trinidad-rancheria tag-trinidad-tidings tag-trinidad-town-hall-photovoltaic-project tag-trinidad-vacation-rentals tag-tsurai-study-area-management-team tag-vacation-rentals content-print">
        <div class="entry-thumbnail">
        <a href="https://madriverunion.com/trinidad-tidings-lions-and-rentals-and-lights/" title="Permalink to Trinidad Tidings: Lions and rentals and lights" rel="bookmark">
            
            <img width="230" height="376" src="https://madriverunion.com/wp-content/uploads/2016/04/Trinidad-Tidings-230x376.jpg" class="attachment-medium size-medium wp-post-image" alt="" srcset="https://madriverunion.com/wp-content/uploads/2016/04/Trinidad-Tidings-230x376.jpg 230w, https://madriverunion.com/wp-content/uploads/2016/04/Trinidad-Tidings-110x180.jpg 110w, https://madriverunion.com/wp-content/uploads/2016/04/Trinidad-Tidings.jpg 300w" sizes="(max-width: 230px) 100vw, 230px" />        </a>
    </div>
    
    <div class="post-inner">
        <header class="entry-header">
            <h2 class="entry-title"><a href="https://madriverunion.com/trinidad-tidings-lions-and-rentals-and-lights/" title="Permalink to Trinidad Tidings: Lions and rentals and lights" rel="bookmark">Trinidad Tidings: Lions and rentals and lights</a>
            </h2>
        </header>
    </div>
</article>
<article id="post-46189" class="row-fluid post-46189 post type-post status-publish format-standard has-post-thumbnail hentry category-community category-featured tag-advanced-placement-environmental-science tag-arcata-high-school tag-drought-response-outreach-program-for-schools-drops tag-ghd tag-inc tag-jolly-giant-creek tag-low-impact-development-lid tag-northern-humboldt-union-high-school-district tag-redwood-community-action-agency-rcaa tag-sinkin-the-stormwater-in-humboldt-county tag-state-water-resources-control-board tag-surfrider content-print">
        <div class="entry-thumbnail">
        <a href="https://madriverunion.com/ahs-students-are-sinkin-the-stormwater-in-humboldt-county/" title="Permalink to AHS students are &#8216;Sinkin’ the Stormwater in Humboldt County&#8217;" rel="bookmark">
            
            <img width="230" height="173" src="https://madriverunion.com/wp-content/uploads/2018/12/DSCN6129-230x173.jpg" class="attachment-medium size-medium wp-post-image" alt="" srcset="https://madriverunion.com/wp-content/uploads/2018/12/DSCN6129-230x173.jpg 230w, https://madriverunion.com/wp-content/uploads/2018/12/DSCN6129-110x83.jpg 110w, https://madriverunion.com/wp-content/uploads/2018/12/DSCN6129-768x576.jpg 768w, https://madriverunion.com/wp-content/uploads/2018/12/DSCN6129-640x480.jpg 640w, https://madriverunion.com/wp-content/uploads/2018/12/DSCN6129.jpg 1400w" sizes="(max-width: 230px) 100vw, 230px" />        </a>
    </div>
    
    <div class="post-inner">
        <header class="entry-header">
            <h2 class="entry-title"><a href="https://madriverunion.com/ahs-students-are-sinkin-the-stormwater-in-humboldt-county/" title="Permalink to AHS students are &#8216;Sinkin’ the Stormwater in Humboldt County&#8217;" rel="bookmark">AHS students are &#8216;Sinkin’ the Stormwater in Humboldt County&#8217;</a>
            </h2>
        </header>
    </div>
</article>
<article id="post-45863" class="row-fluid post-45863 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-arcata-high-school tag-arcata-police-department tag-shooting content-print">
        <div class="entry-thumbnail">
        <a href="https://madriverunion.com/arcata-police-charge-man-with-attempted-murder-over-shooting/" title="Permalink to Arcata Police charge man with attempted murder over shooting" rel="bookmark">
            
            <img width="230" height="230" src="https://madriverunion.com/wp-content/uploads/2017/03/APD-star-230x230.jpg" class="attachment-medium size-medium wp-post-image" alt="" srcset="https://madriverunion.com/wp-content/uploads/2017/03/APD-star-230x230.jpg 230w, https://madriverunion.com/wp-content/uploads/2017/03/APD-star-110x110.jpg 110w, https://madriverunion.com/wp-content/uploads/2017/03/APD-star.jpg 400w" sizes="(max-width: 230px) 100vw, 230px" />        </a>
    </div>
    
    <div class="post-inner">
        <header class="entry-header">
            <h2 class="entry-title"><a href="https://madriverunion.com/arcata-police-charge-man-with-attempted-murder-over-shooting/" title="Permalink to Arcata Police charge man with attempted murder over shooting" rel="bookmark">Arcata Police charge man with attempted murder over shooting</a>
            </h2>
        </header>
    </div>
</article>			
						</div>
					</div>
				</div>
		
		
			

<div id="comments" class="comments-area">

		
	

	


		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/ahs-class-of-74-reunited/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="https://madriverunion.com/wp-login.php?redirect_to=https%3A%2F%2Fmadriverunion.com%2Fahs-class-of-74-reunited%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	
</div><!-- #comments .comments-area -->
		</div>

  	
	    <div id="secondary" class="widget-area span3" role="complementary">
		<aside id="wp_sidebarlogin-3" class="widget widget_wp_sidebarlogin"><h3 class="widget-title">Login</h3>
		<form name="loginform" id="loginform" action="https://madriverunion.com/wp-login.php" method="post">
			
			<p class="login-username">
				<label for="user_login">Username</label>
				<input type="text" name="log" id="user_login" class="input" value="" size="20" />
			</p>
			<p class="login-password">
				<label for="user_pass">Password</label>
				<input type="password" name="pwd" id="user_pass" class="input" value="" size="20" />
			</p>
			
			<p class="login-remember"><label><input name="rememberme" type="checkbox" id="rememberme" value="forever" checked="checked" /> Remember Me</label></p>
			<p class="login-submit">
				<input type="submit" name="wp-submit" id="wp-submit" class="button button-primary" value="Login &rarr;" />
				<input type="hidden" name="redirect_to" value="http://madriverunion.com/category/premium/" />
			</p>
			
		</form><ul class="pagenav sidebar_login_links"><li class="lost_password-link"><a href="https://madriverunion.com/wp-login.php?action=lostpassword">Lost Password</a></li></ul></aside><aside id="text-25" class="widget widget_text">			<div class="textwidget"><p>If you don’t have an account you may subscribe directly below.</p>
<style type="text/css"> #ptp-15632 div.ptp-item-container{border-radius:0;padding:0;margin-left:0;margin-right:0}#ptp-15632 div.ptp-item-container div{margin:0}#ptp-15632 div.ptp-plan{border-top-right-radius:0;border-top-left-radius:0;font-size:1.5em;padding:.9375em 1.25em}#ptp-15632 div.ptp-price{font-size:1.75em;padding:.9375em 1.25em}#ptp-15632 div.ptp-cta{border-bottom-right-radius:0;border-bottom-left-radius:0;padding-top:1.25em;padding-bottom:1.25em}#ptp-15632 a.ptp-button{border-radius:0;font-size:1em;color:#fff;background-color:#c96236;border-bottom:#c93c00 4px solid;margin:0}#ptp-15632 a.ptp-button:hover{background-color:#c94d18}div#ptp-15632 .ptp-highlight a.ptp-button{color:#fff;background-color:#ca3c00;border-bottom:#c41300 4px solid}div#ptp-15632 .ptp-highlight a.ptp-button:hover{background-color:#c9683e}#ptp-15632 div.ptp-bullet-item{font-size:.875em;padding:.9375em .5em .9375em .5em}#ptp-15632 div.ptp-most-popular{border-radius:0;font-size:.75em}</style>
<div id="ptp-15632" class="ptp-pricing-table">
        <div class="ptp-col  ptp-highlight ptp-col-id-1"><div class="ptp-cta"><a class="ptp-button" id="ptp-15632-cta-1" href="http://madriverunion.com/subscription-options">Subscribe</a></div></div>
</div></div>
		</aside><aside id="text-30" class="widget widget_text"><h3 class="widget-title">Advertisements</h3>			<div class="textwidget"><a href="http://getreadyhumboldt.com/" target="_blank" rel="noopener noreferrer"><img src="https://madriverunion.com/wp-content/uploads/2018/11/Get-Ready-Humboldt-logo.jpg" alt="" width="110" height="160" border="0"></a>


<a href="https://madriverunion.com/arcata-summer-recreation-guide/"><img src="https://madriverunion.com/wp-content/uploads/2019/03/RECS2019-Guide-with-coversFINAL-1.jpg" alt="" width="110" height="160" border="0"></a>


<a href="https://madriverunion.com/legal-advertising-fictitious-business-name-statements-name-changes-more/"><img src="https://madriverunion.com/wp-content/uploads/2019/02/LegalAd.webad_.Newjpg.jpg" alt="" width="110" height="160" border="0"></a>

<a href="https://www.keet.org"><img src="<a href="https://madriverunion.com/2018-fall-activity-guide/"><img src="https://madriverunion.com/wp-content/uploads/2019/07/Keet.revised.7.17.19.jpg" alt="" width="110" height="160" border="0"></a>" alt="" width="110" height="160" border="0"></a>









<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- First ad sidebar -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3490466616595796"
     data-ad-slot="3698236469"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>













<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- First ad sidebar -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3490466616595796"
     data-ad-slot="3698236469"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>



<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- First ad sidebar -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3490466616595796"
     data-ad-slot="3698236469"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>


<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- First ad sidebar -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3490466616595796"
     data-ad-slot="3698236469"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>


<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- First ad sidebar -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3490466616595796"
     data-ad-slot="3698236469"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</aside>		<aside id="recent-posts-2" class="widget widget_recent_entries">		<h3 class="widget-title">Recent Posts</h3>		<ul>
											<li>
					<a href="https://madriverunion.com/ahs-class-of-74-reunited/">AHS Class of &#8217;74 reunited</a>
									</li>
											<li>
					<a href="https://madriverunion.com/companion-animal-foundation-the-powerpuff-kittens-of-sunny-brae/">Companion Animal Foundation: The Powerpuff Kittens of Sunny Brae</a>
									</li>
											<li>
					<a href="https://madriverunion.com/dogtown-jax-an-adventurer-and-otis-a-distinguished-gentleman/">Dogtown: Jax, an adventurer, and Otis, a distinguished gentleman</a>
									</li>
											<li>
					<a href="https://madriverunion.com/arcata-scoping-new-revenue-sources/">Arcata scoping new revenue sources</a>
									</li>
											<li>
					<a href="https://madriverunion.com/humboldt-takes-aim-at-unlicensed-growers-planco-oks-mck-subdivision/">Humboldt takes aim at unlicensed growers, Planco OKs McK subdivision</a>
									</li>
					</ul>
		</aside>	</div>
	<script type='text/javascript'>
	var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-58649125-1']);
_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
            </div>
         </div>
     </div>

    
    <!-- Footer -->
    <footer id="colophon" class="site-footer dark" role="contentinfo">
        <div class="container">

            <div id="site-tools">
                <div class="row">
                    <div class="span9"><ul class="breadcrumbs"><li itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="https://madriverunion.com"><span itemprop="title">Mad River Union</span></a> </li> <li itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="https://madriverunion.com/category/community/"><span itemprop="title">Community</span></a></li><li> AHS Class of &#8217;74 reunited</li></ul></div>
                                    </div>
            </div>

            
            <div class="footer-shadown"></div>
        </div>

        <div id="site-info" class="container">
            <div class="clearfix">
                <div class="copyright">
                    <p>Copyright &copy; 2014 by <a href="http://www.madriverunion.com" title="DW Focus" rel="nofollow">Mad River Union</a></p>
                    <p>All Rights Reserved</p>
                </div>
                <div class="logo">
                    <a class="small-logo" href="https://madriverunion.com/" title="Mad River Union" rel="home">Mad River Union</a>
                </div>
            </div>
        </div>
    </footer><!-- #colophon .site-footer -->
<a class="scroll-top" href="#masthead" title="Scroll to top">Top</a>
		<script type="text/javascript" alt='evo_map_styles'>
		/*<![CDATA[*/
		var gmapstyles = 'default';
		/* ]]> */
		</script>		
		
<script type="text/javascript">
    window._tpm = window._tpm || [];
    window._tpm['paywallID'] = '0'; 
    window._tpm['sandbox'] = false; 
    window._tpm['trackPageview'] = false; 
</script>

	<div style="display:none">
	<div class="grofile-hash-map-bf535201942314b455964ae40aec0404">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/madriverunion.com\/ahs-class-of-74-reunited\/":50547};
	</script>
				<div class='evo_lightboxes' style='display:block'>					<div class='evo_lightbox eventcard eventon_events_list' id='' >
						<div class="evo_content_in">													
							<div class="evo_content_inin">
								<div class="evo_lightbox_content">
									<a class='evolbclose '>X</a>
									<div class='evo_lightbox_body eventon_list_event evo_pop_body evcal_eventcard'> </div>
								</div>
							</div>							
						</div>
					</div>
					</div><script type='text/javascript' src='https://madriverunion.com/wp-content/plugins/ditty-news-ticker/legacy/static/js/jquery.touchSwipe.min.js?ver=2.2.4'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/plugins/ditty-news-ticker/legacy/static/js/jquery.easing.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/plugins/ditty-news-ticker/legacy/static/js/imagesloaded.pkgd.min.js?ver=4.1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mtphr_dnt_vars = {"is_rtl":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/plugins/ditty-news-ticker/legacy/static/js/ditty-news-ticker.min.js?ver=1564106043'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/plugins/gabfire-widget-pack/js/jquery.tools.min.js?ver=5.2.2'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201932'></script>
<script type='text/javascript' src='//madriverunion.com/wp-content/plugins/eventON/assets/js/eventon_functions.js?ver=2.7.2'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/plugins/eventON/assets/js/handlebars.js?ver=2.7.2'></script>
<script type='text/javascript' src='//madriverunion.com/wp-content/plugins/eventON/assets/js/jquery.mobile.min.js?ver=2.7.2'></script>
<script type='text/javascript' src='//madriverunion.com/wp-content/plugins/eventON/assets/js/jquery.mousewheel.min.js?ver=2.7.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var the_ajax_script = {"ajaxurl":"https:\/\/madriverunion.com\/wp-admin\/admin-ajax.php","postnonce":"7d877cf1f1"};
/* ]]> */
</script>
<script type='text/javascript' src='//madriverunion.com/wp-content/plugins/eventON/assets/js/eventon_script.js?ver=2.7.2'></script>
<script type='text/javascript' data-cfasync="false" src='https://madriverunion.com/wp-content/plugins/s2member/s2member-o.php?ws_plugin__s2member_js_w_globals=1&#038;qcABC=1&#038;ver=190617-190617-497438754'></script>
<script type='text/javascript' src='https://madriverunion.com/wp-includes/js/wp-embed.min.js?ver=5.2.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://madriverunion.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=7.5.3'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
</script>
		<script>
			jQuery( document ).ready( function($) {
							$( '#mtphr-dnt-12580' ).ditty_news_ticker({
					id : '12580',
					type : 'scroll',
					scroll_direction : 'left',
					scroll_speed : 6,
					scroll_pause : 0,
					scroll_spacing : 40,
					scroll_init : 0,
					rotate_type : 'slide_left',
					auto_rotate : 0,
					rotate_delay : 7,
					rotate_pause : 0,
					rotate_speed : 3,
					rotate_ease : 'linear',
					nav_reverse : 0,
					disable_touchswipe : 0,
					offset : 20,
					after_load : function( $ticker ) {
											},
					before_change : function( $ticker ) {
											},
					after_change : function( $ticker ) {
											}
				});
			 			});
		</script>
		<script type='text/javascript' src='https://stats.wp.com/e-201932.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.5.3',blog:'147660978',post:'50547',tz:'-7',srv:'madriverunion.com'} ]);
	_stq.push([ 'clickTrackerInit', '147660978', '50547' ]);
</script>
</body>
</html>